[BETA] Hubitat Package Manager

Hit the gear icon next to the app on the app page, scroll down to the bottom and hit remove.


I get the following error:

NullPointerException: Cannot get property 'repositories' on null object on line 3538 (prefSettings)

When doing what?

Think you might be in the wrong thread, this is a thread for Hubitat Package Manager, doesn't really have anything to do with Door locks.

Should start a new thread in support and say what app you are using to try and do this.


SUPER nice job on your Hubitat Package Manager!

See PayPal for a presie left yesterday!





Just wanted to take a moment to say thank you for putting this 'app' together, as well as thanks to the other devs who've gotten on board in support of this effort!

As someone brand new to the world of Hubitat (and HA period), I knew before I bought the C5 that I now own, that I would be taking this on board. (I tend to research as much as I can before I dive into what I expect will be ongoing, or long-term projects.)

It's already proving very useful, and after having read through the entirety of this thread, have also picked up on other apps that I fully expect to be useful in the days to come.


ok. i'm feeling pretty stupid here but i dont understand how to install this package manager. I looked at the first post in the thread and i see that it links to the github but then what? What are the steps to get it into HE?

Check posts 258 and 259.
Should be pretty easy, especially after you've done it 4 or 5 times. :wink:


i dont have the 'add user app' button. only the built in app button.. what am i missing?

Should show up after importing a user app. as below:

1 Like

Try post 95

It's what I used to put into the "apps code" section IIRC

Go to "apps code"

Then click on "new app"
Then "import"

Then put the website link in (from post 95)

1 Like

that was painful but it's done.
I had to go to the github, select the 'apps' folder, select the '...' button then select 'view raw' then cut and paste the url into hubitat. I guess it's all about the learning..


Could have pasted the raw link into the Import URL text box also

that would have been too easy. And if the link to the raw was in the first post, i missed it.


The link was in post 95, as mentioned above:

But you only have to do it once, unless you later add stuff that is not in HPM.

Welcome to the community!

i'm retarted. i'm skimming and not actually reading the posts. looking for the quick answer. lol now that i finally have everything migrated over i can slow down and figure out the rest of it out.
thanks for the welcome..

1 Like

Well, there are only just over a thousand of them. Read carefully, there will be a quiz. :wink:


I'll work on adding some installation instructions to the readme... just been too busy


Hi @dman2306 -

One note that you might want to add to your install instructions would be to delete all OLD user apps and drivers for any and all pieces of code for all packages that a user wants your Hubitat Package Manager (HPM) to install, setup and manage in the future.

It's commendable that HPM tries to match up old versions of code w/ newer but "I think" there are too many fragments and leftovers from previous versions to fully update a system cleanly.

I had older versions of the Kasa, Ecobee, Combined Presence Sensor, etc. apps and drivers that matched in HPM setup but didn't completely get updated and transferred to the new code as evidenced by various errors and issues in the logs.

In my case and to save time debugging, it was easier for me to just fully delete the offending old code (manually) from the system and start fresh w/ HPM.

This helps everyone - especially from a debugging standpoint.

My 2 cents :slight_smile:



I have the same general input. This app is a great step to the way systems should treat installs and deleted AKA Linux.
I have tried but can't resolve a WebCore issue along the same lines.
I installed WC before I discovered HPM. I ran HPM and matched up the packages. I later added the WC Storage component but I didn't do it through HPM as it wasn't second nature yet. Decided I didn't need it but HPM won't let go. Everytime I install a WC update it fails as it tries to update WC Storage even though I don't have it anymore. I re-added it to the app and tried Repair or Modify to remove the reference but no luck.
We need a way to edit the package refernences and manually correct the components?