Basic Z-Wave Tool

I may just be getting old, but although I can find lots of references to this app/driver in the forum, I can't seem to find the actual source thread for it where I would presume there would be instructions etc.

Is this it:

It's the closest thing I can find. I still don't really see the basic "how to use" stuff though.

Appreciate he help unfogging my brain! Thanks!

1 Like

The driver you’ve linked to is the Basic ZWave Tool. It comes with these instructions on its use:

and this warning:

2 Likes

It works like a champ though... I finally got around to programming in the auto-off timer for my Zen 17 relay (an otherwise hidden parameter), and it worked great.

For this tool, you'll need 3 things - Parameter #, Size, and desired Value - you cannot leave any of those fields blank. Prior to my tweak, I checked the Parameter Report (available thru this tool) for my parameter and noticed the Size field was as expected, so I thought I could leave it blank when I updated the desired Value. Nope, gotta fill out all 3 fields for the change to stick.

2 Likes

OK, thanks. Perhaps I misunderstand what the purpose of this app is. I know that It can let you tweak parameters. What I’m trying to use it for is to get reliable information on firmware levels of devices.

For example I have a zooz power strip that I got the latest version of firmware for from zooz. With or without this driver being loaded to read the device, it seems to be showing a newer version of firmware than what they even sent me so I don’t know how that could be possible. I guess I was expecting the perimeter fields and all that stuff to populate when I switch to the driver but everything is just blank. The information down at the bottom of the page when you load it is the same whether you use the correct driver for the device or this utility driver.

FTR, i’m not trying to change any parameters whatsoever. I’m just trying to get a baseline on my devices so I can update the firmware on them if appropriate.

This is probably not what mostly people use the Tool for, but the "Get Version Report" command should spit out a few things in "Logs," one of which should be the firmware version for most devices that report it. I think something like "firmware version" and "firmware subversion" are the pieces you could put together to do this (e.g., "1" and "5" would be 1.5 or, as it is often displayed, 1.05--but keep in mind that these are equivalent).

Many drivers also display this in the "Device Data" section at the bottom of the device page. However, some drivers don't update this after a firmware update, and there's no standard for how to force it to re-check (a refresh or configure might). So, I suppose the Tool is one way to always see for sure. If you're using a C-7 hub, the built-in Device Firmware Updater app can also tell you--just go to the page in it where you choose deivces, and pick the one you're interested it. The "firmware targets" dropdown will then show you the version(s), and you can just back out or close it before you update (you don't even need to upload any firmware files to get this far).

4 Likes

Does anyone know if I should type hex or decimal in the parameter input field when setting parameters?

Normally, I guess commands should use hex, but since the log messages from this driver displays the parameter values in decimal I don't feel sure, and I really don't know how much I might mess up my devices if I put the wrong numbers...

Decimal

i.e, for a parameter of length 1, use 0 .. 255

2 Likes

i used all ones on mine and it worked. You have to dry contact the the middle terminal and the one on the side of the tamper switch to make it register. These guys in this topic have the solution.

TLDR process to get dry contact working (at least for me)
#1 get the thing paired with the series 7 aeotec driver (hit include button then tamper button on device x3)
#2 get the driver for the zwave tool at (https://raw.githubusercontent.com/hubitat/HubitatPublic/master/examples/drivers/basicZWaveTool.groovy)
#3 copy the driver into drivers code and save it
#4 Change the device to use that basic zwave tool (in the device area)
#5 open the device and enter 1 in all three slots under set parameter and then click set parameter
#6 Then tap the tamper switch to wake the dumb thing up and take parameter change
#7 Change driver back to the aeotec series 7 one in devices section
#7 open the device back up and short the two terminals closest to the tamper switch and then feel joy in your heart as you watch the status change.

Useful link because the included instructions sucked.

Download the Hubitat app