Aqara Roller Shade Driver E1

Hello, does anyone have a driver for this : "Aqara Roller Shade Driver E1"

got it to work with this driver: [RELEASE] Aqara (B1) Smart Curtain Motor (ZNCLDJ11LM & ZNCLDJ12LM) Driver :+1:

Does your Aqara Roller Shade Driver E1 work well?
Iā€™m thinking of buying one of these or go for the IKEA.

Yup, working perfectly so far

1 Like

Hi mo.hesham. did you need to do anything specific to get the blind unit working with Hubitat? i can see the device via Zigbee and add it - but the driver doesnt appear to control the E1.

Thanks

Just installed one E1, and it works very well.
I can also control it with Alexa trough the HE Hub :slight_smile:

1 Like

Just installed the [Aqara (B1) Smart Curtain Driver Motor Driver]([RELEASE] Aqara (B1) Smart Curtain Motor (ZNCLDJ11LM & ZNCLDJ12LM) Driver)

And using it to control the Aqara Roller Shade Driver E1 (Model RSD-M01) and can get I to open/close blind, but most of the other controls do not appear to work - ie STOP

Is this normal for your usage of the E1 device using a B1 driver or is there something else going on?

Hi everyone, can someone help please? I had these working with this - [RELEASE] Aqara (B1) Smart Curtain Motor (ZNCLDJ11LM & ZNCLDJ12LM) Driver - it was listed as v1.0.2.1123. Now it is listed as v1.0.2.1123b and my E1 Rollers have stopped working. I am new to this and am a little confused. I have tried going back to the v1.0.2.1123 driver but it is not working for me now. Have tried repairing as well and a HE reboot.

I'm running v1.0.2.1123b and it works just fine; try removing the device and re-discovering it. if you can't discover it with Zigbee, try "Iris V1 Zigbee" Button

also make sure your Hubitat is updated

Hi, it's fully updated and have re-paired numerous times but no luck. I can't understand how it was working and then just stopped.

I started running into this issue now after upgrading to the latest firmware; I'll troubleshoot and let you know if I could find anything

for me it wasn't working when the position is set to any value below 3, the close command sets the position to 0 so that was not working too, I'm not sure if you're facing the same issue or not, but I've managed to add workaround in the driver code. I can share it if that's your issue

Set position 3 closes the blind, but open/close command and anything else other than stop doesn't work. That's some progress though,

Hi, it has stopped working completely now. Can you share your driver please?

Has anyone got the Aqara (B1) Smart Curtain Motor driver, mentioned above, for the Aqara Roller Shade Motor E1 working.
None of the options work for me.

I've installed the Driver - referenced as version v1.0.2.1123b.
The unit is found by HE. I'm running 2.3.1.138 on the hub.

Such a shame - physical buttons work a treat.

Any help, or a different driver would be greatly appreciated.

sorry for the late reply folks; this is the modified driver. it's working great for me
@thorpe.jez @JTT

Thanks @mo.hesham I will give it a try later on today. Better late than never! LOL

OK, so I have close working and set level between 3 and 97. Stop, open and anything else doesn't seem to do anything. It still says driver version being used is v1.0.2.1123b even though i removed the previous one and then installed the one above. Could this be an issue with my HUB?

Likewise - Thanks @mo.hesham
However I too have removed the device and the 1123b driver from HE, even rebooted hub before adding the 1123x code in "Drivers Code". The Shade motor is pairing correctly and I am changing the Driver to the "Zigbee - Aqara Smart Curtain Motor"... But nothing seems to work for me. I've done "Save Preferences" and tried Initialize & Refresh,etc
For me also the the Driver still shows as 1123b
image

How can I tell if anything is being communicated to the unit?

Any help would be gratefully received - I've bought another of these units and really would like to automate that also.

Download the Hubitat app