Aqara Cube not working


I am trying to get my new Aqara Cube to work on my new Hubitat.

I tried to find the driver mentioned here:

But did not find the driver. Link is not working. Then I found a Xiaomi Mi Cube driver. However my cube is not reacting when choosing this one.

Do you have an idea?

Thank you


I also tried to set my Cube as virtual device and then choose the Xiaomi Mi Cube driver. But also in this case, in the log no activity is listed :frowning:

I have one as well but will no longer allow Aqara crap on my mesh. It's just not worth inviting that gremlin in.

Works on Home Assistant supposedly. I have it there and it recognizes the various movements but can't figure out how to use it in an automation, lol.

Non-supported devices often don’t work very well. That said, I have one setup on a hub with my other problematic Zigbee devices and it works relatively well with the following driver:

1 Like

Mine is still working great on my HE7 along with everything else. I will try to help you get going but I am not an expert.

Here are some screenshots of my installation:

Driver download link:


what other products would you recommend?

I still need some:

  • Zigbee Motion Sensors
  • Zigbee Smart Plugs
  • Zigbee Buttons

Which devices would you recommend instead of Aqara?

Thank you!


Thank you all! I will try to get it working with your advices!

It works!!! Thank you so much!

I had to install this driver:

Thanks to your URL and screenshots I found it :slight_smile:


1 Like

Glad you are up and running.

Welcome to the club!

Lots of opinions on Zigbee devices. Since you are just starting out you have a perfect opportunity to stick with officially supported devices. Prefer Zigbee 3.0 compliant devices.

These are my gold-standard motion/temperature sensors since they were originally branded by Samsung but now cloned by Aeotec. They cost about double what the cheaper motion sensors cost but have always worked perfectly for me.

Aeotec SmartThings Motion Sensor, Zigbee, Magnetic Mounting, Works with Smart Home Hub and Compatible Zigbee Hubs

I have several of these Sonoff SNZB-03 motion sensors. They are one of the most inexpensive options - especially from eBay or Aliexpress in quantity with slow shipping. They have a reputation for sometimes giving false motion reports but I use one to turn on my workbench light and a few other locations where that is tolerable. They use an odd-size coin battery but Amazon has them, of course. I like the price but I am trending toward spending a little more up front and not having to fiddle later.

SONOFF SNZB-03 ZigBee Motion Sensor, Wireless Motion Detector Get Alerts or Trigger Lights to Turn on, SONOFF Zigbee Bridge Required

Check out the Third Reality brand on Amazon. They are well priced, follow ZigBee 3.0 exactly (no nonsense like Aqara, Ikea, Linkind), and best of all they use AAA batteries. After buying cell batteries and discovering half of them are dead right out of the box you will thank me. Trust me on that on.


I like these Zigbee plugs. Inexpensive and work well for me. Make sure you order the Zigbee model and not the WiFi model. They are not always clearly distinguished by Amazon vendors. They also function as Zigbee repeaters - which is important.

SONOFF S31 Lite 15A Zigbee Smart Plug ETL Certified, Works with SmartThings, and Amazon Echo Plus, Hub Needed for Amazon Alexa 2-Pack

I have two of the Third Realty motion sensors and they work well. AAA batteries are definitely a plus. Some have complained about the oblong form factor necessitated by the batteries.

THIRDREALITY Zigbee Motion Sensor 2 Pack, Zigbee Hub Required, Pet Friendly, Works with SmartThings, Aeotec, Hubitat or Echo Devices with Build-in Zigbee hub

Great thank you all!

I already got my first devices running in HE. It is such an amazing product... I am absolutely fascinated :slight_smile:

I am looking forward to be part of the HE community.



Thank you for the driver link.

I've managed to add it to the hubitat, but now I'm lost. Where can I configure the Aqara Cube buttons/actions?

There are several options, but I would recommend using the built-in “Button Controllers” app. This app will allow you to set actions for each of the available buttons.

Maybe I'm doing something wrong. Just for testing I've configured it for simple 7 button mode and made all buttons to turn on the light. And it don't seem to work

Have you confirmed that the button press was received? Does it show in the device page? I find my cube to be quite a bit finicky with Hubitat. Sometimes it works, sometimes not…