App type with namespace: hubitat and name: Rule-5.1 has parent type that does not match current app

I have a C-7 with firmware I ran into this today when attempting to make my first Rule Machine rule:

Error 404

App type with namespace: hubitat and name: Rule-5.1 has parent type that does not match current app

This issue has come up before with no clear solution. I tried all the suggestions in the comments with no luck.

The link it's sending me to is the following:


Can someone please tell me what I need to do to make this work? Rule Machine is the entire reason I bought this device.

Can you post some screenshots of the screen where you are attempting to create the rule from? I.e. where are you clicking, etc.

1 Like

Thanks, and when you say you have tried all the suggestions, what steps have you tried?

I saw some people have some success reverting to an earlier platform version, doing a soft-reset and then performing the platform upgrade again. I'm not suggesting you try it necessarily, I would prefer to let the Hubitat support or others more knowlegable than me chime in first, just wanted to see if you had tried this already.

1 Like

I tried reverting to the other platform version available, but it's so old that my ZWave devices don't work. I soft resetted on that version then updated again, didn't fix it. I tried a hard reset, but it didn't seem to delete everything which I thought was weird. Do I need to delete backups first?

I don't believe so, and wouldn't feel confident advising you on that anyway, I'd suggest waiting for support to reply. I was mostly wanting to capture a few more details for them when they get a chance to take a look at this for you.

1 Like

Out of interest, do you have an older version of RM installed at all? Earlier than 5.1? Typically it is displayed as "Legacy" in the Apps page,

1 Like

It says 1.0.4 but I have no idea if that's current or how to update it. I saw somewhere that the firmware updates supposedly also update the core apps, but I'm not 100% sure on that. If you know where I can get an update to try for RM please direct me!

Ah... Sorry, not that version. I could try and explain what I believe that version to represent, but I would possibly get it wrong :slight_smile: I at least know it is not what I was referring to when I mentioned 5.1.

Perhaps the easier question to ask is, in the Apps page, do you see something like this, with a Legacy App, or just Rule Machine.


I don't want to labour this point too much, because it is likely not the issue.

Just Rule Machine, no Legacy

Ok, cool. Just thought I'd check. Should probably leave it for the experts now, don't want to create too long a thread for them to read :slight_smile: Unless you have any other info you want to provide, don't hold back there, but I won't pepper you with too many more questions.



Since you have no rules yet, Have you tried removing the Rule Machine app and reinstalling it? Maybe even remove it, reboot, wait a few minutes, then install the app from the menu at the top.


@user7085, can you PM me the hub id? I'll take a look at the engineering logs.


Sent, thanks!

I'm having the same issue. A new C5 hub. Did the latest firmware update I added Rule Machine and get the error 404 when I try to make a new rule. Tried removing Rule machine, reboot, reinstall. No love. Any suggestions?

You will have to PM @gopher.ny your hub ID, I don't think a solution has been shared,

having the same issue, PM'd gopher ... hoping there's an easy fix for this, I'm dead in the water.

I too am facing this issue.


  • I have an New App with a definition{...} section that DOES NOT include a parent key.
  • I want to use app.addChildApp(...) to create child New App instances under multiple Existing Apps.
  • I expect instance(s) of New App to appear as a child of any Existing App in which an instance(s) is created.
  • Unfortunately, calls to app.addChildApp(...) get an error which reports New App as missing the parent key (in its definition {...} section).

I DO NOT HAVE a fix for the underlying issue.

I DO HAVE a workaround. Basically, I do the following:

Step 1 - Convert New App to a New Library

  • Set aside (remove) any #include directives from New Library, these are used below.

  • Set aside the definition {...}, it is used below.

  • Replace the definition {...} with library {...}, which has a similar structure

  • Set aside the preferences {...}, it is used below.

  • Leave all of your New App methods in New Library.
    Even the rendering | display functions can stay.

Step 2 - Create new Skinny Apps
The Skinny Apps will have names similar to New App.
For example: Incorporate the Parent App in the name.
Examples: NewAppW for parent W, NewAppX for parent X, ...

  • Add the original New App #include directives to each Skinny App.

  • Add the original New App definition {...} section to each Skinny App adding an appropriate parent key - e.g., parent: 'X', parent: 'Y', ...

  • Add the original New App preferences {...} section from New App.

All methods in Skinny App are resolved from the #include of New Library. Optionally, you can tweak method names or behaviors if desired.

Step 3 - Cleanup and Installations

  • Remove the original New App

  • Add the New Library

  • Add the new Skinny Apps

I too am having this issue. I recently replaced my C5 with a C7 I had as a spare. I would like to get my Christmas light app working soon. I've read there is a fix in beta. Hopefully they can release the fix soon.