Anyone successfully paired a Zigbee Visonic K9-85 motion sensors?

I have what I think is a zigbee, Visonic K9-85 motion sensor (Visonic NEXT K85 SMA) which I inherited from an old Xfinity setup. I realise this isn't on the list of either officially or community supported devices but wondered if anyone has any experience in setting them up?

I tried pairing this device to HE. It was found without issue but it seems the initialisation fails. Also looks like the motion sensor keeps on trying to find a network to join even after the HE tries to initialise it.

In detail what I see when I try device discovery is that the is device found and initialisation starts. Then moments later a "2nd" device is discovered "Zigbee device null:null", which is flagged as a "Previously Joined Zigbee Device".

The first time I tried device discovery the initialisation of the "1st" device failed. The second time I tried it (after deleting devices from the first attempt) the "1st" found device initialised as a "Device". This left me with both a "Device" and a "Zigbee device null:null" added to the list. No "last activity" shows up. Changing the device type to "Generic Zigbee Motion Sensor" (pressing save/configure) also doesn't result in any change in the available settings. Looking at the motion sensor the network light still flashes, suggesting that it doesn't know it's been joined to the network.

I can provide logs if anyone is interested in taking a look.

FWIW, the Zigbee chip set in the motion sensor consists of an EM357 and Skyworks SKY65336-11.

1 Like

Any luck on drivers?

Following as I have tried 10 different drivers as well and nothing.

I am following this, as I have tried different drivers.
Anyone had any luck here.

As I have historically found Visonic sensors to be reliable, robust, and battery thrifty in security system applications I'm throwing my hat in the ring of interest for a resolution to this. I'd love to get a K9-85 on ZigBee talking to HE as I have its predecessor on a Visonic proprietary setup.

These things would likely be as rock solid and reliable as their Visonic Power Series alarm system compatible units if we could get the Zigbee driver sorted out. Can you say loooonnnnngggg battery life :+1:

Also known as: Xfinity Home MP-840 K9-85 SMA VISONIC 2.4 GHz ZigBee

Mr. @mike.maxwell what would you need to look into this if you could be persuaded to?

a sample device...

would I ever see it again? :thinking:
nevermind, it would be worth the cause to add to your collection.

assuming you have a lower 48 address, then yes, it would be returned...


OK, I want to be careful jumping to conclusions here....but....

I have just successfully paired an MP-840 and set what appears to be a functional driver - Generic Zigbee Motion Sensor (it came up as a Generic Contact Sensor by default).

MP-840 K9-85 (2.4Ghz) EU
REV: A 11.08.2016
Zigbee HA 1.2

  • endpointId: 01
  • model: MP-840
  • application: 01
  • firmwareMT: 1011-000C-0000001C
  • softwareBuild: 0000001C
  • manufacturer: Visonic

Current States

  • battery : 100
  • motion : active
  • temperature : 78.80

State Variables

  • lastBattery : 1633665790
  • tempOffset : 0
  • sensorTemp : 80.60

While I was initially thrown by the device automatically going into Walk Test/Testing Procedures upon battery insertion (and after pairing) .... this motion sensor seems to be operating as it should with Hubitat...but given all the posts in this thread saying it didn't, I'm suspect of what seems to be success.

The default testing procedures are standard for Visonic and I should have remembered them from configuring the K-95s on Visonic Alarm Panels. I was too quick to look at the Device screen in HE and the sensor LEDs expecting certain other behaviors when in fact the device was in a different mindset. These Visonics carry on some of the same alarm system level aim & adjust tuning steps they've always required for a better security installations.

The device rolls out of testing mode into normal operation after 15 minutes. See the instructions in the package. I am working off set D-306398. I know they are out there on Visonic's site as well. They will mention that battery saving "Rearm Timer" feature which waits 2 minutes before allowing motion to trigger the device again. This is a feature that will make you think it's not working/not communicating to HE and have you messing about with things wondering what be aware.

Driver-wise we either have what we need onboard the 2.2.8 HE system...or are very close. The device does send a Tamper notice when opened but I suspect that's unique enough that the driver isn't handling it. @mike.maxwell this is not a biggie so maybe we don't need to lift the hood to get this device to work after all. We'll see.

[Now- if you want to talk about how flippin hard it was to get the front cover off from the base without damaging the case seams....we can talk. The point on the "bottom" of the case that looks like a screw hole indention WAS, in prior Visonic designs, for a screw which allowed for easy dismantling. Now it's just a point of shear frustration where a plastic "spring tab" holds on to the cover piece like a gorilla. Don't ask me how buggered up the case seam is now as a result of trying to lever it apart. It now appears I could have stuck something in there at the right angle and sprung that tab a bit...but the instructions to "depress the bottom" were not getting me anywhere.]

I just ran into this issue myself. Tried switching to Generic Zigbee Motion Sensor before I ran across this article, and it still doesn't ever actually trigger. My model is Visonic Next Plus K9-85 SMA (2.4Ghz) DIY. I'm going to try waiting, based on what PunchCardPgmr said about the 15-minute "testing mode", but may wind up just buying some cheap Sonoff motion sensors. I've had good luck with their Zigbee buttons and Zigbee plugs.

Mine is working GREAT. If you have the same model that I quoted above...don't give up on it. The ZigBee is fairly new for them...but false-free motions with sophisticated radio communications is not...not at all. They pretty much perfected the wireless market offering for this stuff in the certified alarm business.

1 Like

I think mine is slightly different. You had Rev A. I have Rev B. Yours was MP-840 K9-85. Mine is Next Plus K9-85.

Ouch,'s the Next Plus family that is key.

The MP-840 is ZigBee, this Next series seems NOT to says 2.45 Ghz but not a word about the ZigBee protocol and it could be, and likely is, totally unintelligible to HE ...I just don't know.

Sorry, I think we all get caught by this when buying sensors at some point. In fact Visonic makes many sensors for their proprietary alarm panels and does so in different frequencies (same private protocol) for different markets (based on local Regs.) I have excitedly bought something off Ebay at a great price only to find the seller didn't show the specifying side of the label/box....and I ended up with something made for the UK market. Learned my lesson to ask for clarification EVERY TIME. Many sellers that get this stuff surplus/clearance (and turn around and Ebay it) don't know the difference.

It's ok. I got it for free.

1 Like

Just to document some behavior on a Visonic / Xfinity MP-840 (pretty much in the same family of the thread subject ).

Was diagnosing a problem with the temperature on said unit not triggering another automation when it should have. Same temp for looong time even after moving the device. All motions through the field of view of this unit were showing in the event log. Had a temp reading earlier in the morning.

I had little thought that there was a problem with the battery level due to the motions triggering as expected. Granted the Device screen showed 100% and that's sometimes a dead giveaway of outright deception.

Pulled the battery, 3.1 V , put in a fresh one...presto...temperature readings back. (Edit: Likely just from the "fresh start" than the battery being low?)

These do sip power, this particular motion IS in a path of constant activity. I can't recall when I replaced it last.

Edit: I think there is something more to this. Some hours later I'm still not getting the temps as responsively as expected. Experimenting with Device Driver settings for frequency of reporting. Even hitting REFRESH after changing temperature environments does not readily cause an updated report. This might actually be a consequence of this Generic Zigbee Motion driver working by luck and less by design with this device.

EDIT 2: adding link discovered on github showing some configuration data on this device - Visonic MP-840 K9-85 PIR · Issue #3360 · dresden-elektronik/deconz-rest-plugin · GitHub

Here's some of the Debug print off mine -