Anyone get a AC1300 (Archer T3U Plus) WIFI dongle adpater to work with Hubitat

I need to get an HE in a remote building on my property to be able to connect to WI-FI, I can't run a CAT5 to this location like I would normally would do and Ethernet over Power cables is not possible either because it does not have the same power meter. I already have an exterior WIFI antenna installed, so signal strength on the property is very high.

Anyway I followed the information here for the recommended dongles and got the long range to be on the safe side...

But since I'm in canada, went to the Amazon Canada site and searched for the AC600 (T2U PLUS) long range dongle, but stupid me, I clicked a link for the AC1300 (T3U PLUS) and bought that one instead. I followed the instructions to a T and nothing works, after about 2 hours of frustration I noticed my error and kicked myself but still blame Amazon search for giving you as a choice a product that is not what I searched for (this seems to be trending everywhere lately).

Anyway, I was hoping that someone might have got this to work or do I need to purchase a new dongle, the right dongle :frowning:

I'll tag @gopher.ny just in case on this one. Thanks!

You need a right adapter. Those drivers are compiled from source for a particular device, they're not universal. I've also encountered a few that happened to compile fine and didn't work anyway.


I've tried a T2U Plus and a T3U Plus (they look identical aside from the model number etched into the USB plug), just for fun, and was only able to get the T2U Plus to work. I can't rule out possible Wi-Fi issues on my side, as I tried my 5 GHz network that doesn't have quite the range of my 2.4, but ... still, it wasn't promising. :slight_smile: Your findings probably confirm this.

1 Like

Thanks Gopher for confirming my fears, now I just need to wait for Amazon Canada to get some back in stock, hoping it's not a model that will be discontinued :pleading_face:

If ever you add drivers for that dongle, let me know so I can beta test it if you want :man_facepalming:


Where are the install instructions for the tplink ac600 archer t2u plus? All i can find is install drivers then reboot.

@user4490, some instructions here...

I think that is a supported dongle so follow the instructions in this post:

okay i have from i can tell installed the drivers, connected the OTB-cable, and connected the dongle. i am not being presented with any screen or fields to enter wifi details.

the dongle led is flahing green. what does that mean?

where do i enter wifi details?

Then my best guess is that you don’t have a supported dongle.

This was a bug a while back. I wonder if it still isn't fully fixed?

1 Like

if the install worked correctly (supported dongle and drivers installed), at the bottom of the Network settings page, you should see this...

Open the WIFI settings and enter credentials there, you most likely need to reboot the Hub to see it?

Other than that, I have no idea, once I had the right dongle everything went as planned.

If the UI isn't cooperating, you could use this endpoint:

1 Like