Any new advice for the new hub registration issue?


#1

Second hub will not pair. I'm out of time and patience. Has anyone come up with a solution?


#2

Step 1: Contact support - support@hubitat.com
Step 2: you've already done that - ask the community

Please be specific with what you are seeing (or not seeing) and others may have a solution or point you in the right direction. Chances are you will need HE support anyway so I would definitely reach out to them while others here attempt to assist.


#3

This is the 2nd time.. same symptoms? 5 sec blue Light; 10 sec flood of packets using no-dhcp address? You connect it to your VM and can connect to it on port 8081?


#4

Ahh...by second hub, I thought @Randy meant he already had one hub configured and has now purchased a 2nd hub. If this is an ongoing issue, why not just post this under the original thread so others can see what you've already tried and what has already been suggested?
Opening a new thread would just get you repetitive suggestions from those who do not know your history.


#5

Right.. here's his original Thread:

I'm guessing Hubitat couldn't get DHCP to work either and shipped him a replacement. I'm hoping to verify that the symptoms are the same.. 2 hubs, identical symptoms cuts the universe of problem areas down by half.


#6

The problem was my router, a certain few do not assign DHCP and mine is one. They are working on a fix. In the meantime I have installed a second router behind the first.


#7

I am having the same issue, but I have a Ubiquiti router running my DHCP. I get an orange light on the network port and no DHCP address.

I can see the hub, but no way to get to it. I am starting to think it doesn't like that it is connecting to a 10.1.x.x address range or something.

I wish there was a way to get to them and set a static IP on the device. I have now reached out to hubitat support to see if they can help.


#8

I added the second router to bide time while they work this out. I suppose there is a chance that the hubs may never work with some routers. I am hoping to be able to connect straight to my Motorola but am likely to keep a second router for home VPN use. I would like full remote access to the hub plus I fancy the thought of having my own encrypted internet portal. You might consider the same if you just want to get things going. I went to Staples and bought one which I will return within 2 weeks.


#9

So..my hub is useless at this point. I am not going to purchase another router for this, and hubitat support has just dropped me at this point.

Not happy with this company so far.


#10

My understanding was that they had a fix and that it might be something that they could do via a remote update. What have they told you?


#11

I got a response yesterday. Basically, they have a fix that will go to devices that get connected, but since mine will not connect they are going to have to send me one with the update.


#12

I can tell you the above isn’t an issue with at least the C4 version of the hub.

I find it really odd at the extent that some people are having DHCP issues. I mean DHCP is pretty cut and dry.

I have noticed that a lot of times no one provides the make and model of their router, which doesn’t help.


#13

The BIG update was in 1997 when bootp got incorporated. :smiley:


#14

Oh yeah, forgot about that one! :rofl:

I have to question if some people are trying to use cable modems or limited cable modem/router combos.


#15

reading between the lines, I'd say there's a subset of modems/routers that don't respond fast enough or slow enough. Or aren't willing to repeat. Something that is outside of spec, but can be programmed to deal with.

I could be miles off.... speculation, absent facts, yields so many opportunities for me to be wrong. :slight_smile:


#16

If anything, I would think it would be the hubitat that is not following the spec. I use ubiquiti unifi all of my network equipment, and Hubitat is the only thing that had an issue.

It looks like hubitat just shipped me my new device and it should be here by next week. I will updat the thread if the new version, with the new firmware fixes it.


#17

I can tell you that HE works perfectly with Unifi gear, and pfSense, and OPNsense, Sophos UTM, and OpenWRT on a Pi through a OpenVPN tunnel, and 5yr old ASUS WiFi router, and, and, and and lol.

Also saying that HE is the only thing that doesn’t work with your Unifi gear isn’t saying much. Of all the gear I have purchased, the APs are the only ones that I don’t regret. There are cheaper and better options for the rest of their Unifi line.


#18

Look it's pretty simple. Most C5 hubs worked fine with the way we had DHCP set up. We identified a situation where DHCP wasn't starting up due to some network ports that didn't engage fast enough, and the hubs boot up very fast now... Well, after it did the DHCP check and the port wasn't "ready" it failed. We have fixed this...

We have issued a fix in 2.0.6 that addressed the new DHCP configuration and for those that are unable to get a switch or network gear that exhibits the issue working, we have replaced or in process to replace those. If you can get a temporary network port to get it to work and DHCP gets assigned, all it takes is to update to 2.0.6 or later and the problem is fixed.


#19

If you want to diagnose, and you're comfortable with the Ubiquiti command line, you can also do a tcpdump on the Network port hosting your Hubitat. This will give a bunch more data on what's going on locally.

If you see something responding that's not your router (in the sample below, it's 192.168.3.1) then you've got something rogue on the net.

In the past, I've had devices that were incorrectly serving DHCP responses on my Network (um,.. :eyes: Vera :eyes: ).

Typically it was slower than the router, so it went un-noticed.... until I replaced the router, and then all sorts of things fell off the network.

Details...
Depending upon your port layout, on an Ubiquiti Edgemax it's something like:

sudo tcpdump -vvi switch0.3 "(port 67 or port 68)"

Where switch0.6 is something like eth1 or eth0, depending upon the router model you have.

A good response looks something like:

    192.168.3.150.bootpc > 192.168.3.1.bootps: [udp sum ok] BOOTP/DHCP, Request from 7c:10:15:... (oui Unknown), length 548, xid 0x902be4b2, secs 65535, Flags [none] (0x0000)
	  Client-IP 192.168.3.150
	  Client-Ethernet-Address 7c:10:15:... (oui Unknown)
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Request
	    MSZ Option 57, length 2: 576
	    Parameter-Request Option 55, length 7: 
	      Default-Gateway, Subnet-Mask, Option 252, NTP
	      Domain-Name, Domain-Name-Server, Hostname
	    Client-ID Option 61, length 7: ether 7c:10:15:...
	    Hostname Option 12, length 19: "b2qt-brilliant-imx6"
23:00:42.784380 IP (tos 0xc0, ttl 64, id 65210, offset 0, flags [none], proto UDP (17), length 358)
    192.168.3.1.bootps > 192.168.3.150.bootpc: [bad udp cksum 0x8f4b -> 0x1899!] BOOTP/DHCP, Reply, length 330, xid 0x902be4b2, secs 65535, Flags [none] (0x0000)
	  Client-IP 192.168.3.150
	  Your-IP 192.168.3.150
	  Server-IP 192.168.3.1
	  Client-Ethernet-Address 7c:10:15:... (oui Unknown)
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: ACK
	    Server-ID Option 54, length 4: 192.168.3.1
	    Lease-Time Option 51, length 4: 86400
	    RN Option 58, length 4: 39306
	    RB Option 59, length 4: 71706
	    Subnet-Mask Option 1, length 4: 255.255.255.0
	    BR Option 28, length 4: 192.168.3.255
	    Hostname Option 12, length 16: "brilliant-office"
	    Domain-Name-Server Option 6, length 4: 192.168.3.1
	    Default-Gateway Option 3, length 4: 192.168.3.1
	    Domain-Name Option 15, length 18: "<...yourDomain...>"

#20

Just an update, I got the new hub and it finally picked up an address and connected. However, odd thing is now it will just stop responding for a bit, and then come back, especially when adding rules or devices.

Also something odd, it seems to be broadcasting data like crazy, to the point where it floods so much traffic that my Unifi server stops detecting other devices on the network.

Something is definitely wrong with the network stack on these things.