Android - Geofence not working

I know there's a few other issues like this already although many of them were created a while back.

In my case, geofence presence had been working great for a while.. I often go on a walk in the neighborhood and I get the 'out of geofence' notification I setup right when I leave the area and also when I return.

But, recently I'm not getting the notification and my device's presence isn't changing. Often, I can manually start the app and it'll update the status. But, sometimes like this picture suggests that doesn't even work.

Note that the blue dot is accurate and I'm well outside of the geofence but the app still thinks I'm inside..

Is there some kind of debugging that I can do to help figure out what's going on? I'm an Android developer and have some geofence experience too.

I figured I could try logging out and back in again and maybe that will fix things.. but, if this is something that happens to others I thought maybe it'd be useful to figure out the issue first


I should add that I'm also whitelisting the app from any kind of battery optimization.. in this case Samsung S20.

8 Likes

a few people have started reporting this

2 Likes

Thanks, I didn't realize this was a beta version or there was a thread about it!

Since updating to 1.6.7.126 geofence no longer works.

1 Like

I am not in the beta program yet I still received a new Android app which doesn't report presence events.

1 Like

Same with me, it was working really well and I confirmed I am now on 1.6.7.126 and it has not worked since the update.

1 Like

Same for me. Can't figure out how to roll back mobile app.

Not working for me either.
Fortunately I run Life360 and Tado presence in parallel so it is not impacting me.
Not a good start to the new build though.
I'm not sure who to tag but @bobbyD, @gopher.ny & @mike.maxwell any thoughts on this issue?

1 Like

Add me to the list also. Only way I can get Presence to trigger is by going into my H7 and finding my Cell and hitting ARRIVED. How can you get back on the "Stock" mobile app and off the "Beta"? I messaged moncho1138 as he was working with the Beta I believe.

1 Like

there is a way, if you open the app change the geo radius and it triggers an update

1 Like

My phone updated to 1.6.7.126 yesterday as well. When I go to geofence in the app, I get a black screen that says "Geofence needs permission to your device's location." Location permissions are, and have always been granted to Hubitat. Anyone else experiencing this behavior? I have a Pixel 6 pro, Thanks

I did not see that issue myself. For me everything looked correct but when I looked at the Notification History, that is when I noticed that it stopped working as of the update. However even though I did not adjust my Geofence area at all, after poking around in the app yesterday it started working again. So it was either hitting ok on the new features popup on the update, or doing the Send Geo Event button that may have got it working again.

This is what worked for my wife's phone. I don't know yet if it will continue updating when she leaves or arrives. :crossed_fingers:

@moncho1138 usually handles the app stuff. Maybe he can comment?

1 Like

I'm also seeing the same problem. I'm on Android 11, current app and hub firmware. I actually deleted and reinstalled my app today on another problem. I have tried moving the GEO circle as suggested elsewhere and the app is showing me leaving the GEO circle but continues to say I'm inside the geofence.

Logging out and back in seems to have fixed my app location permission issue.

I would think if you left the beta, then uninstalled and reinstalled the app, it should reinstall with the last public release rather than the current beta.

1 Like

Yeah, that's what I finally did. It took awhile for me "leaving beta" to register. Then, I did the install of the regular release. I was told that they are the same but it did seem to fix my problems. Thanks!

Was working fine but it has stopped working on all my devices, really wish they would put it back that way it was previously or at least give us a timeline to a possible resolution.

If you are in the Android beta program, there was a new build released today. Specifically said it had improvement to background service for presence.

2 Likes

Download the Hubitat app