Alexa skill controls device but says the device is not responding


#62

I also seem to be having this issue mainly with child switch devices from devices like Sonoff Dual using the driver @ericm has provided to the community.


#63

I am also in the most current FW and this issue, which occurred on Z wave (non plus) dimmers, seems to have resolved. I don’t recall the last time the verbal error msg was received.


#64

I see Alexa unresponsive errors. They turn up in great swathes, but never hang around for longer than a refresh.

For example... it all looked fine. I refreshed... and got:

At the moment, though, I can instruct the lights with alexa that are apparently 'unresponsive', and they respond without issue, with Alexa saying 'OK'.

All the bulbs there are exported hue groups. They're just put through to Alexa as a single group, and I don't export the actual lights for fear of making things worse. That's 17 rooms worth, and about 110 bulbs behind that.

-- Jules


#65

When opening the Amazon Alexa screen you suggested, I do see some devices as unresponsive. It changes quickly if I go to a screen and back to the device list. Seems to be intermittent but not affecting Echo responses to my voice commands.


#66

I'm having an issue with my Peanut Zigbee Outlets using the Generic Zigbee Outlet Driver. Any work around besides using a virtual device?


#67

It’s pretty much a guarantee I’ll have 5-6 devices at minimum showing “unresponsive” each time I open the Alexa app, and I get a device isn’t responding error often as everyone has previously mentioned. I just rebooted my HE waiting about 5 min and opened the Alexa app and boom...zero unresponsive errors in the app.


#68

Hi all,

Just to let everyone know I have logged a specific support ticket with the team to highlight this issue.

Best wishes,
Mark


#69

Hi all,

I'm a newbie (Iris convert)... but one thing I have noticed with using bulbs (and we all know the OSRAM bulbs aren't the most reliable), with the Generic Zigbee Bulb device driver, I can control them better by adjusting the dimmer level up or down, not setting the dimmer level, and also not turning the light on or off. So, I set up a virtual switch device that triggers a rule to adjust the level to 0 ("Off" or up to 100 (bright). For the echo skill, it will pick up the switch as well as the bulbs. So, If I want to adjust a single bulb, I can say "Alexa, set light 1 to 0" to turn off. Or, I can say Alexa turn off Bulb 1 (or whatever the switch name is), which in turns triggers the rule to adjust the dimmer level to 0.

So, in summary, I added the bulb(s) to HE. They appear as Generic Zigbee devices. I then create a virtual switch to adjust the bulb level. You might have switch for each bulb or a group. Then I set a triggered rule to adjust the bulb level. Then, under Apps, Echo skills - include the switch as a device Alexa can control. You could also, then have other rules or triggers that use the switch to initiate turning off or on the light(s).

Hope this helps. This approach seems to eliminate the "DNR" from Echo.


#70

Thanks for submitting the ticket Mixweaver, please keep us up to date with any resolution!

I am a new Iris convert and have also been experiencing the "unresponsive" message from Alexa after issuing a voice command, although the action do take place. At first I thought the issue was my first zwave hop was through a standard zwave GE switch, since such time i have moved my HE so that the first hop is to a zwave plus GE/Jasco Dimer that I regularly use for alexa control. The "unresponsive" message woes continue and at times there is a good deal of latency before the "unresponsive" message is delivered. I do not recall that the command has ever failed only the response.


#71

IIRC one of the firmware updates released since the creation of this thread was intended to address this issue (which seems to be occurring in the cloud, not due to any specific devices in a user's Z-wave or zigbee mesh). I have found that it occurs less frequently than it used to, though it hasn't been 100% fixed. But when it does happen, I just ignore it. The fact that the light (or whatever) turned on is enough confirmation for me that the command was received :slight_smile:.


#72

For what it's worth I was having the same issue with my Zigbee Peanut plugs. I fixed it accidentally when I was playing around with one of the plugs in the device driver. After I hit the "Configure" button in the device driver, I had zero issues with Alexa claiming it was unresponsive. YMMV.


#73

I'm also experiencing this issue. For me it's only the generic z-wave switches (in my case GE Jasco z-wave and z-wave plus). I had this set-up on an Abode security gateway previously, which Alexa integration, and they worked just fine there.

I'd love to see this fixed....


#74

i just had the same issue pop up. everything was working great. Then this last week it started Saying device not responding and "there are a number of devices that share that name". But there isnt.
In case anyone can give advice. Here is what i have done in the last week.

  • added the Alexa tts with node.js cookie.
  • added a ge/jasco fan switch.

#75

I just started having Alexa / Hubitat issues in the last two days. No device configuration chagnes on my system excluding the last update I installed.

When I ask Alexa to turn on some Virtual switch, it does, immediately. Then Alexa says the Device is not responding, check the power, etc..

I will try and find the problem this weekend, assuming it is still happening.
M


#76

This has been happening to me for many months. I logged a ticket and @bobbyD advised that it is on their list to investigate. It is not an Amazon Alexa API issue (see my other post comparing the skill with SmartThings for the same Zigbee devices).

Mark


#77

SOLVED: I was using Hubitat's Amazon Alexa APP when I should have been using Hubitat's Amazon Alexa SKILL. The App is old. The Skill is the new hotness. When I uninstalled the app and installed the skill and also installed the Hubitat skill in the Alexa App, everything works very smoothly and the "not responding" error message went away. Followed the "Amazon Echo Skill" instructions in the documentation.


#78

I have been using only the Skill, and this behavior comes and goes for me.

I have been able to resolve it by logging into https://alexa.amazon.com and deleting all devices, then re-discovering them. Usually works for a few days afterwards.


#79

I’ve had this issue since a month or so ago now. Alexa says the device doesn’t respond when in fact it has done what I asked Alexa to do. What I’ve found is that if I go in to the Alexa App and get it to discover new devices (even though it won’t find any new once), it then starts working again. I don’t have to do anything in the Hubitat Amazon Alexa Skill app. However, this only works for a short time, about half a day or a day, and then it goes back to saying that the devices doesn’t respond again. It’s driving my wife bonkers.

@bobbyD - is this the behaviour you have seen as well and are looking at investigating?


#80

This happens occasionally for me - much less than some months ago. Seems it may depend on my internet connection speed as far as I can tell. Fortunately now so infrequent that I just ignore Alexa a feedback when it does happen. Don't think it's a HE specific issue.


#81

I cannot say that I know myself where the issue is. For my part I can only say that it does not appear to be an issue with the Internet connection and that it only affects devices that are controlled through Hubitat. When Alexa says a device is not responding I can ask her to do a discovery and then immediately after that it works again. When I posted above I had done a discovery to get things working again. Alexa has since stopped working so just before I started writing this post I did another discovery and she’s now working again. I have never had any issues with controlling Sonos or Hue through Alexa, just HE devices.