Alexa skill controls device but says the device is not responding


#82

Hi all,

This is a HE specific issue - I followed up with @bobbyD who confirmed the team are still working on ironing out these Alexa gremlins.

Mark


#83

If it helps.. I still get it with Hue devices, but then I DO have a lot of them (3 hubs worth). I've got it rigged so that it's only really asking rooms at a time to turn off, but there are around 25 'rooms', and if you ask for all of them at once, you can pretty much guarantee that Alexa will say that something's not responding.


#84

I don't have any problems with the Hue stuff.... just the switches, shade control etc.....


#85

I have started to have this issue for the last few days / week. It is really frustrating. She does the action but says the device isn't responding.

IF I DELETE THE HE SKILL, (not the devices) and re-enable the skill, she activates the devices and says "OK". The only things i've added is the TTS driver in the last week so i've disabled that. This has been happening every second day or so.

Was this ever followed up @bobbyD ?

Happened again 12hrs later.
Alexa control single device "is not responding"
Alexa control group of devices "is not responding"
Alexa control virtual switch "is not responding"
Each time the action is performed, she just doesn't get the feedback. I tried this on echos that I have listed as TTS and another I dont have listed for TTS (but TTS is currently disabled for testing thing issue).

Ive deleted TTS, Deleted the Alexa skill and deleted device watchdog - the only apps that ive installed recently. All the apps and drivers for them as well then rebooted my hub. Re-installed the alexa HE skill and then the alexa HE skill on the amazon side. See how long this lasts.

Also ping @ogiewon and @mike.maxwell / @bobbyD RE my error logs below.

Here are my error logs:
app:1942019-07-06 07:06:18.656 am errorError making Call to Alexa message gateway: {"header":{"namespace":"System","name":"Exception","messageId":"ASRLS_59491c2e-3a50-4914-8a4b-be16ef6f40cc_1562360778506.0..ASRLS_59491c2e-3a50-4914-8a4b-be16ef6f40cc_1562360778506"},"payload":{"code":"INTERNAL_SERVICE_EXCEPTION","description":"Unsealing correlation token failed for client side issue"}}

dev:462019-07-06 07:06:18.532 am infoyeebulb2 was turned off

dev:462019-07-06 07:06:18.529 am debugswitchEvents value: off

dev:412019-07-06 07:06:18.295 am warnskipped:[id:3, result:[ok]]

dev:472019-07-06 07:06:18.235 am warnskipped:[id:3, result:[ok]]

dev:462019-07-06 07:06:18.204 am warnskipped:[id:3, result:[ok]]

dev:492019-07-06 07:06:18.137 am infohallway lights switch was set to off

dev:412019-07-06 07:06:01.400 am infoyeebulb3 was turned on

dev:412019-07-06 07:06:01.397 am debugswitchEvents value: on

dev:472019-07-06 07:06:00.794 am infoyeebulb1 was turned on

dev:472019-07-06 07:06:00.791 am debugswitchEvents value: on

app:1942019-07-06 07:06:00.670 am errorError making Call to Alexa message gateway: {"header":{"namespace":"System","name":"Exception","messageId":"ASRLS_9639f02f-4de4-4c52-b225-e522510a0b01_1562360760520.0..ASRLS_9639f02f-4de4-4c52-b225-e522510a0b01_1562360760520"},"payload":{"code":"INTERNAL_SERVICE_EXCEPTION","description":"Unsealing correlation token failed for client side issue"}}

dev:462019-07-06 07:06:00.584 am infoyeebulb2 was turned on

dev:412019-07-06 07:06:00.580 am warnskipped:[id:1, result:[ok]]

dev:462019-07-06 07:06:00.575 am debugswitchEvents value: on

dev:472019-07-06 07:06:00.557 am warnskipped:[id:1, result:[ok]]

dev:462019-07-06 07:06:00.141 am warnskipped:[id:1, result:[ok]]

dev:492019-07-06 07:06:00.091 am infohallway lights switch was set to on

app:1942019-07-06 07:05:43.708 am errorError making Call to Alexa message gateway: {"header":{"namespace":"System","name":"Exception","messageId":"ASRLS_34eada80-e56b-4de3-94c4-ffa8533e95d8_1562360743550.0..ASRLS_34eada80-e56b-4de3-94c4-ffa8533e95d8_1562360743550"},"payload":{"code":"INTERNAL_SERVICE_EXCEPTION","description":"Unsealing correlation token failed for client side issue"}}

dev:822019-07-06 07:05:43.132 am infoextra light was turned off

app:1942019-07-06 07:05:27.942 am errorError making Call to Alexa message gateway: {"header":{"namespace":"System","name":"Exception","messageId":"ASRLS_8e5cb270-d5bd-4709-aae0-554eda1914fa_1562360727784.0..ASRLS_8e5cb270-d5bd-4709-aae0-554eda1914fa_1562360727784"},"payload":{"code":"INTERNAL_SERVICE_EXCEPTION","description":"Unsealing correlation token failed for client side issue"}}


#86

Removed TTS and the added devices
Removed the Alexa Skill HE
Removed Watchdog app
Removed Alexa skill iOS - deleted all associated devices.
Installed 2.1.2 hub update & restarted hub

Added Alexa skill HE,
Added alexa skill iOS - discovered devices.
36hrs so far and alexa is getting replies from the devices and hasn't lost her way yet.


#87

I’ve been having this issue as well for over a month now. Hubitat worked great for a long time, never a single problem, until Ima recent firmware upgrade. It looks to me like hubitat isn’t updating Alexa on the status once it’s changed.

Pretty disappointed to see it’s been about 7 months since people started having this issue and there’s no solution in sight. Kinda turning me off of hubitat.


#89

I can say since i've done the above from my post, she has been onpoint and not lost a device handshake since.


#90

I have always had this issue off and on. I did try the steps above in the post, however mine still says not responding even though the action is taken.


#91

Hang in there folks! The Hubitat team mentioned updates are coming for the Alexa Skill during the last Hubitat Live session. Hopefully these changes will improve the overall experience.


#92

It's controlling the devices, so because you didn't get an OK is not a huge problem is it? This is Alexa and Google Home. They both have this issue from time to time with many hubs and bridges, not just HE.

How about if you turn on Brief Mode in your Alexa app? Does that resolve the issue?


#93

I have had this issue occur occasionally ever since the Alexa skill was released (I can’t recall whether it happened with the now-deprecated Alexa app). But this is exactly how I have always felt about it.

I don’t really care if Alexa thinks the action didn’t occur. I can see that the light turned on, shade went down, etc. So it’s NBD.

This won’t make a difference. She will still let you know that she wasn’t able to control a device even in brief mode. But again, NBD.


#94

Yeah I've had it on Wink, Insteon, SmartThings and Hue too. It's an Alexa thing.


#95

The Alexa app isn't deprecated AFAIK; it still can be chosen when 'add built in app' is selected. I still use it; the limitations it has vs. the skill don't matter to me as I only use it for switches and dimmers. It too suffers from the 'not responding' issue which went from an intermittent problem to a constant one for me with one of the Spring firmware updates.

My workaround: Create an Alexa group for the voice controlled HE device, include within the group a SmartThings virtual switch or ST virtual dimmer-- doesn't have to be unique or have anything to do with the HE device you want Alexa to control; {apparently the handshaking with the ST cloud is long enough to mask any API timing issues on the HE side) and voila... the problem is solved, I haven't had a single recurrence since I did this back in May. And it doesn't introduce any perceptible lag vs. 'pure' HE voice control.

Seems cumbersome but I still have access to ST and usually have to create Alexa groups anyway to add 'synonyms' to make voice control easier... and the 'not responding' spiel while harmless was annoying the crap out of everyone.


#96

We've recessed Echo Dots into the walls of all the rooms here. Voice has become the primary control in our house and this Hubitat Alexa Skill issue has been such a headache that I've been forced to bring back SmartThings this weekend.

As I tried to explain much earlier on in this thread, this fault is a Hubitat issue not an Alexa problem. HE support have acknowledged this and the item is on their list.

My workaround is to use Hubitat Hub with the brilliant HubConnect App, along with the SmartThings Alexa Skill. It's a tiny tad slower but it works - And for us that's the most important thing.

The issue has given Hubitat a bad name with the non-technical users in our house when actually we all know that it's the best! I hope it is sorted soon.


#97

I believe it’s the only functional option for users in several countries, but its been referred to as deprecated by hubitat staff.

I’m assuming that means they aren’t updating it, and possibly not providing support if someone has an issue with it? But admittedly, that’s an assumption.


#98

Thanks, I missed that.


#99

Hubitat firmware v2.1.3 has been released which includes a fix for some Alexa "Device is not responding" issues. It also adds motion and contact sensors to the Hubitat Skill for Alexa.


#100

So I was really hoping this latest update would fix the issue. Unfortunately, I still have Alexa tell me that a device is not responding even though the action is taken. The funny thing is that now it is very consistent in that turning on any light works just fine. However, when turning off a light it has the above issue with saying the device is not responding even though it does complete the action.


#101

Let's start at the beginning...

  1. In your list of installed Apps on your Hub, are your using the "Amazon Echo Skill" or the "Amazon Echo App" ?

  2. What specific brand and model of device is Alexa reporting "device is not responding" for? What Driver are you using for that device?

Starting with those two questions will help us guide you in troubleshooting this issue.


#102

I am using the Amazon Echo Skill only. The light switches I use (which are the ones that have this issue) are a combination of Leviton DZ6HD-1BZ and DZR15S-1BZ. Right now, I am using the "Generic Z-Wave Smart Dimmer" or "Generic Z-Wave Smart Switch" respectively. I have also tried switching to use the same driver without the word "Smart" in it.