Alexa skill controls device but says the device is not responding


#41

+1 to this. I wiresharked the traffic between my hue bridge/hubitat to see what was happening, and this seems to be the case for devices that alexa says "ok" to:

0.00 seconds - Packet traffic from Amazon to Hubitat (Encrypted)
0.02 seconds - Packet traffic from hubitat to hue, telling it to turn on living room
0.08 seconds - Packet traffic from hue to hubitat saying that the lights have been turned on
0.10 seconds - Packet traffic from hubitat to amazon (Encrypted)

Now, everytime Alexa hangs for a bit and says that the device is not responding...

0.00 seconds - Packet traffic from Amazon to Hubitat (Encrypted)
0.02 seconds - Packet traffic from hubitat to hue, telling it to turn on living room
0.10 seconds - Packet traffic from hubitat to amazon (Encrypted)
0.12 seconds - Packet traffic from hue to hubitat saying that the lights have been turned on

It appears that hubitat doesn't make a 2nd effort to alert Amazon that the device has responded, or is not waiting for the device to respond before sending information to amazon.

This is ESPECIALLY noticeable in larger light groups. For my hue light group "Everything" which includes 40~ bulbs, Alexa has literally never responded "Ok!" to any command involving them, even though they always turn on/off nearly immediately.


Google Home integration saying random lights are offline
#42

It definitely feels like a simple race condition between Hubitat and Alexa. Your WireShark data seems to confirm that hypothesis.


#43

One workaround for this is to use a virtual switch where there is a delay..

Alexa turns on/off the virtual switch and responds ok...
Virtual switch controls other device.. it can take its time because alexa already thinks its complete because of the virtual switch response..

I use this for my ‘night’ routine as it sets various dimmers and lights etc.

I use ‘one to many’ to take control of the virtual to the other switches/lights.

Andy


#44

I've had to downgrade my hub back to 2.0.1.110 to speed up Alexa's responses.

@Cobra I will try your virtual switch workaround.

Mark


#45

While I agree that this would probably resolve the race condition, it feel far from an ideal solution for the long term. I would hope that Team Hubitat (@bravenel, @patrick, @bobbyD, and @chuck.schwer) would be able to fix this eventually to give the hub enough time to complete the actions before sending an update back to Alexa.


#46

This must be why I hardly ever experience this with HE. I use virtual switches for almost everything.


#47

With the latest iteration of He I now have this EVERY time asking Alexa to do something with He. Still does it but Alexa reports back that the device is not responding. Annoying to the family.


#49

There doesn't seem to be much interest from support in investigating this issue, I have had to go back to the Amazon Echo App,

I am not convinced it is an Alexa issue, It may be the old dimmers i have are not playing well with HE.


#50

On the contrary, support is very much involved with troubleshooting the issue and working with the engineers to produce a fix.

Andy


#51

I think it's a timing issue. How long Alexa waits for confirmation after sending the command before reporting not responding.

I've never gotten the error from Alexa when controlling a something on the HE hub. I have gotten it when controlling Hue lights. My Hues are connected to a Hue Hub and Alexa is using the Hue Skill not going through HE.

but I'm only controlling always on zwave devices with Alexa through HE, Both Plus and older zwave devices.


#52

Sorry for the troubles. We know how annoying this could be and we have been investigating this issue. We think we have it resolved and hope to have a fix released soon, if internal testing goes well.


#53

A lot of the time, if you ask the same thing in a different way after these kind of responses from Alexa, it will immediately perform that task and respond OK. It's a widespread problem with the AVS platform, and not isolated to HE.


#54

I have a virtual switch called "Reading Scene" so that I can say those words to Alexa.

Last night I had a something similar, perhaps. I spoke those words and she said she was having trouble finding that. I tried it a few other ways and although the responses were slightly different, it never worked.

The reading scene is made up of three lights so I asked Alexa to turn on one of them. Worked fine. Got an OK. I tried "reading scene" again and it worked. Got an OK.

I think this might be an extreme case of


#55

Hi @bobbyD,

Are you guys still actively looking into this issue?

Mark


#56

I’ve been having this problem with light groups defined in HE. I’ve resorted to making the groups in the Alexa app


#57

I only see this with one device so far.

"I say - Alexa", Turn on light
:: waiting for the light to dim off ::

"Alexa Response.. " - Sorry, this light is not responding.

But the light turns off ?


#58

Heya. I see it quite a lot.

It's apparently something that the guys are aware of, and are working on it. I suspect that Alexa is timing out the query before the hubitat code has had a chance to answer it, so despite the fact that it aborts and says 'we failed', the hub is still processing the command.

I always assumed it was more likely to happen with big environments, but in fairness, despite the fact that I've got ~120 bulbs... I really only expose them to Alexa as a dozen or so groups. Anyway... happens to me on probably 10% of requests.

-- Jules


#59

I had that same error a lot before the last hub update. Since then it’s been a lot (99.999%) reliable and the “not responding” hasn’t been happening.


#60

I've been stable too. Currently on version 2.0.3.117.


#61

The Alexa Skill has certainly improved with the latest HE Hub update. When controlling HE connected devices by voice I now don't receive a verbal "Sorry, X device isn't responding" reply from Alexa.

However, I do still receive the error visually even with the latest HE update installed which suggests that there is still an issue somewhere. In the official Amazon Alexa iOS & Android App all my HE connected devices show a red "Device is unresponsive" label. Clicking the device name to open its controls shows the same error message at the top in a banner for 1-2 seconds. It then disappears and the device status is updated to online.

@ourmessages and @cdallum do you see any errors for your HE connected devices in the Alexa App?

Screenshots here:

I have replicated this issue on many HE Devices Types including:

  • Generic Zigbee CT Bulb (dev)
  • Generic ZigBee RGBW Light
  • Generic Zigbee Outlet
  • Group Bulb Dimmer
  • Virtual Switch

I have other devices in Alexa connected with SmartThings (such as the 3x Lounge Lamp bulbs labeled in the screenshot above), Osram Lightify, Nest, Ring and TP-Link Kasa and none of the devices linked through the these Skills have the error.

@JulesT I suspect you're probably right here. @Collisionc previously Wiresharked the traffic and the findings would suggest some sort of time out issue.

Mark