Alexa skill controls device but says the device is not responding


#1

Hey all,

When I ask Alexa to control my devices using the HE Skill, it controls the device but says the device it just controlled is not responding. Has anyone else seen this behavior? If so, how can I fix it?


Server is unresponsive - Alexa App
Alexa delayed response
Alexa; "A few things share the name lights. Which one did you want?"
#2

I’ve seen it intermittently.

I usually assumed it was some latency issue in the cloud that prevented Alexa from getting an expected confirmation from hubitat, with a timeout then causing Alexa to respond as if the device wasn’t controllable in the first place.

Are you seeing this all the time on all devices? Only sometimes? Specific devices?


#3

To be honest I don't use Alexa enough to know if it's intermittent or not. When I do use it, it happens every time and the device doesn't matter.


#4

Remove app and skill and setup again.


#5

I've experienced that. I agree with Aaron. Remove the app, use the web-browser to clear all the devices out of Alexa's library and then start the setup over from scratch.


#6

I had this issue until I uninstalled nest camera integration. Now I don’t have it at all. Could be a load issue?


#7

I've tried all of these suggestions and I still have this issue. Any other things I can try?


#8

Happens all the time? I get it only intermittently, but I would not call it a Hubitat issue. I've had the same thing happen with the Insteon Skill and the Wink Skill. Always goes away for a time, then reappears, goes away, etc.


#9

yes


#10

And you tried the obvious, reboot your Echo? Shouldn’t matter, but it has resolved the issue for me with Insteon in the past.


#11

Which one? I have 3 echos and 2 cubes.


#12

The master if you know which one that is, if not, all of them.


#13

I have the same problem, might be because I am in Oz. I only need the basics so the old Alexa app
works best for me. No more not responding replys any more...


#14

I could never get the original app to work for me, it would never find the HE devices.


#15

Did you make sure to add them in the App ?


#16

yup. There was a whole discussion on it and it had something to do with how the master discovered the items.


#17

Bummer, I have never had a problem with my stuff. Works so much better for me, did get annoying
when she kept telling me it did not work when it did....


#18

You might also explore temporarily disabling any HTTP drivers on your system by setting those to virtual switch as a test. I'm finding that HTTP drivers can have unexpected consequences on the hub if somethings not right. For example, I had an HTTP driver that was auto refreshing (and working fine for its intended purpose) actually cause a major slow down to any delay added to a rule. 1 second delay became 30 seconds.

Anyway, it's not identical, but somewhere to look. Maybe something is cause a major delay on your network and Alexa cannot get the status before timing out and giving the response (sorry the device is not responding). In fact, not that I think about it, the times when I used to get that response from Insteon, it was a known issue and they were updating their firmware to try an resolve it, but I also has a faulty Insteon hub that was working-ish. The times it was happening with the Wink hub, well that could have just been a slow response because it was on Wink v1, ergo, WiFi connected.

Here's something simple to try. Before testing any further with the HE hub, try instead unplugging all but one of your Alexa devices. If the problem still exists, unplug that one and plug in just one other. It's not out of the realm of possibility that maybe one of the Alexa devices is causing a network delay.


#19

My hue devices work fine from my echo, it's just the HE devices.


#20

Has this problem existed ever since you started using the Alexa Skill?