Alexa not working today, anyone else?

My Alexa integration was working yesterday, but I rebooted the hub today, and Alexa no longer works. I tried removing and re-adding devices, but Alexa kept responding with "not responding". I disabled the skill in the Alexa app, but was not able to re-link it, although it did show me my hub. The message was "Unable to link account with Alexa - We are experiencing a problem connecting with the skill to link your account". I then removed the Amazon Echo Skill from HE, and re-installed it, allowing access to one device. I tried enabling the skill again in the Alexa app, but it still failed. I rebooted the hub again, but got the same results.

Edit: I'm getting this message in the log, but it really isn't linked, so it might be expected:
2023-03-26 11:24:54.904 AM (http ://hub/logs?tab=past&deviceId=6#)Error making Call to Alexa message gateway: {"header":{"namespace":"System","name":"Exception","messageId":"SOME-GUID"},"payload":{"code":"INVALID_ACCESS_TOKEN_EXCEPTION","description":"Access token is not valid."}}

Edit: I tried linking the account from a web browser. This URL (shortened) was called:
https://oauth.cloud.hubitat.com/oauth/select_hub?scope=app&response_type=code&redirect_uri=https://pitangui.amazon.com/api/skill/link/M3F6BAFXNQFFU8&client_id=6b43cb0f-2350-4b2f-b167-a048fec2eb46&state=A2SAAEAENNLSjfM

The response was: Amazon Alexa

Linking unsuccessful.

I just tried mine and I was able to control a device.

So I'm in a weird spot - I was about to say that I'm experiencing the same as @Sebastien - and it's true that all appears to be working, however, I have the same error in my log as @Daro66, so I don't know what to say.

That said, I have noticed some odd things with Alexa in just the past few days - I've had lights and plugs randomly turn off unprompted and when I check the events, it says that it came from the Echo skill, but there had not actually been a trigger from Alexa (like, my whole family was in the kitchen eating dinner and suddenly all of the lights in the house turned off). I was almost wondering if some missed commands from weeks/months ago were suddenly popping out of the cache - it was really bizarre.

1 Like

Just checked my logs and not seeing that error - odd!

Just checked my logs (using Alexa skill and Echo Speaks).
I do have a new error in my logs:


However, I was just able to add a new Alexa Dot (What I was just doing, coincidentally)

Yes! I had a light go on twice late last night, but there's no telling where it came from anymore.

Are your events still listed on the device page?

There is no way that the 2 circled ones actually were triggered by a concurrent command given to an Alexa (I say concurrent due to my "cached command" theory above), and the only Alexa Routine I have related to this switch is a power cycle (i.e. if the routine had been somehow triggered, it should have turned the switch back on too, but it didn't. Really odd.

Yes. My dimmer got two commands to set level from an App that is unknown, so I'm going with Alexa.

Edit: I forgot, that I did an update yesterday...
update Updated with build: 2.3.5.117 2.3.5.117 2023-03-25 01:19:12.135 PM EDT

Someone fixed it. I tried a few more times yesterday, and this morning. Just now it worked.

It should be posted in this thread;

And there is an interim solution has been posted here:

Thank you. I will move it.
And thanks for the interim solution.

1 Like