Alexa Not Finding Your Devices?

So you added a new device and Alexa can’t find it. Did you you add it to your Alexa app? (Of course, you need install the Alexa app first). Yes, having to give permission for Alexa to add each device adds an extra step, but opting in is an important security feature and keeps local control as the default for all of your devices.

We’re working to make our Alexa integration the best in the biz. Any integration features you’d like to see?


Right now the Alexa integration just supports lights with on/off and setlevel. What other integrations would there be?

Color changing?
Mode changes?

1 Like

do you have a how to video on integrating in Alexa or a way i can start looking under the hood at things before my hub gets here?

Alexa is pretty straightforward, but I’ll see if I can put something together. The steps are pretty simple, add the app, choose your devices to share with Alexa and then have Alexa discover the devices. No skill right now, and its limited to lights. We will expand our Alexa offerings post launch in adding custom skills and additional features. Let us know if there are any key features you are looking for in an Alexa integration.

1 Like

I second the Garage Door open/close/status through Alexa

1 Like

I’ve added a Motion Lighting App with the new Alexa option. I see it creates a virtual device named as such. I added that to the Alexa app. It can’t be found, and the other three devices I have now say offline.

Any thoughts?

I successfully added 3 GE switches to Hubitat (my first devices to bring over from ST). Pretty painless, but, Alexa does not find them. Yes, I have the Alexa App installed and Yes, the switches are selected.

Switches are 2 - 14291, and 1 - 14294

Did you remove them from the ST Alexa app? Assuming they are the same name?

Run “Alexa, discover devices” a couple times too.

1 Like

Yes, yes, and did many times… I’ll keep plugging away

Discover devices through the App and not via voice. That’s what worked for me.

Thanks, yep, tried that too…

I had trouble yesterday. I had to restart hub to get them added. I reported this to support as well.

Thanks, restart… still nothing…

I am having this problem also. Did you ever get it to work?

Nope… Patrick has been helping me pretty much every day for the last week - he’s been great, but it’s still not working…

I experienced this issue after first being successful. In my case, it was my Echo had joined one of my WiFi routers that is isolated from the Hubitat. Once I corrected that, the devices were again found.

Are you using one of the new mesh routers like eero or google wifi? They can be problematic with IT devices and just plain incompatible with some.

No, I’m using an Airport Extreme… everything is on the same wifi… Thanks

By any chance, is your Amazon Alexa device connected to the 5GHz WiFi instead of 2.4GHz? Looks like another Airport Extreme user reported a similar problem with 5GHz devices not being able to 'see' other devices on their network. Just something to try...

Yeah, tried that… thanks

1 Like

If you have not already tried it, change the IPv6 connection sharing setting and if that doesn’t solve it, also change the IP range to 192.168.x.x