Aeotec MultiSensor 7 - Software Failure?

Has anyone seen this warn error before with the Aeotec MultiSensor 7's?

I've tried shutting off the hub and unplugging and booting back up. Reflashing to the latest firmware. powering the device off (it's connected to mains power) and then power back on. The only thing I haven't tried yet is factory reset of the device and re-pair. Its preventing my Hubitat Z-Wave Mesh Details screen from ever grabbing any device data. At least it never populates. Wondering if this has anything to do with my earlier issue that @bobbyd has reached out to me on earlier today.

Zwave settings details show the following for this device. Notice the high miliseconds reading. Yesterday it was reading over 3500 before the device stopped responding all together. Wondering if maybe i have a bad device. I installed 6 of these in my house, and this is the only one giving me an issue.

What started me looking at this device, is the motion sensing never goes inactive. It's always active which is interfering with my bathroom Room Lighting rule which thinks it's always active and therefore never "resets" to run again on new motion.


1 Like

Software failure is a report from the device.. Possible a firmware issue.. I would check with aeotec.

It was written in the driver to report that error but this is the first time I have seen it.


Im having the same exact issue on my new sensor I received today. The LED triggers as if it senses motion, but its like the state change to inactive never hits the hub.

Have you figured this out? Mine has since calmed down and is behaving properly now. No high ping times and no more errors. I did remove mine from mains power at the advice of Aeotec for 6 minutes and then plugged back in again.

I’m seeing this again with all my ms7 that I just installed. Frustrating.

It is an error provided by the device, with an error code that would likely only make sense to the manufacturer.. Aeotec would likely know what this means and would know how to fix or possibly provide a firmware update to fix.

Here was their response when I inquired about the error:

Not quite sure what software failure [85] is related to, but there are a few things we can try such as flashing its firmware to a lower version to see if that helps or power cycles. This is my recommended troubleshoot steps here:


  1. Re-install firmware V1.4.1 as long as the MultiSensor 7 is still active you should be able to still push the firmware update.

  2. Power Cycle, remove power for 6 minutes, then power it back up

  3. Unpair and re-pair (pair the MultiSensor 7 while keeping it nearby the hub)

  4. Last case, try flashing the firmware with an earlier firmware version (attached - V1.3.7 US Frequency). See if this helps overall.


Chris Cheng

Field Application Engineer

Aeotec Inc.

Ha.. It’s in their documented features.. Figures..

Is it something you might be able to reach out and help me understand? I’d like to see how to actually resolve it because every time it happens the sensor goes unresponsive and any rules I have setup based on activity of the sensor don’t run right because the system gets stuck in the last sensor state until the failure stops. So last night one of my room lights was on all night because the sensor wasnt recording inactivity from motion and so the rule was constantly active.

So frustrating ! I have a few of these on the latest firmware and 1 of them has the "85" bug but others seem OK. Tried reinstalling and power cycling so now downgrading the firmware...

Latest response from Aeotec with the latest firmware and software failure 85. I haven’t had time to do this yet with any of my devices.


This is caused by the Watch Dog process causing the application layer to timeout and reset itself. Its advised to do this:

  1. Upgrade the MS7 units to the latest version v1.4.1.2055 via OTA

  2. Press and hold the Action Button for 20 seconds to reset the MS7. (This is needed over exclusion, you can exclude the sensor then manually factory reset the sensor)

  3. Re-pair the MS7.

I will continue to run tests to see if i can determine the underlying cause, but this is the recommended flow to resolve this issue.


I've managed to get mine working OK for now by doing roughly as above - exclude, reset, replace FW, repair etc and no error 85.....for now.

Thanks for letting me know. I’m going to give it a try myself today and see if it helps my situation. But I’ll pass the info along.

I'm trying to get this firmware update done and it just doesn't want to work. I'm using a USB Zwave controller with simplicity studio and the z wave pc controller. I follow the instructions exactly as on the Aeotec website. It sends the upgrade, gives me a successful message, but when I pull a get on the current firmware info, it still says 1.04. I'm at a loss. I've tried a reset after the success message as well. I don't get it with this thing. I can't find a copy of 1.3.7 gbl file anywhere to try that.

Give it time to refresh and it will update the version number. You can also try clicking on save preferences of the device I. Hubitat.

I'm not using hubitat to update though. I have a C-5. Do the same using the stick and PC Controller 5? Let it sit and bake maybe?

1 Like

Recommend reaching out to Aeotec support. Let us know what they say?

Opened a ticket. I'll report back when I hear something. Thanks.

So I must be losing it. I kept looking a 1.04 version and not realizing it was just a leading 0 before the 4 and it dropped the third digit in 1.4.1. at any rate Aeotec suggested trying to downgrade it and sent me 1.3.7 and 1.3.6. I tried 1.3.7 and it seems to work ok now. No more 85 errors and the motion state isn't freezing on active.

Did you try upgrading and the firmware and then Factory reset and then readd?