Aeotec Multisensor 6


#84

Hi @csteele. I have been using your driver for a while now and it has been working great.
With the latest Hubitat update I added my multi sensors to Alexa but they show up as contact sensors.
The workaround was to comment line 85 capability "Contact Sensor"
Now they show up in Alexa as motion sensors. Just wanted to let you know in case there was a reason you had Contact Sensor in the driver.
Thanks for your work!


#86

The release notes in the driver say:

2. remove tamper and instead use feature as contact and acceleration ie vibration sensor

Removing capability "Contact Sensor" probably will cause an error due to line 406, 412 not having an attribute any more.

The Engineering Spec for the device shows:

leaving plenty of room for interpretation. :frowning:

I've updated my copy of the source and will do some testing with reverting back to a TamperAlert. However, this could quickly become a game of Whack-A-Mole. :slight_smile:

Hubitat's built in Multisensor6 driver has 'capability "tamperAlert" but treats the event as an 'acceleration' based on one test.

dev:1642019-07-30 08:45:44.817 am infoAeon Multisensor 6 acceleration is active
dev:1642019-07-30 08:45:44.811 am debugNotificationReport: NotificationReport(v1AlarmType:0, v1AlarmLevel:0, reserved:0, notificationStatus:255, notificationType:7, event:3, sequence:false, eventParametersLength:0, eventParameter:[])


#87

released v1.6.8 with TamperAlert replacing Contact Sensor.


#88

Hi, I'm currently taking the first steps to getting my Hubitat up and running. Right now I'm trying to include the Aeotec Multisensor 6 using the standard included driver. It won't include either securely or insecurely. It just isnt recognised. It looks like there is something basic and simple wrong, so would appreciate guidance.

This will be my third generation of automation hub once I get it working, I started out with a Zipato Zipabox then moved to OpenHAB running on a Raspberry Pi.

The Multisensor 6 has been running successfully on the Pi for many months. I excluded it, reset it and then shutdown the Pi, as described above. When I set the Hubitat to include, then hit the button on the Multisensor 6, precisely nothing happens. The M6 just flashes red to indicate failure afer a few seconds and the Hubitat shows no sign of having heard anything.

On previous hubs I've used, the Z-Wave controller shows up as a device. This is not the case here, not one device shows up on the Devices screen. Is this normal?

Any pointers appreciated

Thanks, Richard


#89

Is your hub set to secure connect the device (look for it in settings>z-wave settings>secure join drop-down) if it is you should doublepress the button on the mi6 within 1 sec. Or change the drop-down to locks / garage door openers only.


#90

Given the limitations on the number of packets per second over the Z-Wave and Zigbee radios, adding additional, unrequired, packets for Secure Connect is counterproductive.

ZWave communications can be as low as 9.6kb/sec for the very oldest devices, 40kb/sec for ZWave and 100kb/sec for ZWave Plus. Zigbee is 250kb/sec. Therefore, our hub's can create thousands more packets to be sent than the channel(s) can process. A few hundred devices can flood a channel pretty easily too with door/window messages, battery level and energy readings. I know I would hate stepping on a Lego because a light didn't turn on due to my Washer telling me it still is using zero energy, thus delaying the outward command from the hub to a light switch.

To me that means doing everything to minimize the consumption of the Radio. Which includes NOT using Secure Connect when it's not mandatory. :slight_smile:

This analysis led me to choose to double the number of Radios I had and therefore double the number of packets per second my 'total system' can handle. For those moments when there isn't any radio congestion, the speed of my 'total system' is not any better than anyone else's. What I've been doing in my 'total system' is attempting to reduce the number of times per minute/hour/day/week when the Radios are congested. That yields a far more consistent perception of speed/response time.


#91

Many thanks @frits, I hadn’t worked out the relevance of that setting. Very handy.

Regarding my problem, that’s now fixed and I have a couple of devices installed and a simple automation running. Sheer dogged persistence was how it was done, going back and stepping through right from square one.

Nest step is to work out how Rule Machine works, which looks non-trivial. Then build the migration plan....

Cheers

R


#92

Thanks @csteele for the guidance. Most of my automation does not need the security overhead, so I’ll avoid where I can.

Apart from that, the hub is working now and I’m onto the next steps....


#93

Good to hear that it's working now. About Rule Machine, if you wan't to do something with motion you might be far better or with other apps. There are two HE apps (motion lighting apps and zone motion controllers) and of course apps from the community. Those apps make life very easy compared to RM.


#94

If I installed this driver, I can just switch the driver in the device thats already connected. Is that correct ?


#95

Yup!


#96

after switching the driver, click Configure to cause the driver to send all it's setup commands to the physical device.

The only time you don't do this is when you switch to a driver such as the Basic ZWave Parameter Tool and make device changes. When you switch back to a normal driver, you wouldn't want to UNDO what the ZWave tool had done.


#97

thanks @csteele


#98

Being new here, not sure if I should create a new thread but here it goes.

I am new to Hub but have done quite a bit of Home automation using ISY and decided to give this Hub a try.
I am trying to add Aeotec Multi sensor (ZWave) and unable to do so. Nothing happens, just like reported earlier. I have tried:

  1. Factory Reset the M6 device
  2. Exclude and Include in discovery mode, but device is not found. Hub and Device are 3 feet apart so should not have any comm issues.
  3. Added new drivers that were mentioned in other threads, but nothing changed (maybe there is a config/step I am missing)

I brought this device home and excluded and then included it with ISY setup and it works like charm (less than 30 secs to set this up and see the readings). It is one of the supported device fir Hub and since it works with ISY, it means that M6 itself is working. What am I missing?
Any pointers/help is much appreciated

thanks


#99

Did you excluded it from ISY first?
Then try pairing it to Hubitat?


#100

Thanks. Just to clarify, this is a brand new device and my first attempt was to pair it with Hub at a different location. Since It did not work there, I decided to check if device itself was working and that is when I paired it with ISY at home.


#101

Are both sensor and Hub same frequency? They differ worldwide. Australia, USA, Europe etc.


#102

I assuming they are, the box (ordered of Amazon US) says AeotecModel ZW100-A (908.42Mhz) and as far as I know ISY, Hub and this device is all US based. If it was any other frequency than US, it would have not worked with ISY. If there is any specific step in Hub to confirm then, let me know.


#103

I have 12 of the Aeotec Multisensor 6 and they all joined 'easily'. Just last week I got a new one to replace one I had bought off ebay a year or more ago, that came with a broken illuminance sensor. I had no trouble joining the new one, and equally had no trouble excluding the old and joining it again to my development hub.

** Note... 'easily' is always relative.. relative to how easy the manufacturer makes the button pushes to put a device into Include or Exclude. Aeon is there in the middle of the scale..multiple pushes, and for the Multisensor, an unreliable mechanical linkage. I leave the back cover off and click on the arm when I'm including or excluding.


#104

Is there a debug mode where I can see these messages on the hub? It may help getting to a resolution or returning it back to Amazon. I do understand that these sensors are iffy at best, having dealt with ZWave and Insteon devices in past.