Aeotec Multisensor 6


#1

I see mention of the Gen5 Sensor. Does anyone have the Multi 6 working? I unpaired it from that other cloud hub and go through the process of setting it up and Hubitat doesn’t see it. What’s my next step? I have over 100 devices on that other platform and so far all I’ve moved are my Lightify spots and a Hue bridge. Any advice would be appreciated since I have six of these.


#2

It is listed as compatible
I will go in my attic tomorrow (not home right now) get mine and transfer it over to Hubitat and see.


#3

Yes, I have a (new) Multi 6 working. I know you said you excluded it from ST, and if that was successful, you shouldn’t have to do this, but have you also tried resetting the sensor? From the manual:

Resetting your MultiSensor.

At some stage or your primary controller is missing or inoperable, you may also wish to reset all of your MultiSensor’s settings to their factory defaults. To do this, press and hold the Z-Wave Button for 20 seconds and then release it. Your MultiSensor will now be reset to its original settings, and the LED will stay solid for 2 seconds and then turn off as a confirmation.

You’d then need to try pairing it to Hubitat again, probably by putting the hub into pairing mode and pressing the “action button” (which I’m assuming they also call the Z-Wave button above?) once for “regular” pairing or twice for “secure”/S2 pairing. I’m pretty sure I did “regular” with mine, but if the driver is written to handle it (I’m not sure), S2 should also work.


#4

I have a couple of these. Even though I had removed them both needed to be reset per the above before I could get them to join. If memory serves they worked fine. I don’t actually use them, just pulled them out to see if they worked.


#5

Thanks for the help. I got it working! I did the hard reset, still didn’t connect. Then since I’m running another zwave hub I thought maybe it was passively interfering. Disabled it and Hubitat Elevation did it’s thing. Thanks all for the assist.


#6

I’ve been using this driver and it’s been working well:


#7

I’ve been trying to get the Multisensor 6 to update the temperature and humidity every 5 min. I have an App that looks for a swing in humidity over the last 20 min and if it is a large change, turn on the bathroom fan. I changed to the above device code and set waking every 5 min but I still get an update every 2 hours, any thoughts?
Thanks,
Craig


#9

I get the same behavior from the multisensor. I am trying to do the same thing. Did you ever figure this out?


#10

I am using the stock driver. My multisensor reports humidity every 10 minutes. Lux is reported very frequently. Mine is USB powered.


#11

At work right now, but I am using the above driver, but it took a while for any changes to keep. I will do a compare of my code to the original code to see if I made changes. I do remember that the sensor would not report humidity if it didn't change, and that to get the timing to work, it had to stay awake a while (there is a setting in code I think)


#12

Thank you! I would appreciate you taking a look at your code. Haven't figured this out yet.


#13

try this:
If your MultiSensor is battery powered, you will need to ensure
that it is active when configuring it. To do this, press the Action
Button once, which will trigger to send out a wake up notification
command. If you want it to wake up for 10 minutes, to do this, press
and hold its Action Button for 3 seconds and then release it. Your
MultiSensor’s LED will fast blink for 10 minutes to indicate that it is
active.
When you are done configuring or communicating with your
MultiSensor, you can put it back into sleep mode to conserve
battery power. To do this, press and hold its Action button for 3
seconds and then release it. Your MultiSensor’s LED should now
be off to indicate that it is asleep.


#14

Thank you! I hope this is the prob. Trying now


#15

@napalmcsr I can't believe it was something so simple! Thank you so much for your help. Its updating humidity every 4 min now!


#16

nice!


#17

Is this driver still working well for you? I just got a couple new Multisensors and the only thing not working is motion!


#18

Mine still work. Just checked 2 of them.


#19

Yes it is.


#20

I use this for my 12 Aeon/Aeotec MultiSensor6:

Just updated it yesterday to allow the chatty logs to be turned off, and put in a 30 min timeout to automatically turn off debugging, just like standard Hubitat drivers. (Code copied from Hubitat's examples in github.)


#22

I have one of these wereboth motion and accelerations are stuck active. Kind of makes it useless as a motion sensor I don't suppose you know anything about how to fix that? It's always something with these devices...