Aeotec Multisensor 6 Z-Wave firmware 1.14

Hello,

Has anyone been able to extract the firmware 1.14 from the exe package?
I would like to use the native HE FW updater :slight_smile:

2 Likes

Yeah... It is pretty darn annoying that they won't release the firmware in a usable format for hubs other than Homeseer.

But, you know... Aeotec.

Have you created an account and opened a support ticket with Aeotec? It certainly can't hurt to ask them directly...

Aeotec Group Support Home

FWIW, I've received quite good response from them surrounding the Range Extender 7. Of course, your mileage may vary.

Look at the homeseer option. Those guys moaned that much about wanting the firmware only file that aeotec made it happen. Homeseer can update firmware too

@NoWon extracted the bits to work with the original firmware updater where you point it to a URL for the file. I am going to try this today on my 2 MS6s.

Does this work using the HE firmware updater?

Is this for the EU version? I would like to try it :slight_smile:

1 Like

@syepes no that one is for Unites States version.

I can not test EU version
but here you go I extracted the Hex the same way so it should work.
European Union Aeotec Multisensor 6 firmware 1.14 hex

2 Likes

I compared this to my one I extracted and it was exactly the same, which means I did it correctly. But neither version seemed to work.

Has anyone had any success in updating their sensors with this using the firmware updater app?

I had issues with one of my US version ones but it did eventually take.
Did it time out or say please wake sleepy device?
Try going to the Zwave page and repair or refresh the device then update.

All my devices are powered so no sleepy message.

I'll try this but the one I tried bis basically next to the hub, 2M direct line of sight.

All mine are powered as well still got the message a few times.

I watched it the whole way through last night it never gave me a message during then said it completed at the end. I then went back into the app and it still said 1.13 :thinking:. Has anybody else updated the firmware on the EU version? I wonder if it's updating but they forgot to change the version line?

I have tried it, but it does not look to work.

After doing the upgrade using the FW 1.14 it completes 100% but the FW still seams to be unchanged.

Has anyone else done this?

1 Like

After the firmware update completes my US version did not show 1.14 immediately.
I changed the DH back to "AeotecMultiSensor6 2.0.1" by cSteele.
You could also try power cycling the Aeotec or configure and then refresh

That's exactly what mine does.

I'm still wondering if it is updating but there is a mistake in the code that the version number didn't get updated?

I'm not sure I got all the steps memorized BUT... I updated one of my Aeotec MS6 to v1.14 a couple of minutes ago and got the correct value showing:

Screen Shot 2021-01-22 at 12.35.41 PM

It's pretty much the first time I've used the built-in Device Firmware Updater tool. I got the hex file and added it into the tool. Took 3 swings to get it to complete but eventually it did. Then, using "my driver" I turned on debug and clicked Save Preferences. I know that that step does a config and I watched the Logs... when it finished, I refreshed the Device Info page (because the State Variables area is not dynamic,) and the image above was showing.

Do you have a C7. I was under the impression the old zwave firmware updater tool was for most hubs, but now with the built in version, it's only for the C7.

For some reason I was stuck back on version 1.7 of your driver, and the import function was not working. Copy and paste ftw. Thanks for all you do with this driver.

Yes, I have a C7 and yes, I used the built-in App... first time.

The previous 4 years I've used a Secondary Controller and Aeon's PC based upgrade tool. We had no choice til this 1.14 version.

All the rest of my MS6 are on my NOT C7 hubs... so I'll have to use a) Bryan's previous or b) a Secondary Controller.

I specifically did this test for the simplest of reasons.. did the 1.14 version show.?? LOL.. my goal was to make sure 'my driver' wasn't a problem... turns out, for this, it's not :smiley:

1 Like

Will I can confirm, it doesn't work or at least the EU version.

I have my own version of driver for this device and it's still showing 1.13 even after several power cycles.

Going back to the good old way.

Download the Hubitat app