Adding user lock code failed on schlage lock

The lock shows up as a device under the Devices menu. Select the lock and you will be shown the Device config/details page.

Yes, adding lock codes to schlage locks is broken, either via LCM or directly from the driver page.
I'm expecting a dedicated schlage driver to be completed and released in platform 2.1.1 that will resolve this issue as well as a failure to report physical changes.


Thanks Yap. Interesting, I can see where I think it wants this info, but it also wants position. Not sure what that means. I thought you needed the app to do it.

Thanks again.

Thank you.


Thanks much.

This is fantastic news!!! Thank you so much for all of your work on this!

CC @waynespringer79


Schlage locks can have up to 30 codes. Each code has a position of 1 up to 30. For example, the 2 codes that the lock has when factory-default are position 1 and 2.

If you’re looking at the lock on your device page, you’ll likely see on the right hand side of the page (if on a desktop browser) a single number next to each lock code. That’s the position.

When creating a new code, make sure to use a position (any number 1 through 30) that doesn’t have a code assigned to it yet. If you want to overwrite a code with a new one, then enter the position number for the code you want to override.

Hopefully that helps!


Just finished watching tonight's Hubitat Livestream and was disappointed that no updated news had been given on the "Locks issue", then I see this post......THANK YOU @mike.maxwell for your hard work on this it is very much appreciated!!!!

Thank you @craigspree for tagging me.....this made my day!


Is there a date for this to be released. I just got a new HE and the BE469NX lock and no luck. Tried all tricks from other threads and the lock refuses to pair every single time. I loose count on my number of tries.
I am really frustrated with this, please can someone help before I decide to return it all to Amazon? Can I have early access to the new driver? Do you need help to complete it @craigspree ?

It is in software version 2.1.1.x - the current version is, Make sure you update your HE to the latest version.


Then it sounds like I already have this, but still my lock refuses to pair with HE. I don't what else I can try, sounds like something is wrong either with the hub or the lock. Is there a way to debug it on HE ?

How far is the hub from the lock when you are pairing? They really need to be within a foot of each other to pair. Also try to do a zwave exclusion first. Also after it paired, make sure that it is pair securely or else it won't work.

Also, how good is your mesh? Do you have repeaters between the hub and the lock?

1 Like

I assembly a long ethernet cable and set it few inches from the lock but no luck. The exclusion works very fast and I get the green icon symbol of ok. But when I try to pair it doesn't work, always get the red icon after 5 to 10 secs.

This is my first z-wave device, I have just started my project and choose HE after researching for a while. I also have a zigbee motion sensor that is working fine, and a couple of wifi devices I've burned tasmota to it.

I can try it again one more time if you believe the distance between them might be an issue.

Open live logging while you are doing the inclusion process. Be patient as it can take some time. If this is your only zwave device then you might have issue if it's too far from the hub once you get it to paired. If this is still within the return period from Amazon then I would return it and get a zigbee version.

If you think zigbee is better I will return this one and buy the zigbee version.

If that is your only zwave device and you do not have repeaters/extenders/amplifiers, you will definitely want the zigbee version. If you do have extenders etc. you need to pair those first to help build your mesh. Yes the zwave "locks" must be next to the hub during paring (especially without any repeaters/extenders/amplifiers)

1 Like

I don’t completely agree with the need for repeaters. My hub is 15 feet away from my front door and I am fine. I only have five z-wave devices in my mesh right now. Z-wave is in the 900mhz range and has a much longer range than Zigbee in a single hop. Yes there can be more noise in at 900mhz I know, but still Plus he had the hub right next to his lock while attempting to pair so clearly this is not the issue.

I suggest a factory reset even if this is the first time this lock is being paired. A video of this is available here:


Ok. I got the new Zigbee model, after installing it I runned one of the factory code and tried to pair with the Hubitat but it didn't work. Then I tried a factory reset and still it doesn't pair. Now I am feeling like I am missing something. Neither version (z-wave or zigbee) are working with my Hubitat hub.

I notice on the Schlage manual a mention that some hub might need me to enter the code zigbee code from the label. But I cannot see where to enter this code on Hubitat.

:pensive: frustrated

Okay. I just figured out what was the problem! For some reason, when using the browser on my phone it didn't show the lock. When I use the interface on my chrome running on my MacBook it found the device apparently. I will run some tests now to see how well it works.

Glad you got it worked out.

Yes I have noticed that a phone browser often doesn’t display some things you need to see.