Adding user lock code failed on schlage lock


#1

Update: Tried it for the zillionth time today and it finally worked. Not sure why the issue was happening. It only took a week. lol...

I can control my Schlage lock without issue, but it won't let me add a new user in LCM all of a sudden. I has let me add other users, just not now. Like I said, I can lock and unlock it, but can't add a user in LCM. It just says failed. Hubitat also had an update last night.

I have repaired zwave and it still won't work.

Any tips?

Thanks.


#2

Are you using lock code manager, or directly adding a user & code from the device page?

Edit - I've had issues with LCM.


#3

Yes, with LCM. I edited post to add that.


#4

Can you add directly from the edit device page? Trying to determine if it's a device issue or app issue? Can you command the lock to lock and unlock from the edit device page? Z-wave or zigbee variety?


#5

I was having some similar issues. I was not able to control the lock, but it was reporting the status if I manually unlocked it and also the battery. I was not able to edit or add lock codes either. I unplugged the batteries and plugged it back in and everything worked for me again.


#6

Did you delete all lock code from the lock, then try adding them from LCM? This is a Schlage quirk.


#7

Can't speak for the OP, but I certainly did that. LCM failed when I tried added codes to two locks at the same time (FE599, BE469). Works perfectly with the BE469 every time.

Ultimately, I ended up using the device page for each lock to add codes.


#8

That should not be. Tagging @mike.maxwell


#9

I think I saw in another thread that someone had sent @mike.maxwell a FE599. If there is still a need for an FE599 to be sent, I am likely to be able to do so after June 15th.


#10

I just installed Yale Assure SL with ZWave module. I was able to add two users and code to the lock via the device page. I then added Lock Manager and tried to add a third. I submit, but the job fails each time. Device page attempt with same name and code won't work now.

Any idea why LM can't successfully insert user and code and why a failed attempt seems to prevent submission on device page?

Logs look normal.


#11

I can command lock and unlock with HE app. Not sure what the edit device page is other than the LCM?


#12

Unplugged battery and still have issue


#13

It wont save the code to begin with.


#14

I dont know what the device page is to add codes on? Where is that? I know the device page, but I see a chart with stuff.


#15

I looked at the logs and found this:
dev:652019-05-26 03:25:20.405 pm warnchangeIsValid:false, length of code "####" does not match codeLength of null

The #### is the 4 digit code, I edited that to post here. Lock is setup for 4 digit codes and all the other 4 digit codes work, I just cant save new ones to it anymore with LCM. Again, I can lock and unlock the lock with HE, just cant add user.

Thank you.


#16

Tried it for the zillionth time today and it finally worked. Not sure why the issue was happening. It only took a week. lol...


#17

The lock shows up as a device under the Devices menu. Select the lock and you will be shown the Device config/details page.


#18

Yes, adding lock codes to schlage locks is broken, either via LCM or directly from the driver page.
I'm expecting a dedicated schlage driver to be completed and released in platform 2.1.1 that will resolve this issue as well as a failure to report physical changes.


Schlage z wave lock
#19

Thanks Yap. Interesting, I can see where I think it wants this info, but it also wants position. Not sure what that means. I thought you needed the app to do it.

Thanks again.


#20

Thank you.