- Zigbee plugs are found but do not function

Upgraded to 2 days ago. Since, I have had zero response to Zigbee plugs which are a combination of Sonoff S40 and S31, and Dogain. The plugs show up on the Zigbee Network Graph (beta) immediately along with all other Zigbee devices. But, they do not respond to on/off or any other function through device details. I have tried restarting the HE, shutting down/restarting, rebuilding the zigbee network, and just tried restoring to ~2.2.8 without success. 2.2.8 doesn't seem to work at all with error 500 when I attempt to drill down on a device. I have restore back to latest backup. The other Zigbee devices seem to work. (Most of which are Aqara)

What gives?

1 Like

Have you tried resetting the plugs and re-joining them? They will slot right back into your hub and all their automations. Don't remove them from the hub, just reset and re-join them.

If the issue repeats, then more troubleshooting may be required. had no changes to Zigbee or areas that would affect Zigbee devices, it is unlikely that the plug issues were connectected to the platform release.

1 Like

Thanks for the quick feedback. The only thing I find weird is that every single plug is showing but will not function. I can reset them as you mentioned and I'll see what happens..

I tried resetting 2 plugs and they don't even get recognized during the zigbee pairing. This just doesn't make sense. All plugs seem impacted. I am stumped.

That is pretty weird I don't remember hearing about anything like this.

I'm a bit stumped as well frankly.

What platform version were you on before you updated to that 3.9.157?

I checked my backups and I had a few builds on 239 and prior to 238. I typically update whenever the new builds come out.

1 Like

Just wanted to confirm that the update wasn't some huge jump from a really old version.

Just sharing, I'm having this same issue. Was super stable, now no Zigbee device responds

Edit since I'm jumping into a thread.

Few days ago things were fine.
updated to .157 (maybe a previous update), and now no zigbee device works (third reality, the unstable-but-ok-for-me peanut, or samsung). Doesn't update state, doesn't send signals, and cannot even add devices.

Thanks for confirming Steven. Have you attempted to rollback? I tried to going back to and things were even worse as mentioned. I may try a factory reset today as my network is now hooped. The repeaters/plugs are all flashing that I have tested. (which won't pair)

I went back to .140 and that definitely didn't help. All of my zigbee devices are essentially dead.

And in case you didn't see there, there is another thread with similar issues. Zigbee issues since upgrade? - #74 by jtmpush18

There's nothing in .157 and other 2.3.9 releases related to Zigbee changes. There have been a few reports of issues but correlation and causation are easily confused. There have not been a flood of reports of Zigbee problems from 2.3.9.xxx), so unlikely the platform release is the root cause of problems...

If you want to confirm if the platform release is the issue, use the Diagnostic tool to revert to, the final release of that platform version.

Restore Previous Version

Returns the hub platform to a previous version, leaving the existing database intact. If you experience problems and suspect a recent update as the cause, this is one step you can use to test.

Select Restore Previous Version, then select the desired version from the list. Confirm with Yes, then wait for the version to restore. The hub will reboot automatically when finished, then display a Success message in the Diagnostic Tool with a link to the main hub interface.

2024-06-28 09_06_11-C8, C7, & Misc Hubs


If you don't have in your list in the Diagnostic tool, you can get it via a hub endpoint.

After the roll-back you can do a reboot and select the option to rebuild your database and see how things behave, if plugs can be re-joined.

I would not do that yet...


Restoring a backup does not roll back the firmware. It says this in multiple places on the hub UI where the buttons are to restore backups.

Just make sure you change the endpoint to /238 to download 2.3.8

What hub model?
What Zigbee Channel and Power?
What is your Wifi 2.4Ghz Channel?


Thanks I will follow the diagnostics process.

Looking at other thread:

I have solid network separation on AP's and channels. My default channel is 20 already. I learned how critical this was almost a year ago. This is definitely not a channel issue.

Do you have a C8? I don't think you ever said what hub model.
There have been some issues recently with channel 20, unknown cause. Try switching to channel 25 and then pairing one of the problematic devices again.


Good point, Jeff.

@goldbond1 - switching to 25 may provide better Zigbee results across the board, so this could be a good time, while you're working on your Zigbee issues, to flip over to 25 for Zigbee. Can take a day or so for devices to find themselves on the new channel, and some may need to be power cycled or reset/rejoined to connect on the new channel.

1 Like

go back to 147 a they will work again

Diagnostic/restore was very brief. Indicates I am on I do have a C8.
I tried pairing the plugs and no joy. They are not recognized.
I'll try channel 25 now. I'll report back once complete. (tomorrow) Will continue testing.

1 Like

OK, thanks. Before you start trying to pair devices, do the shut down/pull power/wait 30/restore power dance so that the radios get a restart and are "fresh."

If you have another hub that you are not using, make sure it's turned off and then unplugged...just leaving turned off does not turn off the radios.

1 Like

make sure you update 1st again. After having issues on 20 I moved to 25 on my c8 and things have been fine since. Most devices changed channels but I had to re pair a few. My hub has been happier since. (also make sure your wife is at 6 or below)

1 Like

I hope I have the sequence correct:

  1. Downgraded to 140 (note: I do not have 147 and I do regular backup/updates)
  2. Power down/restart. (no other HEs)
  3. Channel change to 25. Wait app 24 hours.