[][C8] ZigBee Devices Non-Responsive


After updating to .124, I had a few Aqara FP1s that stopped responding. Tried power cycling the devices, with no luck. I finally powered off the hub for 15 minutes, and booted back up. No luck.

I've also found that my Iris v2 motion sensors are not responding along with 9 Sengled RGBW bulbs, and 5 Ikea shades.

Does look like my SmartThings motion sensors, two Third Reality buttons, three GE ZigBee switches, and three Xbee ZigBee 3.0 devices are still working.

I'm still on .124 so logs can be grabbed, etc. Attached ZigBee logs, regular logs with debugging enabled, and ZigBee routing table.

1 Like

Very odd, ive updated three production c8 hubs to 124 without any issues like this.
Any chance between now and the last update that any of your routers were moved or unplugged?

Negative. I updated this morning and that's when things stopped working. I left for work right after. Everything was still having issues when I got home several hours later which is when I did the power cycle. That was 2.5 hours ago.

Your post scared me (I have Aqara contacts and buttons, Sengled bulbs, and Iris v2 & v3 motions) so I did a double check but all of my stuff is still fine/active. So bizarre how some of these instances appear seemingly out of nowhere...

Most recent change was you implemented your Xbee devices recently, right?


FWIW, I did jump from .121 to .124

Yeah, I've taken all of the updates as offered, but that shouldn't matter.

No issues here on 124 either, with a lot of Iris v2 devices and Sengled (no Aqara here - but it sounds like you don't have Aqara outlets; the sensors are less likely to create the kind of issues you've described). This sounds like one or more routers are misbehaving, which unfortunately wouldn't show in engineering logs. Troubleshooting misbehaving routers is more or less a local task, but I am sure you knew that already. May need to remove any recent mains powered devices that you have introduced in your system.

I think I'll just try a rollback. I stayed in case anyone wanted to troubleshoot. The Xbee devices were the last thing added a week ago, but no issues until the firmware update today.

Try the rollback, but if that doesn't work, I would look into checking routers individually.

As I responded in another thread, after updating to .124 this morning one of my zigbee Kwikset locks that has been rock solid for at least 1 1/2 years dropped off line with 80% battery. After fiddling with it for a half hour I gave up and rolled back to .123. The lock is now operating normally. No recent changes in any of my zigbee devices and no new zigbee repeaters in months.

After the rollback, the same devices are not working. They won't re-pair either. I've tried pairing while standing with the device a few inches away from the hub with no luck. I've removed the Xbee repeaters with no luck. I removed, factory reset, and re-attempted pairing an FP1 with no luck.

I can understand the sentiment of clearing house, but when the problems started with a firmware update on the tail end of a trail of updates to solve ZigBee connectivity issue, I don't think the first inclination should be that there's a problem with a device. My suspicion is that .124 has broken something with the ZigBee stack on this hub and rolling back didn't correct the problem.

These devices are scattered all around the house. The repeaters were scattered all around the house. If this were a problem with one or more repeaters, I would expect that the problem wouldn't be focused to entire device types. There's also devices sitting a foot apart where one is not working but the other is (motion sensors I never took down after getting the FP1s).

The one Sengled bulb is no long functioning, so now I'm at 10/10 that are unresponsive. All six of the Aqara FP1s are not working. All five of the Ikea shades are not working. I double checked and only have one Iris V2 motion sensor, that is also not working.

I did several tests with an existing FP1 and a brand new FP1 pairing to C-8 hub, platform - it works OK in my environment.

Hope you will find the reason for the issues and will restore your HE working system.

1 Like

After an EXTREMELY frustrating afternoon I've finally gotten all my devices reconnected. Absolutely nothing I tried worked until I randomly had the idea to readd my Ikea repeaters. I went through something like 10 cycles each of trying to re-pair a Sengled bulb and an FP1 in the same room as the hub with no luck. The Sengled bulb wasn't even being found. The FP1 would continuously get stuck at initializing, even trying the legacy mode.

As soon as I hooked one Ikea repeater back up, both devices were instantly found and included during pairing. I added two more Ikea repeaters back. After a short power cycle, the rest of the devices did not recover. I ended up having to run around and re-pair every device.

If I were a new user, this experience would have pushed me to a different platform.

Really odd...all of my Sengled were originally added w/zero Ikea repeaters, at that point just Centralite plugs primarily. The bulbs worked w/out issue for years, and and fell into disconnecting problems some months ago on both my C7 and C8 (regardless of the fact that I had added Ikea repeaters a year or more ago). These Sengled behaviors have been inconsistent across several reports from different users. Mine are nicely solid now on the C8.

Curious - .125 is out...are you going to take a backup and see what happens?

Maybe this weekend. At this point I'm wondering if using the migration option isn't what got me. Before doing another upgrade, I'll need to be in the mindset that if things stop working again, I'll need to reset the ZigBee radio and just rebuild the mesh from scratch.

Inevitably someone is going to think the aha in all this is that I needed more repeaters, but I don't believe that's the case. The Xbee repeaters had been carrying the mesh for a week, including though a reboot on Saturday due to memory sitting at 75 mb. I'd even noticed better response times from motion sensors after replacing the Ikea repeaters with them. This wasn't even a case of increasing the number of repeaters. The three Xbess were installed exactly where the three Ikea devices were.

The precipice for all this was the firmware upgrade to .124 yesterday morning.

1 Like

Now I'm wondering if this wasn't my problem. I did turn the option off, can't recall exactly when though. This would've definitely resulted in the symptoms I had.


Yeah, I have that option to "rebuild upon reboot" off since I thought @mike.maxwell said that option was going to be removed sometime soon, but now I can't find that reference.

And it's possible I just dreamed that up anyway.

Did we ever confirm if the "reboot" mentioned in that option refers to a hub reboot or a ZB radio reboot?

Yes, I remember the same, that he said recently that the option is not going to be there long-term, was more of short-term intevention provided while things were going a bit crazy w/Zigbee on the C8.

It means hub reboot...covered in Zigbee documentation here: Note "...rebuilding the Zigbee network on demand or every hub reboot..." (Credit to @Eric.C.Miller for noting the info in the HE documenation in another topic.)


First time I noticed it was after the reboot following a firmware update... it can definitely bite you if you're not expecting it.

How did you figure this out?

I don't recall seeing anything about it via release notes (could've missed it). I've been trying to stay up to speed on the other ZigBee related threads, but it's a bit difficult.

I can imagine this may have been my original issue, but not realizing, made matters worse when trying to TS in the dark.