[] Lights Activator doesn't pick up correct state

Im not sure when it started, but noticed after None of my room lighting rules work (again, ill add, as they stopped after each post-beta update until I tweaked them), I tracked it down to the activator device doesnt get correct information form the group state. Bulbs can be on, with a color temp, and at 20% and the activator states 100%, and a completely different temp. Re-starting the activator device does not work, but manually triggering the activator application works. This means that none of the rules that call the activator device actually work as all activator devices have completely wrong state information. Am I doing something wrong? Why wouldnt the activator device pull from the actual activator? Pulling my hair out! Thanks all.

Edit 1: I see an error in the log:
org.quartz.JobPersistenceException: Failed to obtain DB connection from data source 'myDS': java.sql.SQLException: Connections could not be acquired from the underlying database! on line 973 (method mainPage)

Click on the device or app number in front of that error (like below) in the logs and the source of the log entry will be highlighted in the list of devices/apps above in the log page. Add that info to your post, might be helpful.

App:626 and dev:606

I’ll note I’ve tried to configure every which way (by the way this was working great the past couple years…). The activators just don’t seem to have a clue the actual state of the light after the last update which leads to none of my light switches working. It’s super weird and it started after this last update or the previous one, but I’m pretty sure it started after .130

Edit. After much complaining in the house I rolled back. 130 is super buggy for me and so I’ll chalk it up to a bad update. Everything works as expected again.

1 Like

Thanks - for next time want to clarify I wasn't asking for the app/dev number, but their names that are highlighted when you click on the app number or dev number. The app of device in the list of apps and devices above on the logs page is highlighted when you click on the app:### or dev:###. :slight_smile:


Man I wish Groups was still an option, room lighting is awful. Like a dummy I converted my groups to room lighting automations and deleted groups so i'm just screwed, I guess. It is possible I just randomly started having my hub go bad but we will see after the next update. Its weird because I was in the beta and everything worked as expected, then boom, first updates after beta completely wreck my entire lighting setup for some reason.


Can you revert back to an earlier version? I had some problems after I updated to 130 that went away after I reverted back to 128, which might be a beta. Somehow, I don't think I'm in the beta program anymore.

I reverted to 127 - works somewhat better but still not great + my hub has just randomly rebooted like 6 or so times today.

Your hub randomly reboots? I've never had that happen. Could that be a loose power connection? I'm just a simple automation guy, maybe one or two rule machine. Good luck.

Ya, I feel the same way. I’m trying to figure out how a fireplace and shades are “lighting” and was told “shades let in light”. I suppose my fireplace “lights up the room” and a door should be under thermostat as “ventilation”
Groups of things non related in grouped areas makes more sense. I don’t consider my patio and surrounding area a room, but it’s a great group of dissimilar items.
I’ll take this argument to my grave.


I have worked for hours on this and the setup I have now seems fingers crossed to work about 75% as good as groups. Basically I have my room lighting tables, 1 for each room, with the desired color temp, level, and force enabled. I then have under activator, the actual activator device. Its a bit counter-intuitive as the room lighting activator states that is should be already controlled by the activator device but I still had to add the device manually as an on/off activator to get it to actually activate. That works well enough but I get a bit of pop-corning, where the lights will turn on and off 1 at a time. That never happened with groups. I have tried all the settings, and it doesn't seem to matter if ZGM is on or off it still doesnt activate as a group based on the table it activates each device in the group separately. IIRC rule machine has (had?) an option to set the bulb states prior to activation which really helped this as then all I would do is turn on the lights and they would....turn on at once. Im super curious to know what changed, but we can at least control lights again now, albeit in a popcorn-y way.

Another option that I see potentially is setting up multiple activator devices, basically a button that turns on and off for JUST the light switches and a separate bulb activator for color temp control, as if I only use the bulb activator it tries to change color on a temp only bulb every time and screws up the level. Its interesting. Ill turn on a bulb using the bulb activator and it will turn on to 20% brightness, and 6500K temp, the activator device will say its happily at 100% and 2430K or something, and bright red, and I pull the rest of my hair out. I then change the color (on a color temp only bulb) to white and it immediately goes back to 100% brightness matching the activator device, though the activator device still has no clue what color temp it is even though the activator table clearly shows the right temp. Im thinking 2 way communication doesn't exist between the activator and the activator device which doesn't make sense to me but Ill keep messing with my test bulbs to see if I can get it any more consistent.

Edit: Just checked my hub events log again and noticed its rebooting a ton, possibly has something to do with some of the issues Ive been having here, we will see. After updating my rules for morning and nighttime Ill monitor and make sure they fire per the table settings. Morning rule went fine this morning but I was on .125, I updated to .130 after that and thats when the reboots started again. Will update when I find out more.

Nothing about Room Lights prevents you from doing this. Did you miss the last part of this:

You certainly don't have to use Rooms to set it up, just put in the devices you want to group together.

Groups are very simple in RL: Pick the devices, name the Activator Device, done. That will act as a group, just like the older app. If what you want is just a group, ignore all of the other aspects of RL.

1 Like

You should show your RL setup page, as this does not make sense, and is not needed if you have RL create the Activator device (just like Group-2.1 creates its activator device).

This sounds like you don't have it set up right at all.

The lights will follow the activator device, just as they did in Group-2.1

This again sounds like you don't have it set up correctly at all.

The Activator Device overrules the table. In fact, for a group the table isn't even used other than that it shows the current values of the lights. The Activator Device commands all of the grouped devices to follow it.

It sounds as though you are confusing a Scene and a Group. A Scene has different values for each light, and the Activator Device either Activates it or Turns it off -- used only as a switch. A Group is a bunch of lights that follow the settings of the Activator Device.

See this post:

Ive been over that a few times, maybe I am confusing Scenes with Groups. That being the case, my assumption is, correct me if I am wrong, that the proper way to make sure lights always turn on at a certain temp and dimming level is to make a rule machine rule to do so using a virtual switch or something like that?

Could you just say in English what you want to happen and what should make it happen.

I’ll try :slight_smile:

I want to turn on all the lights in a room to 100% and 6500k temperature using a virtual dimmer and a physical switch. The virtual dimmer is passed to homekit where I have the ability to control color temperature and brightness. That’s basically how I had groups set up before. I’ll note that it works almost like that now, with the exception of the pop-corning.

What kind of lights?

Are they all Zigbee?

All zigbee

Assuming these are Zigbee bulbs, using the Activator Device to turn them on should not have any pop-corning. Is this what you're seeing?

However, turning them on with a switch wouldn't use Zigbee Group Messaging, so you would get pop-corning, unless you do that in a rule outside of RL, and that rule turns on the Activator device (Basement Lights). When the Activator Device turns on, if they are all Zigbee, it will issue a Zigbee Group command to activate them. Look at a Logs page, and if you see "on (Z)" that's an indicator that it is using ZGM.

Remove the 'Switches that turn on' Means to Activate. Remove the 'Command devices on/off irrespective of...' option. Remove 'Activate even if partially Activated' option. Change the Indicator option from 'Group Any On' to 'Group All On. Remove the 'Switches that turn off' on Means to Turn Off Lights. Remove the 'Turn Off even if already partially off' option. Then hit Update.

Make those changes and see if it doesn't work better.


Made the changes in a new test lighting rule and same results except this time it turns on the lights to 20% but says they are 100%. If I activate manually in the actual light rule it activates properly. I mean…correct me if I’m wrong, but really I shouldn’t be doing anything with the switches directly, I’ll need to set up rules for them in rule machine. Is that accurate? So I set up the “group” but it may just be easier to call that group and set parameters in a rule machine rule, the only downside is homekit won’t show the true Light status since the activator device doesn’t sync up with the group State.