[ C7] Apps Not Running?

I have an app that should be executing (the trigger appears in the log), but it's not running (although the trigger appears in the log, I don't see the app actually firing).

Namely, in this case, it's an RM4.0 app that is triggered when my Ring devices switch arming states.

The (user) Ring part is working, as I see those devices changing state and I see the app's trigger.

However, none of the actions in the RM4.0 app are happening--nothing is in the logs.

I rebooted the hub. My "Arm Home" stuff seemed to work and things ran (and the HSM re-set itself properly). But, the routine simply isn't running properly on a "disarm".

This had been working fine. I rebooted, etc. No luck.

The triggering event is noted in the log--but the RM app isn't actually being invoked.

I did a soft-reset and restore. No luck Same thing.

Here, you can see the device changing state AND the trigger being recognized:

This should have run--but this RM rule never actually fired (nothing in the logs):

Oddly, the App's Event list does NOT show it going to "Off" since yesterday:

App details:

@bobbyD @gopher.ny Any ideas why this suddenly isn't firing right?

I had a couple of 4.0 apps not fire today but it was around the time I uploaded the last hotfix.
As they were small rules I just re-did them in 4.1.
Should have investigated further I suppose.

@bravenel @bobbyd @gopher.ny

So--I backed off to and it worked fine:

I also had a rule that didn't work as normal today. One common factor is that the rule uses a "NOT" condition I wonder if that is the culprit?

I my case, it seems to be related more to the triggering.

The rule fires in one case but not the other--even though the event is recognized both times.

I just had another set of rules fail.
I don't think I'm willing to go through this again.
Back to webCoRE much as I hate to.

Which hub/rule was it?

I have exactly the same issue. I just put up another post before I noticed yours here. Exact same situation

Just spotted this.
I've already re-written them (2 hrs I won't get back :slight_smile: ) in 4.1 so they no longer exist in 4.0.
All were timed rules.
Curtains closing.
Un-pausing various rules at specific times/conditions.
RM 4.0 mode manager rule not changing modes.

Before the last hotfix the rules were painfully slow to edit but worked. Latest update and some rules did not trigger.
I had rebooted the hub after the first rule failed to make sure all was OK. Looks like that didn't work.

Also, see: Issue with HSMstatus and rule machine?

so when you re-wrote the rule in 4.1, the problem went away?

I am having a very similar problem. I have a couple rules that have been working for > 1 year, no change to the rules.
I have global variables that get changed in one rule and these globals are then used as a trigger to another rule. What I noticed is that a change in the global variable no longer causes the other rule to trigger.
As a work around I added one of these to the bottom of the 1st rule and now the 2nd rule is triggering.

Run Actions: Bathroom Kids - Master Controller

I pretty convince there was a regression in one of the recent updates, I'm currently running:

I'm just hoping that the rules I've re-written in RM4.1 will work going forward.

Oh I so do not want do have to re-write those rules. I've got too many that are still 4.0 )-:


I believe we identified the root cause. There will be a hotfix. No rule rewrite is necessary. Please roll back to 133 if you run into the issue.


Thank you kind sir.. You are a gentleman and a scholar.. (-:

1 Like

W00t!! Thanks!!!

1 Like should take care of it, please give it a shot.