2.2.5 …… when?!?

You asked. They delivered. :wink:


So what I said was right on the money. :wink:


Now: Release 2.2.5 Available


Good job, HE team.


I'll bite! Cheers!


There are several bug fixes not listed.
Settings > Location, map image is fixed. See:

Doing more regression testing now.

1 Like

I'm a noob to Hubitat but I tried to update and it didn't go well. After sitting at updating for over 30 min I restarted and the hub just sat and did nothing. I rolled back and everything is fine. I guess that's what I get for trying within hours of release...

Edit: Hub is a C7

Dunno. I upgraded all 5 of my hubs as soon as it was released. 2xC4, 1xC5, 2xC7.

1 Like

I checked the logs - don't see it actually trying to run 2.2.5 at any point. Looks like it was stuck on all along. Could you please try switching to 2.2.5 from diagnostics tool at http://your.hubs.ip.address:8081 ? It should be, ironically, under Restore previous version.


I started giving it a try again the normal way before your post. If it fails again I will try from the tool.

1 Like

Really appreciate the Networking settings and digging the new combined Logs page!


THere were rumors of a chromecast initialization fix precluding the use of other apps/rules to keep the initialized. Anyone know if that made it in?

I believe that the link should end in :8081, not /8081.

Might be confusing for a newcomer.


Second try. It still hung at applying update for 20 min. During this time the diagnostics tool showed it as running 2.2.5. I shut the hub down again but this time when I powered it back on it started the boot process and loaded 2.2.5 just fine. shrug

1 Like

Still Regression testing. Bug of Support Request 19767 appears to be fixed, may be a side effect of the fixes to ensure all battery events, even repeated events, are now reported.

Support Request 19767

Issue: Built-in driver for Ring Alarm Extender not reporting power status or events after initial mains to battery change. Repeatable for 6 Ring Alarm Range Extender v2 devices.

C-7 on, 6 Ring Alarm Range Extender v2 devices, all paired S2, all using the built-in Ring Alarm Extender driver, fairly vanilla setup.

Has something changed since December 14, 2020, with power source event and status reporting that would affect the Ring Extender v2?

I got these Ring Extender v2 devices after seeing Bryan Copeland’s recommendations. I got the first one the last week in August, and added 5 more, and added the sixth one on December 14, 2020.

When I got the first one, I thoroughly tested, and the power (as reported on the driver page) would change from mains to battery and back to mains as I unplugged and plugged the Ring extender (both on the driver page and reported events for notifications). All seem to be the same firmware level, all are using the built-in Ring Range Extender driver. I attach screenshots of the Drivers page for a representative device. On December 14, when I got the sixth one, I tested it, as well, and it also correctly reported each change from mains to battery and back to mains as it was unplugged and re-plugged, etc.

However, now with, all will report the first event (mains to battery) when they are unplugged (or lose power as by a whole house power fail, as happened today), but none will report restoration to mains on the driver page or in events when plugged back in or when power is restored. I’ve tried refreshes, etc., just looking at the state in the driver. Rebooting the hub does not cause the driver to return to “mains” status. Shutting down the hub, removing power, then rebooting the hub, does not cause the driver to return to “mains” status.

I can only get them to go back to reporting mains by the following:

(1) change the driver to built-Device, hit Save Device, hit Configure.

(2) hit deleteAllStates

(3) change the driver back to built-in Ring Alarm Range Extender, hit Configure

It’s not a question of just waiting a while in case the driver or system has a delay to avoid power source flapping during a true utility power failure event. I can wait hours after re-plugging, the “battery” status will stay until I change drivers, clear events, change driver back, which restores the mains status. I have to do this for each device.

See attached screenshot of the device events page. Note that power events reported correctly on December 14, when the device was first installed, but, as of this week, when there is a power fail for the Ring Alarm Range Extender v2 (whether by true loss of power, or by unplugging the device), the initial power fail (power changes mains to battery) will always be reported, but the return to mains will never occur until I change drivers, clear events, change driver back, which restores the mains status.

Now, I do have a rule that refreshes the Ring Extenders on systemStart to handle missed events, but that doesn’t explain why the mains status doesn’t return while the hub stays up, nor why the mains status doesn’t return on system reboot when the SystemStart refresh is done by my SystemStart rule.

No problems otherwise, all Z-Wave devices working fine.

1 Like

So the radio backup feature didn't make it into 2.2.5 either?

I tried to update last night with the same results. It all crashed and the hub is non-responsive now. I did save a backup locally right before initialising the update. However, I am not sure how to restore it (I am new to this as you can tell). I've tried to follow some brief instructions in the documentation but http://cloud.hubitat.com doesn't work for me either, so I have no idea how to get to any screen where I can initialise the recovery.

Anyone help pretty please...?

@gopher.ny, @bobbyD, @patrick (sorry guys, found your names in another thread, but ignore if you are not the right people to help...)

Read all of this to the end before starting.

Briefly, you are going to go to the Diagnostic Tool, do a Soft Reset, restore the backup you downloaded to your computer, and restart.

(1) go to the Diagnostic Tool.


(2) log in (the bottom button). Password is your hub’s MAC address, printed on the bottom of the hub, in the form:


(3) click Restore Previous version, choose the hub version (presumably, you were running before the failed update. This reverts the firmware.

(4) do a Soft Reset: click the Soft Reset button, type

soft reset

in the blank, click the button.

(5) you will be taken to the setup page. Scroll down to the link:

Restore from backup?

(6) Click that, choose your backup file you downloaded. This will restore your database.

When the backup has been restored, restart.

Now you can try the update again. Hope this helps.

It may be, however, that the original update succeeded, and your hub just did not reboot properly after the update.

When you initially log in to the Diagnostic Tool, look at the Platform Version. If it says, the update happened but the hub just didn’t restart properly. So, before doing the rest of the steps, simply try to shutdown. When you see the red light, remove the power (at the wall, not at the micro USB connector, which is fragile and can break the solder joints), wait 30 seconds (to reset the Z-wave radio), then power up, see if hub boots to green light. If not, then do the Diagnostic Tool steps from (1) to the end.

Hope you get back up.


@672southmain - thanks a lot for the detailed instruction. However, I cannot even get to the Diagnostic Tool. I've tried Brave, Safari, and Chrome and always get something that looks like that...

Could you try an incognito mode in the browsers? What color is the light on the front of your hub?

FYI, Patrick changed jobs, no longer works at Hubitat.

1 Like