2.2.4 and SmartThings Arrival Sensor V4

For whatever reason, my SmartThings Arrival Sensor V4 is flipping between present/not present every few seconds. This started with 2.2.4 - here's an example from the event log.

Edit - See solution below

1 Like

Set the default timeout time

1 Like

I have. It has been at 15 minutes for ever. This started after the update to 2.2.4

1 Like

I had a similar issue during beta. But it was because no default was set. When set to 2 minutes it went away.

@mike.maxwell was on the case and I thought it was corrected. However looks like your issue is different.

Edit. Perhaps try saving prefrences once?

3 Likes

So I ran wiped state and cleared schedule using @BorrisTheCat's Clean Device driver. And then changed driver back to the SmartThings Presence Sensor driver. This seems to have fixed it.

Thank you @cwwilson08 - I wouldn't have thought to try that without your last message!

7 Likes

same with me.
all 15min delays have been wiped by this update. no need to run clean device driver.
in my case I just set it again to 15 min

2 Likes

Just to chime in on this thread, same thing happened to me and I mine set at 5 minutes. Reset the preferences at 5, and all seems to be well.
@cwwilson08 @plantucha : Are either of you using the stock button battery? My percentage dropped big time after the update.

1 Like

FWIW - no issues here with battery %.

Yeah, I might be going down that aux bat road.

2 Likes

Yeah those little cells are puny for something that communicates constantly.

I was just looking at the logs. It reports in every 20 seconds.

1 Like

no 2x AA in my case. 6 months 100%

2 Likes

I fiddled around with battery removal earlier. I don't know how many times I'll be able to do that without breaking something. And yes, I did watch the video, lol.

the tabs are too easy to break on that damn sensor.. especially when a couple of years old and they get brittle..
that is why i have a couple of extra in the basement.

for the one in my wifes car i put it in an external battery case and soldiered a connection with 2 aa batteries .. now lasts years. even though sensor is saying battery is low (probably becuase they are lithium)

3 Likes

My ST Arrival sensor V4 with AA battery mod was at 30% (or thereabout) before upgrading to 2.2.4, after the upgrade it is now at 0% !?

Mine went from 90% before, to 37% after the update. Then, when I re-included, it went to 62%.
edit: back to 37% this morning.

I just updated to 2.2.4.141 and my presences sensors are arriving and departing constantly within seconds. Which causes my automations and locks to unlock/lock crazily. Any help would be appreciated.

dev:6732020-11-18 09:37:51.651 am info Iris's Car has departed
dev:6732020-11-18 09:37:48.633 am info Iris's Car has arrived
dev:6732020-11-18 09:37:31.642 am info Iris's Car has departed
dev:6732020-11-18 09:37:28.625 am info Iris's Car has arrived
dev:6732020-11-18 09:37:11.989 am info Iris's Car has departed
dev:6732020-11-18 09:37:08.922 am info Iris's Car has arrived

Thanks
D

Set the presence timeout to be something other than "no selection" and save preferences. This has to be done even if the timeout is already set to something other than "no selection".

2 Likes

Change timeout preference (see above)

3 Likes

Thanks that was it!

1 Like