2.2.3 Update - Unresponsive C5 Hub

I have a C5 hub that appears to have gone through the 2.2.3 update. Upon restart, it is discoverable in the portal and gets me to the hub's "Home" screen where you can click Dashboards, Apps, Devices, Settings, etc. However, when I click on any of these links the browser times out.

Then I close the browser tab for the hub's "Home" screen. On the portal browser tab I click the hub's IP address and now I get NO Home screen. The browser times out.

I have power cycled the hub...about 20 minutes after the update.

Upon power cycle, I click on the hub IP address from the portal which opens a browser tab that shows the hub starting up (progress bar, 10%, 20%, etc...) It starts up and presents me with the home screen.

Once at the home screen, all of the links time out. I have even tried different browsers, Chrome & Safari.

By "power cycle" do you mean unplug and plug back in, or reboot from the settings menu or the hub's diagnostic port yourhubsIPaddress:8081? Pulling the plug can result in database corruption. You can roll back to the previous build by going to the diagnostic page where you will see the following options:

copy your hubs MAC address and paste it in to the login. You can restore from here and then see if you are able to access the hub to update it. You may also want to do a soft reset and restore a previously saved database if you have been pulling the power to reboot.

1 Like

I would check to be sure you have a static address in your router for the Hubitat. I have seen it change IP addresses upon reboot, and all heck breaks loose.

@neonturbo I already knew this was not the issue because I could get to the Hub's "Starting up" screen. Just when the home screen came up the links went nowhere. Thanks for the response!

FYI, I did mean "power cycle". It wasn't a soft reset. Again, thanks for the info. I'm grateful for your response.

@Ken_Fraleigh Good to know there is a diagnostic port! I stepped back to and all is well.

I will try 2.2.3 again when it is more convenient. Thank you for your post. Most helpful!

1 Like

Well just for the heck of it I tried the update again with the same negative result.

I'm having the same issue with my C4. Must be an oregon thing :slight_smile:

1 Like

I also had this problem with my C5 hub. Rolling back to solved the problem for now.

And, weirdly, I'm in Oregon. :grin:


The only thing I see popping out in the logs is wrong time - the hub thinks that current time is somewhere before 5/25/2015. That prevents hub from connecting to the cloud and figuring out which account it belongs to. If 2.2.2 works, I'd say keep using it for now and let us collect more information on the issues that crop up with 2.2.3. We do our best to reproduce and fix them as they come up. Right now, I can't say for sure what's broken.


Interesting you said that. I noticed this earlier. When I look at the time from Settings page, it's correct.

Screen Shot 2020-08-13 at 2.16.20 PM

But when I look at the system time via the diagnostic page, I see this.

Screen Shot 2020-08-13 at 2.16.04 PM

Just as a data point, my C5 updated just fine and seems to be working good. It did take a slight bit longer than normal to do the update itself, but I attributed that to the large number of changes. The reboot after the update didn't seem abnormal in any way.

1 Like

I've updated 2 C-4, 1 C-5, and 1 C-7 today. All working. To be fair, though, 1 C-4 and the C-5 have almost no apps on them, they are for development.

1 Like

I too have been battling a extremely slow C5 hub for the past 6+ hours.... I think the update screwed up my db so now I am downgrading everything prior to the update and see if it fixes my issues.

Yup going back to resolved all my problems.... something very wrong with the new version.

I had the unresponsive/slowdown issue with one of C-5 hubs, but not the other C-5 or the C-7. Here's what happened along with what resolved the issue (edited from a PM sent to someone):

I've had a tough time updating my Hubitat C-5 that only has zigbee devices (mostly Xiaomi - admittedly unsupported). The z-wave radio was disabled on this C-5.

  1. After the update, the hub slowed to a crawl. The Xiaomi devices threw an error. But all my zigbee devices (even the ones on the compatibility list) were unresponsive or very slow to respond. So was the web interface.
  2. So I rolled back to - everything worked fine again.
  3. Repeated the process of updating Same problem again. This time, I decided to download the latest backup, do a soft reset and restore the backup. Hub remained excruciatingly slow (device response and web interface).
  4. So I rolled back to for the second time - everything worked fine again.
  5. Then I updated to a third time. Same issue again. This time, I used the Diagnostic Menu (8081) to shutdown the hub. Disconnected power. Powered it back up again. Same problem (extremely slow device response and web interface).
  6. So I rolled back to for a third time - everything worked fine again.
  7. On a lark, I decided to enable the z-wave radio and then run the update to After the update, everything worked perfectly.

Since then, I've disabled the z-wave radio, removed power, and booted up again. Everything still works fine. So, for whatever reason, this platform update put my zigbee-only C-5 into a funky state if the update was applied when the z-wave radio was off.


Both my C5s updated fine about 14 hours ago and no issues.

Note: my C7 that shipped July 24th still hasn’t arrived !!!

Waiting on mine as well shipped July 25th so you are not alone.
But mine has to come to Canada through regular post so could be awhile.

@aaiyar I have about 20 Z-Wave devices and my Z-Wave radio was ON when I was having my troubles.

1 Like

I have the z-wave radio disabled on one of my C-5 hubs and both hubs updated without issue. I ran Hub Watchdog on both about 15 minutes after the update and the times were .101 and .103 (virtual switches), and both hubs continue to be very responsive.

1 Like

I am a Canuck as well and I just check the CanPost app. Mine is out for delivery today.

Weird. My zigbee-only hub is a C-4 + Nortek stick, so not the same as yours. My two dev hubs (one of which is a C-5) have both radios turned off.

Glad you figured out something that worked! Very strange!