Zwave Yale lock - YRD210

I'm brand new to Hubitat and I spent most of today migrating devices from ST to HE. Everything was going great until I got to my Yale lock (YRD210ZW619). This thing has worked perfectly with ST for over a year. I excluded it from ST and paired it with HE today, but there is no functionality at all. It appears very similar to Plyr58's post from a couple of days ago: Zwave Yale Lock Issues

Unfortunately, the guidance in that post is not resolving my issue. I factory reset the lock twice (following SmartHomePrimer's process) and even held the lock within a couple of inches of the hub during the last pairing attempt, but I still end up with this:

I realize I'm not getting a secure pairing and that's probably why it isn't working, but I'm at a loss of what to try next to achieve that secure pairing. Anyone have any ideas?

Thank you,

You tried power down, remove the module, power up then reset?

[Edit] Not Z-Wave plus correct? Seems the Yale non-plus are difficult to pair for some reason.

Fresh batteries?

Correct. I followed the 11 steps you provided in the other post. And, yes, I believe it is non-plus zwave. All the documentation I see just says "Z-Wave". The little box that contained the module says "Z-Wave US2.0 CP2.5.3".

I have not tried fresh batteries, but I'll definitely give that a shot in the morning. Do I need to factory reset it again with the new batteries? Or just try to pair it with new batteries?

1 Like

Hope you get this figured-out. I do have that lock and it works fine. Here is my data.


Only thing I see different is the Secure pairing. I do have a zwave always on outlet repeater 3 feet from the lock.

Here is a hair ball idea for you: When I paired mine without problems it was before they added the ability to change what was paired in secure mode. When I added mine anything that could be paired in secure mode was. Now the default is only locks. Try changing that setting to pair everything secure and their go through a full reset pair again.

Remember to change it back to pair only locks after this.

1 Like

Factory reset again, used fresh batteries, changed secure setting, and ran a Z-Wave repair...but still no secure pairing for this lock.

Just to make sure I'm changing the setting in the right place, I went to
Settings->Z-Wave Details and Set Secure Join to All Secure Z-Wave.
Please let me know if I'm missing a step somewhere.

Also, I have a hard wired Z-Wave light switch right next to this lock (roughly a foot away) that is working fine. Is there a chance this switch is somehow interfering with the secure pairing process? The switch is already linked to several rules, so I didn't want to exclude it unless there's a good chance it's causing a problem.

Can you just power down the switch. Also, have you rebooted the hub? I don’t want to throw out information that might be wrong, but some have sited successful joining of various Z-Wave devices after a hub reboot. Not just this hub, but I’ve seen those accounts from ST users too.

1 Like

That is the correct setting but you would need to reboot the hub, then wait 5-10 minutes so the network initialization settles down a bit and try again.

Make sure you disjoin/exclude the lock before you restart as well.


Thanks for the tip about rebooting the hub after changing the setting.

Excluded lock, killed power to the switch near the lock, confirmed secure setting and restarted hub, waited 30 minutes, factory reset lock, and tried to pair again. Also powered down ST hub just in case. But still getting same result.

I greatly appreciate all the help so far and look forward to any other suggestions.

Sorry to see your frustration. I had the same issues with the Yale 110. I spoke with @mike.maxwell and @bobbyD and they determined that the 110 was doing some non-standard wonkiness and would need to test. Since the wasn't a lot of people using the lock, I decided to return it and get one that @SmartHomePrimer recomnended... the Yale 256. He was paired right up with secure settings. Love the look and setup of this lock.

Unfortunately I ended up returning that one too but only because it kept jamming in my slightly misaligned door. Ended up with my tried and true favorite Schlage 469.

1 Like

I have the YRD446 (keyless) and it sure seems that locks and garage door openers are the trial-by-fire devices. Mine paired effortlessly on ST, which is a common claim. It paired at a distance too. Moving it to HE was torture because it's just as you said.. try this, try that, try 20 different things, it always pairs but never securely. I tried it with the hub a good distance away, just like it was when ST worked and it didn't work. I removed the lock from the door and brought it up next to the hub. Didn't work

Eventually I gave up, mounted it back on the door and moved on to the long list of other devices that needed to be migrated. I guess (no really, just guessing) that the time interval allowed the devices surrounding the Lock to get themselves fully initialized because when I tried it an hour or more later, with the Lock mounted on the door and the Hub in it's normal position, it worked.

My guess is that one of the devices that are under 3 ft from the Lock, got it's "Beaming" feature up and running and was able to assist as intended.

Your Lock supports beaming.

1 Like

Too bad. Yes, I would guess it's not going to work if you have to push on your door at all to lock. My front door is perfectly aligned, so I've never had powered lock issues. The August on my back door struggles sometimes, but has the right gear ratio to push through. Guess the Schlage 469 does too.

1 Like

Where is the hub in relation to the lock? Have you tried bringing the hub VERY close to the lock? Like within 5 feet? I keep a long network cable around just in case i ever have to do something like this. It might just be too far away to get a secure pair.

@stephack Thank you for sharing a couple of trustworthy locks. I'd definitely prefer the free option of using my existing lock, but I'm not completely against buying a new lock and appreciate the suggestions.

@csteele Very interesting. I'm basically giving up for now and moving on to other devices as you did. I'll definitely try again after a few days and hopefully get lucky too. I actually have a Z-Wave switch within a foot of the lock, so maybe it will handle the beaming after the network settles down. When you finally got yours to work, did you simply pair it again, or did you do a factory reset first?

@Ryan780 The lock started out 15 feet from the regular hub location. But I used a long network cable and held the hub within 1-2 inches of the lock a few times yesterday and it still didn't pair securely. Tried the same thing today after reading some of the suggestions earlier in this post, but still no luck.

I don't remember ever doing a Factory Reset on it. It has that menu and won't even offer up an Include option if it's already included. That allowed me to be certain I had excluded it. I'm pretty sure I would have been using my Aeon Z-Stick to that side of the exclude.

My memory of the event is that I a Recessed Door sensor that didn't pair properly and I took my iPad and Aeon Z-Stick to that area. I clicked the internal button on the Recessed door sensor and that got that going and then, since the Yale Lock is on that same door, I just did the Yale menu steps to #7 and started the include via the iPad to Hubitat and then pushed the Gear icon on the Yale. I almost fell over. It worked. So I pivoted and walked over to the OTHER barrier device I was having trouble with: Linear Garage Door Opener, and was hurting myself with grinning too much, because it too worked.

I have a YRD210 deadbolt and I have had a time trying unsuccessfully many times to get it to pair secure until I found your post. I saw you wrote:

I noticed you didn't mention hitting the number 1 key first in that menu. I tried this tonight and finally it paired secure doing this. It's the # key instead of a gear on my older lock but I just pressed it without pressing the number 1 key first. I even did this without removing it from the door and taking it to the Hubitat which is about 15ft away through one wall. So just want to verify that this worked for me as well and hopefully will help someone else.


I’m having the exact same issues with a Yale Lock. This one to be precise:

It seems nothing I do will make it pair. I’ve tried moving the hub as close as I can. I’ve tried factory resetting the lock - I’ve done everything recommended in this thread and the other but ultimately It doesn’t seem to want to pair fully. @mike.maxwell do you guys have one of these devices to test with?

Yeah I had trouble with an older Yale keyless lock AND the YRD256 - ended up changing the radio module to zigbee and things are working much better. Don't think you can do that with the older lock though.

I found a refurbished Zigbee module for my YRD210 on eBay and made the switch, and it has been working fine ever since. Somewhat annoying to have to buy the other module, but $60 was certainly cheaper and easier than a new lock.

No, we don't have this one.

I was pretty much at a point that I was going to replace the lock after several failed attempts before it finally paired secure on that last try. I can't say it was the "key" (no pun intended) to getting the lock to pair, but on the last step after pressing the 7 key to get into the paring menu, I just pressed the # button without hitting the 1 first. From what I had read, the older non Z-Wave Plus locks are hard to pair. I had no issues with my newer Z-Wave Plus lock which is a YRD226.