Zwave Yale Lock Issues

Hello all. New here. Not sure how I managed to do this but I have a Zwave lock that does not show up in the zwave device list but it does show under the device list in the left hand menu. I cannot add the device by pairing it via zwave. Any thoughts?

Sounds like it joined already. What do the device detail settings show in the Data field?

Can you take a screenshot or copy and paste here please so we can try and help.

Also, the lock itself doesn't seem to think it is paired. It wont let me access exclude mode, only pair mode.

5 bucks says it didn't pair secure.
All locks need to be super close to the hub to pair secure, this is documented right in all the lock manuals.

The "manual" for the network module for this lock is a single sheet of paper. One sided.

I haven’t gotten to my locks yet, but I have had some z wave devices not pair properly. I either factory reset them and did inclusion again or did exclude/include until it worked the right way.

That's just for the module. Which lock is this?

The part we wanted to see was the data field, which you just cut off in your screen shot. This is what we're looking for...


I won't make that bet with @mike.maxwell, because I think he's right.
I have YRD256, if this isn't the lock you have, I'm sure it's probably close to the same proceedure, if not identical. Exclude the lock from HE in the Z-Wave settings window. Then do a factory reset on it. Then try to join it again. 5 feet away is fine.

OK. I factory reset the lock. Then paired it with the HE, then excluded it and repaired. Once it repaired I get this:

I physically removed the lock from the door and it was never more than 2 feet from the HE during the entire pairing process. It doesn't show zwave secure pairing true. lock model is YRD446. I purchased and added the zwave module today.

Did you by chance put the batteries in and then put the Z-Wave module in?

I'm not saying the module's damaged, but mine didn't work right because I followed step 6 in the manual that said install the batteries, then in step 7 they say don't put the batteries in, install the module, then put the batteries in.

You don't have a secure pairing. You can keep excluding and including until it works, but I don't think that you should have to try anything like that. I have joined and excluded my lock multiple times on two different HE hubs and I have not had any problem doing this. Both hubs were and are 10 feet away.

Also see you followed a different order. So do it in this order.

  1. Exclude the lock (what you have now isn't going to work anyway)
  2. Removed the batteries
  3. Removed the Z-Wave module
  4. Replace the batteries (leave the module out for now)
  5. Factory reset the lock.
  6. Remove the batteries again.
  7. Put in the Z-Wave module
  8. Replace the batteries.
  9. Set your master code.
  10. Put the hub in discovery
  11. Try to join the lock again

Success! Thank you both so much! I was ready to pull my hair out.

1 Like

probably this post is useless but just wanted to thank you @SmartHomePrimer as only once I followed your steps I was able to make it work as well !! thanks for being so helpful :slight_smile:


I'm glad to have helped. Thank you for your post. Kindness is in no way useless. :v:


I have 3 YRD256's and I was really struggling to get them secure-paired in my new HE setup. Then I happened upon @SmartHomePrimer's recipe for greatness above. It worked perfectly the first time, er, first three times.

For those that follow, that is how you pair Yale YRD256 zwave locks. Mega props, SHP.


Thank you! This did the trick after multiple failed attempts to secure pair the lock!

1 Like