Zwave setup not working with Zooz devices (C7)


Reaching out here out of desperation. I have opened two tickets with support, both of which have completely ghosted on me after the initial generic response. I purchased this device in the hopes of using it to control my new Zooz Z-wave switches, however my experience has been awful. Nothing seems to work correctly with regards to Z-wave. Inclusion is hit-or-miss, and exclusion through the hub rarely does anything at all. The logs are full of errors. It seems to just freeze intermittently. I have plenty of switches very close to the hub, and they worked perfectly connected to a Zooz USB Z-wave radio (which I bought to manually exclude things from the broken system). I have reset the device multiple times, and tried many solution on these forums. I just don't think Z-wave works on this device.

Any ideas?

1 Like

It does work but sorry to see you having issues. What hub are you on? C7 ? Also what version of software? And lastly could we see you z-wave details page please.

1 Like

Hi - Thanks for the reply.
From the Settings Page:
Hubitat Elevation® Platform Version

Hardware Version
Rev C-7

I just spent the last hour excluding all my devices, and reset the Z-wave radio. I then tried to include a single switch, which sits about 4 feet from the device. It got stuck on "initializing" and won't respond to any Z-wave commands at this point. There is a single, blank 0x06 (006) device in my Z-wave setting. The "Discover" button does nothing. The last log entry is:
2020-12-02 05:57:34.351 pm info Z-Wave Discovery Running

So, it's essentially frozen again. After one inclusion...

@bobbyD @agnes.zooz might be able to help. which Zooz switches are you using?

Ok as you have already reset you z-wave and only done one device let's do that again. Then I assume you don't have any devices yet in the device page? Once it's cleared update the firmware to the latest then once it's booted up, do a shutdown from the menu and once it's down unplug the power to it. Do this via the USB end not the hub end.

Give it a few mins and power it back up.

Then exclude this powered device that you just tried to join and then try and join it. Is it a z-wave or Z-wave plus device?

Basically as you have already reset the z-wave chip we want to make sure that was done correctly. So by doing it and shutting the hub down and down powering, you are fully resetting the stick so there is no chance of odditys.

I have about a half-dozen each V23 toggle, V24 Dimmer switches.

Sure - I will, but this will make about the 5th time I've reset/powered off/updated/excluded all and tried again.
Firmware always says up to date.
Sometimes inclusion works for a while, but eventually it will freeze. Sometimes it freezes on the security and I get lucky and it just applies no security. But if that happens it will not include anything further, nor exclude. The radio always errors "the network is busy" or something to that end. One time I got almost everything included, but performance was terrible and automatons were completely unreliable. switches would take 30 seconds to respond (when they did) and my lights dashboard was a mess.

I'll go ahead and reset the device now... I'll make sure to follow your steps exactly this time.
I do appreciate your time - I don't understand why support couldn't have at least responded to me with these kinds of suggestions...

Could you please post a screenshot of your Z-Wave details page? You may have ghost nodes from all of your pairing attempts.

Also, could you please shutdown your hub cleanly from the Settings page, and, once the light turns red, pull the plug for 30 seconds, then Re-power. This is needed to reset the Z-Wave radio hardware when it gets confused.

The Hub does work. I’ve got a C-7 and all Z-Wave. We should be able to help you through this. I’m surprised that you haven’t been able to get a response from support. My support experience has been pretty good.

Busy perhaps? We have a large number of new customers over the past 10 days...

1 Like

Well... At least this is different:
"Failed to reset Z-Wave network "

Although the table is now blank.

Your hub may work fine, my hub really seems to have issues.

In that case just let me know you are busy, and an expected turn-around time. Better than just leaving a customer in the dark...


Ok, if that screenshot is to be believed, you have no ghost nodes. Some have reported an odd situation where devices disappeared when applying the firmware update, them reappeared after reboot. Could you please reboot the hub now without shutting down? Settings, reboot

Yes it is rebooting now.

When I did a "full-reset" the other day, the device came back with all the old Z-wave devices still showing up! I then did a z-wave reset, shutdown, power-down, and they actually got removed. Definitely should not have had to do that after a "full reset"

Edit- apparently 2.4.153 is available now I'm going to let it update to that and start from scratch again.

I hope you didn't do a full reset as you would have to get support involved to get your hub back up and connected if you did that. You possible did a soft reset? That would just wipe you database but yes you radio devices would still be there. You should never do a full reset without supports help.

Yes this was the update I was referring too. Update, shut down, power down 30s. Restart, wipe z-wave radio, shut down, power down 30s, restart.

Follow manufacturers instructions to factory reset the z-wave device, in hubitat do exclude and do the device dance to exclude. In HE you will see unknown device excluded.

Then join device. If it fails do not wipe that device or start again. Instead go to the z-wave page and find the new device and click discover. Keep a log page open this hole time. Do NOT STOP or move on until this device is joined. If it's capable of joining S2 then do that. If possible you can use the smart start QR code this might work better but that's only new devices.

Yes, did a full reset. It had been nearly a month with no reply from support and I had tried everything else. It just re-booted and came up like a new device, had to "register" it again, and I found my Z-wave devices unchanged (surprisingly). I don't notice any other change after the reset. It's still a mess.

So it installed the update and is back up- should I reboot/reset or anything or just go ahead and try to include devices now?

Oh, I agree with you, it’s just unclear to me, since I am not sitting next to you, exactly the steps that have happened since the full reset. Just trying to be methodical here, assuming nothing.

Now, next step, I don’t know what the shape of your database is. Shouldn’t be anything in it, but let’s not assume.

Please take a backup (Settings, backup, download new backup) and save. That cleans any garbage out of your database. Then, do a soft reset from the diagnostic tools program (http://yourhub_IP:8081), then restore the backup you saved.

Details of this process, which you might want to read first, are at:

In order to use diagnostic tools, you have to log in with your MAC address. Easiest way is to go to Settings, hub details, copy the MAC address, which will be in the form Diag tools wants.

Let’s see where we are then.

Just to throw another grenade into the mix, you next might want to do a firmware update to - a new version came out today. Some people with C-4 and C5 have reported some issues, but it addresses som Z-Wave issues on C-7. Settings, check for updates.

Updated my post above.

I've been down that road too. Let it sit for days. Resulting log:

Just froze like usual.

This should not happen unless you have a part joint device, don't leave it in that state just don't move on to another.

1 Like