Zwave security type for Zooz Switches

I am a new Hubitat owner and I am just starting the process of moving my devices from SmartThings. Most of my Zwave devices are Zooz switches. I ran into an issue with SmartThings and these Zooz switches where the switch would freeze and would not work until power was removed (eg, pulling air gap or flipping breaker). Zooz support couldn't figure out the issue but it seemed to start happened around the time the SmartThings Classic app was decommissioned, me updating firmware, and adding the switches with S2 security.

If S2 is wreaking havoc on these Zooz switches, is it acceptable to install them with S0 security?

You want to avoid S0 as much as possible. That security level is very “chatty” and might cause issues in your Z-Wave mesh.

Instead, try using no security (Security level “None”).

3 Likes

IMHO, absolutely, uncheck all check boxes during inclusion to avoid nagging device ghost issues on C7 at this point.

3 Likes

As noted, make the security check boxes look like this, then hit OK.

S0 security is "bad" because it generates three times the traffic of an S2 switch. No security is preferred by many HE users, simpler and easier. I use security for door locks, garage door openers, but not for switches, dimmers, etc.

4 Likes

The first time I added the switch, the security listed in the column for the switch was "None", however, I thought I checked "Security 0 - Unauthenticated" so I decided to exclude/include again. This time, I could only successfully add the switch using "Security 2 Class 0 - Unauthenticated" I also noticed the node number of the switch increased a few times during the exclude/include tries.

So I should add the switch with all of the boxes unchecked to get "None"?

Security 2 Class 2 - Access Control
Security 2 Class 1 - Authenticated
Security 2 Class 0 - Unauthenticated
Security 0 - Unauthenticated
2 Likes

I'm not sure but I may have created some ghosts with trying to add these. I notice the node number increasing. Is there a way to check for ghosts? Thank you for your help!

BTW, Thank you guys for taking the time to help a newbie. Much appreciated!!

2 Likes

Yes. Your Z-Wave details page will have one or more devices with no in, out clusters. Those devices are ghosts, and must be removed or else grave disorder will result. Please post a screenshot of your Z-Wave details page,

We were all new, once. I came from Wink, then SmartThings. Welcome!

4 Likes

You are fine. No ghosts!

2 Likes

That will happen - Nothing to worry about.

From your screenshot, things are looking good. You have no ghost nodes. :smiley:

2 Likes

I reset the Zwave radio before I saw your comments about the node numbers increasing.

Does this look odd? On one screen, the DNI is 11 and the node is 6.

I haven't figured out how to setup a dashboard yet some I'm not sure if I can actually turn the switch off and on with Hubitat yet.

Yup. This one is a problem. What you are seeing there is a ghost node. Under Cluster, there is only an empty “In: , out:”.

1 Like

Hit Refresh a number of times, at some point you should get a new set of buttons w/Remove as an option. Then hit Remove (like using Refresh it may take 5-10 tries) and the ghost should be removed.

Important: Make sure the ghost device does not have power. If it's a switch w/an air gap, pull the air gap. If it's a plug unplug it. You might have to flip a breaker if there isn't an easy option to remove power. As long as it's powered the hub may be able to ping it a usually won't remove it.

2 Likes

Arghhh.... I hit refresh a bunch of times and nothing happened. I reset the radio again.

So far, my introduction to Hubitat is not going well. You guys are great.... but this experience, not so much. lol

1 Like

You're becomming a radio reset expert. :wink:

Make sure you're starting as noted w/the nearest powered devices. That should make things much easier. Also, try excluding the device using Hubitat even if you've already excluded it from ST may make things more reliable. Also, I turned off my ST hub so it wouldn't try to get into the act and cause issues - some have reported that happening.

1 Like

BTW, you didn't confirm - did you you kill power to the device?

So I know resetting the radio was only an option because I only had 1 device I was working with. If I had everything added, it wouldn't have been a possibility.

I did pull the air gap then factory reset the switch. I turned off SmartThings and added the switch with all of the security options unchecked.

I quickly figured out how to create a dashboard button and I am happy to report, everything is working!!

Next question: I am just using the built-in drivers in Hubitat for this Zooz Zen27 dimmer switch. Zooz has custom drivers listed under their support. Should I install the custom drivers? I had to do this with SmartThings to be able to access the advanced settings.

1 Like

There are usually some more options on custom drivers. You can use whichever one works best for you.

Personally, I like to tinker with my settings so I prefer to use custom drivers when available.

2 Likes

I have three of each - zen21/22/27 and a dozen zen26

I am using these drivers and they are available through Hubitat Package Manager.

The support S2 although I do not use any security settings.

3 Likes

Download the Hubitat app