ZWave Plus Switch, turning on, then immediately off

Hi, I have a Dragontech Z-Wave Plus light switch that I’ve had for about 3 years. For the past month or so, it’s been pretty hit or miss with regards to my automations but lately I’ve noticed that whenever it doesn’t come on via my automation, if I physically turn it on, it immediately turns itself off. If I do it from the web interface, the exact same thing happens.

I’ve tried unpairing and repairing and at first it seemed like it worked, but is now doing the same thing. Is the switch going bad? Or something else?

All ideas are welcomed!

Anything in the logs with debug turned on?

Debug logs are on and nothing is reported when I attempt to turn on, again, either physically or via Hubitat.

The last entry in the logs is the last time the automation worked and it shows it turning itself off.

If you go to the device page at the bottom what automations is it a part of?

It’s part of:
Amazon Echo Skill
Homebridge (Hubitat)
Google Home
Turn Off Front Door at Sunrise (Simple Automation Rule)
Turn On Front Door at Sunset (Simlle Automation Rule)

I have no automations in HomeKit, it simply serves as the interface. No other devices have this issue.

Could be several things, the most concerning of those would be a loose wire behind the switch or at the light. Next could be a faulty switch, but I don't see many switches go bad. The ones that I did see they were controlling a fan or motor with a regular switch instead of a fan controller or motor controller. In the meantime try removing, then factory reset, then re-pair it and see if it's still acting up.

That usually happen when something it automated. I have purposely set some automations that shut light off after a while but you have to do it differently depending on the trigger and if it is a switch or dimmer, As usual, you spend a whole day experimenting on how to do anything. For instance, a siren requires a custom rule for an actuator. I literally had to try every option to find it.

Which is why I asked him to check the rules assigned to it.

I had previously re-paired it and it worked fine for about 2 weeks and now has been exhibiting the same issues, I removed all automations and its still acting up.

I’ll remove it tomorrow and see if I find any loose wires, which would be odd. It does make me believe that it’s the switch acting up. If it’s the switch, I may switch to a zigbee since I seem to have been luck with zigbee items than Z-Wave.

When you remove it, do a factory reset on the device before you pair it back.

Are you using built-in drivers or community drivers?

Built-in drivers. It's detecting it as a Generic Z-Wave Outlet, which oddly enough a few other of these brand of Z-Wave Plus On/Off switches are detected as. I, at one point, changed to Switch and it didn't do anything for me.

I plan on checking it Friday, if I don't see any loose connections, I may just swap it, since I believe I have a spare on hand.

When you do swap it be sure to un-pair it first so you don't end up with a ghost node.

Will do. And with regards to a factory reset, I'm not sure how this is done? Is it standard across z-wave products?

It varies from product to product. Can track it down in an online manual probably if you threw out the box. On my honeywell switches there is an air gap tab you pull out.




Not really, it is mostly by manufacturer. Some claim the double tap but it does not work for me. If you check the supported device list at List of Compatible Devices - Hubitat Documentation you can click on each item in the first column and it will go to to item on another page that document the procedure for that item.

That only cut power to the light not the transmitter.

1 Like

Looks like both use top 3 time then bottom 3 times. If it like my GE one you have to do it quickly and then stop and wait for the blue LED to flash. It should end up off and excluded until turned on. Z-Wave Plus automatically joins the mesh network if you were to turn it back on. I suspect that my GE and yours come from the same factory in China.

So, oddly enough as I was getting ready to finally remove and replace. I did another exclusion and the system works fine again at least manually pressing the button. So, I attempted a factory reset and I saw no indicators that it worked, re-paired it and it’s dojng the same thing, just about 1 second slower.

Previously when paired, if you turned on via Hubitat or physically tapped the button, it would immediately toggle back off. Now, the button works and it stays on if you manually press it, but if I turn on via Hubitat, it turns off, but waits just under a second before turning off. So this feels like it’s Z-Wave related. I can’t see it being a Hubitat issue since everything else works just fine.