Zwave Mesh

Hey Everyone

What do you guy do when the nodes stop messing. I have several lights set up to come on and some of them are not working properly. I figured its the mess.
I ran a Zwave repair and several failed. I tried to turn them on (physically) and also rebooted the hub.

No luck. Suggestions?

Screenshot from 2022-07-27 20-48-09

You should post a screenshot of your entire z-wave settings page. If it is long, you should consider breaking it up into several shots.

1 Like

how do I know which node goes to which device?

The node numbers are indicated in the column titled, "Node".

One issue with your mesh is you have two ghosts.

1 Like

Looks like at least 2 ghosts (0x0D, 0x011) or incomplete pairings that you’ll need to remove before anything will stabilize.

1 Like

How do I identify those devices to remove them,

Normally the next device down is the usual suspect…

1 Like

my devices are not in node order

OxOE looks like it might be the successful pairing of 0X0D, and 0x12 could be the successful pairing of 0x11. (Node IDs are added in sequential order.)

1 Like

What do you mean? They are in the order you pair them.

You go to the next column over where it says Status and [OK][Refresh][Repair]. You click [Refresh] and hopefully it says [Remove]. You may have to press Refresh a few times before Remove appears. You can then press that new button [Remove].

You sometimes have to remove power from the next device down to get Remove to show up.


I celebrate when the nodes stop “messing”, :rofl:. Auto correct has to be the cause of many miscommunications. Just hope that our nuclear arsenal does not use autocorrect!

On a more serious note, follow @thebearmay and @neonturbo ’s recommendations. They are a great resource and give great advice.


Nah, they are all set to 00000000


Following the above directions above, here are the results. I pressed the remove button several times

Screenshot from 2022-07-28 10-00-08

Now one of my switches isn't responding at all. Not even to physical

Is that switch connected normally to the load and controlling dumb lights? If so, nothing you do in Hubitat can affect that.

You still have one ghost:

At this point, before we go any further:

  1. Shut down hub from Settings menu
  2. Pull plug (from wall, hub connector can be fragile)
  3. Wait one minute
  4. Plug in hub and let it boot up
  5. Go to Z-Wave Details page and post a cap of it again

If you still have that one ghost after shut down/restart, you'll need to remove it. Usually using the Remvoe button will work (may take pressing it several times). You'll have to remove power (pull the air gap) on the Front House Lights or Front Porch Lights before hitting Remove on the Ghost.


I followed your directions and it worked. I had to press remove several times and then it disappeared.
I have control of the switch again and am able to turn on and off everything from the dashboard.
I rerun the repair after the removal to get it back to normal. Node 15 (garage lights) still fail. The switch is in the garage and is about 60 feet from the closest switch. Any ideas on how to boost the signal to that switch? I do have Plus switches on both sides.
Thanks for your help
Screenshot from 2022-07-28 11-01-31

You shouldn't need to run repair after changes, but running it can help to "encourage" the hub to find better routing for that switch. Results from a repair related to routing changes can take several days to a week to appear, so patience is recommended. :slight_smile: Run the repair directly on the specific switch that you are trying to improve results from.

You probably need repeaters between the hub and the switch. Can you clarify what you mean by "...have Plus switches on both sides." Generally it sounds like you need more repeaters in your mesh, between your switch and the hub. You may need to add a Z-Wave repeater or two (e.g., Aeotec 6 or 7, Ring 2) or a Z-Wave plug (Jasco). After adding the repeaters, you can run a full repair on your Z-Wave devices, and then wait (could be a few weeks) for devices to see and use the repeaters.

However, you may find things settle down/sort out if you give it a few days. If you can handle waiting on the garage switch for a few days you could start w/that approach while you're shopping for Z-Wave repeaters/plugs to add to your mesh (or mess). :wink:


I'd recommend the ring 2 extender. It's also handy because it has battery backup and can sense power failure. Also if you want your mesh to really sing. Re pair everything WITHOUT security (it's generally useless) except for Locks and Garage door stuff.

I was trying to avoid that discussion until he got through the ghosts... :wink:

A "quick" way to re-pair the switches w/out security:

  1. Reset the switch
  2. Hit the Refresh button for that device on the Z-Wave Details page until it pops up as failed and the Replace button appears
  3. Put the switch into pairing mode
  4. Hit the Replace button for that device on the Z-Wave Details page and allow the hub to replace the switch with itself. Make sure you use the "Include without security" option. The device will re-include and keep the same DNI and app associations so you don't have to do any additional work.

There is also a new "Swap Apps Device" option in the most recent hub FW. To use this option you'll have to reset and re-include the switch w/out security as a separate step before you run the swap process, and you would then use the swap feature to swap your existing device for the newly added version of itself, if that makes sense.

1 Like

Download the Hubitat app