ZWave mesh acting as "asleep" every morning until switch buttons pushed

Recently replaced a Vera controller that was working consistently for years with a Hubitat Elevation. Have a little over 100 ZWave devices that were painfully registered into the new Hubitat and have been very disappointed in the performance. Not sure where to start with troubleshooting at this point.

I have some automation schedule rules setup to turn on a relay and turn on lights every morning. This schedule activates maybe 10% of the time. It seems if I manually press a light switch or trigger a relay, the system 'wakes up' and will then run the schedules properly. I've tried running them through BASIC RULES, ROOM LIGHTING, SIMPLE AUTOMATION RULES, all with similar results.

Any ideas on what to try? I'm on the verge or starting over with a different brand controller.

1 Like

I'd start with some of the ideas here, particularly the section on so-called "ghost nodes" that can be problematic for some:

If you haven't already, you may also wish to make sure your hub's Z-Wave radio firmware is up-to-date, as a recent update fixed a specific issue that caused problems for many users with large or chatty networks. To do this, go to Settings > Z-Wave Details, then see if you have a Firmware Update button at the top. If you do, click it; if you don't, you're already up-to-date.


Thanks - latest firmware is installed for both ZWave and the Hub. I'll double check the Ghost Nodes section.

Also a lot of those older switches may not be plus which means they don't report their status and need to be polled. Have a look here..


Thank you for the link. I do believe some of the switches are not ZWave Plus. I'll do some research on polling and if that is needed prior to running scheduled events. I did find some ghost nodes on the network and am trying to get them removed.

Yeah your mesh will be crap causing issues like you are having until they are removed. More so then the non plus devices.


The issue with the older ZWave devices is that, when they were designed, there was a valid patent that many manufacturers chose not to license. The result was, they didn't send unsolicited status. Hubs that were designed in that era chose to poll devices. Hubitat came along after the patent expired and there were plenty of ZWave+ devices to choose from. Hubitat has a ZWave Poller app you can add to your hub and have it do exactly what it sounds like. You select the devices that you want to poll and voila, or Bob's your Uncle.

Many of us moved those older devices to locations in our home where the Switch/Dimmer itself wasn't used physically and that Automation would take over the functionality. Remember, it's just those physical changes that don't get sent to the hub. All of the Hub commands get acknowledged so as long as there's no physical interaction to mess it up, the hub accurately reflects. Not polling is a goal. 24hrs a day your ZWave radio is getting status that probably hasn't changed in hours, days even in my cases. You could probably find a better use for those tiny slices of radio time lost to polling :smiley:


Thanks to all for the assistance. I still have some ghost nodes that will not remove. I came across this post/comment that mentions using a ZWave USB stick to help with removal. I will try this to remove Ghost Nodes and then see if that clears up the mesh issues or highlights a different problem.

Yeah until those ghosts are gone you will have issues. If you know what devices created the ghosts (usually the one after the ghost) disable power to that device, shut down your hub from settings, unplug power at the wall (not the hub) for 5 mins and power back up. Then attempt to remove ghost again. If that doesn't work then do the stick.


I was able to get all Ghost Nodes removed using a UZB-7 USB Stick from Silicon Labs. The instructions linked in above replies is slightly outdated, and I had to manually locate and update the Windows driver and use the Simplicity Studio software to update the firmware on the USB Stick using the OTW Firmware feature.

Link to latest CP210x Windows Universal Driver:

Link to recent (*edited, not the latest) 7.17.2 Firmware for the UZB-7 USB Stick (Note: US and EU have diff versions):

I'm going to let the Z-Wave mesh rest overnight without changing anything more and start the next level of troubleshooting tomorrow. Thanks again for the help so far.


It's a good thing for you to rest the Zwave mesh until it makes new routes.
I also have to say that Hubitat itself has gotten much better at removing nodes that are "no longer there", with the "remove" button. However, it does take patience. I had a number of these type of nodes, and I kept on using the remove button. Eventually it did work, but it took a number of tries.
P.S. You may wish to look at the Zwave Topology and the community program Zwave Mesh to help you visualize the zwave mesh that you have.

1 Like

Actually 7.18 ... :wink:

If you have issues updating.. like I did it may be due to the newer drivers..

Ah - thanks. I saw the more recent Z 700 firmware in the Gecko SDK folders had changed names to the BRD4206 and I didn't want to risk it. The 7.17.2 was the latest I found with a matching name, and luckily worked for me. I couldn't get through Inclusion to the HE7 until I updated the firmware. I don't remember, but I think the USB stick shipped from Mouser with v7.11?

1 Like

Yep seems like the same stick I bought mine from there as well..
I've always been able to add the stick even with much older firmware so dunno.. :person_shrugging:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.