Zwave devices disappeared on C7

Yesterday I removed and re-added my front door lock (Kwikset Convert) because the battery percentage wasn't working correctly. I did the 'swap device apps' on it to move the old apps to a virtual device, then move them back once re-adding the Lock. That appeared to resolve the battery issue.

Today I logged in and noticed that there were no devices listed under the Zwave Settings page. No warnings in the notification bar about zwave being offline, only error was cloud backup failed.

I reboot the hub and stuff appears to come back up, but I'm not at home to verify. I go ahead and install the latest update (I'm 1 rev back). Reboots, I check remotely, stuff looks ok. I come home and z-wave devices don't work. They show, but don't work.

I restore a cloud backup from before the Front Door adjustment, but don't overwrite zwave radio data. It restores, zwave devices don't work. Again, they show, but not working (I didn't extensively do a bunch of trouble shooting like did only battery devices not work vs. mains powered devices - I just wanted to get back to normal).

I go back to cloud restore and this time include the zwave radio data. The restore goes for awhile then shows "restore failed, please contact support". It reboots, and zwave stuff appears to work. The front door didn't work, so I tried the "replace" option, but I've never used that and it ended up removing the device.

Restored again and included zwave data. Same "restore failed". Stuff still worked minus front door lock, so I did the same thing as the other day (swap device apps) to move it to a virtual, then removed the device. I got it added back, swapped, then removed the ghost (old front door lock device).

I think things are back, but why did zwave just die? Why nothing in the logs, no hub events, just died. Why did the restore "fail" but didn't appear to completely fail. Is that bad? Do I need to try again? What say you @bobbyD @gopher.ny?

There is an issue with the cloud backups failing occasionally and when that happens, it takes down the Z-Wave radio. Power cycling the hub by shutting it down from Settings, then when the led turns red, unplugging it for 1 minute should restore Z-Wave functionality.

To limit this problem, for the time being, I suggest to reduce the frequency of scheduled cloud backups while the root cause of the failure is identified and a fix is released. This seems to affect both C-7 and C-8 hubs.


Thanks for the quick reply. Since I did a bunch of restoring, several of my zigbee devices fell off. Will they come back on their own? Any ideas why certain zigbee devices wouldn’t come right back after a restore.

Edge devices that have weak connection may need to be re-paired. Best to let both meshes settle for 24 hours and reassess the losses afterwards. Also power cycling those devices may help.

1 Like

Has this happened yet?

1 Like

None of the releases' release notes mention this issue, from what I've seen.

I took a manual cloud backup, and have turned scheduled backups off for now.


Adding myself to this thread as I'm encountering this issue after contacting Hubitat support.

1 Like