Zooz ZSE42 Water Leak XS Sensor

Has anyone been able to successfully pair their ZSE42 leak sensors with Hubitat yet? The instructions QR code goes to a page that says to make sure you're running 2.2.9 (not available yet) so I installed this device handler.

So far I haven't been able to get them to include to the hub at all. I've tried 3 of my 15 that came today to outfit my new house with no luck. Exclusion also doesn't do anything.

Has anyone had any luck yet?

@JasonJoel for sure has, but the driver you're using wouldn't affect the ability to pair--that would complete regardless, and even the built-in Generic driver should work, just without the (minimal) configuration parameters exposed. That being said, 2.2.9 will indeed have a built-in driver for at least the two new sensors from Zooz (and perhaps more we don't know about yet).

So, something else must be going on. I'd start with the usual troubleshooting: exclusion before inclusion, making sure you're following the correct inclusion/exclusion instructions for the device, and verifying that these failed attempts (and anything in the past) hasn't left "ghost nodes" in Settings > Z-Wave Details. I'd also make sure the frequencies match, but I'd assume you're in the US if you bought these and probably have your hub set to that frequency too and have other North American Z-Wave devices working fine.

I have also had better luck factory resetting any device before trying to include it. I think sometimes testing gets done at the factory and settings get stuck.

Thanks both of you.

I checked in Settings > Z-Wave Details and don't see anything about them there. I did a z-wave repair just because I have moved some things around so it never hurts, and I am indeed in the USA and set for US frequencies on my hub.

I have a few dozen devices already (locks, smoke/CO detectors, a repeater, and a garage door tilt sensor) which all seem to be working fine. I've also tried pairing right next to the hub just in case it's something with my mesh, but that doesn't seem to make any difference either.

I did a factory reset on all three. The instructions say to press the button 3 times, holding on the third press for 10 seconds, then immediately pressing twice more after that. That actually doesn't seem to work. It's supposed to blink 3 times to verify a successful reset, but instead just continues to rapidly blink. I think I figured it out though - Press twice rapidly, then hold for closer to 15 seconds. The LED will rapidly blink, and eventually change to solid. Once it goes solid, release and immediately press the button 2 more times. It will then blink 3 times slowly to indicate that it has reset.

Unfortunately, that's as far as I've gotten. Pressing the button 3 times rapidly and putting the hub into pairing mode still doesn't find the sensor, and eventually it'll time out and stop blinking that it's in pairing mode.

I have successfully pair both the XS Leak and the XS Open/closed sensors. I have a C7 Hub and had no problem pairing but I have a couple more that I haven't pair yet and will probably do so today, and if I have any problems will let you know. When I pair mine I only press the button 3 times and it pair for me.

1 Like

Yup, I have 16 of them paired.

In general, if you try to pair and nothing shows up in the zwave details page, either wait 5 minutes or reboot the hub. Odds are after you reboot you will see stranded (not "ghost" - there is a difference) device(s) in the details page with a "discover" button. That is true of any device pairing that doesn't complete successfully - not just these Zooz devices.

My recommendation is always, if the pairing times out even when pairing close to the hub - reboot the hub and see if it really did start the pairing process, but never finished. I've seen that at least 30 times now... As I know how to work around it, I've given up trying to understand why it happens.

I had to do that multiple times while I was pairing those 16 devices as the pairing process didn't always complete correctly - for whatever reason.

After pressing discover / waking the device up a time or two the device would be added correctly (as seen in the logs). At first you will get tons of "zwave busy" messages in the log, but usually after just a time or two doing discover/waking device up it will finish.

Also, I would recommend pairing these devices close to the hub, not far away (like I usually do). I had issues when pairing these via NWI.

2 Likes

You've gotten some great suggestions from folks more experienced than I am but another idea is to check with Zooz support. I've found them responsive and @agnes.zooz is frequently engaged in these discussions. I'll be interested to hear experiences from folks who got these (before they sold out) and any comparisons to other water sensors like SmartThings or Dome.

1 Like

Thanks everyone for offering the troubleshooting steps here! @Tasoril if you're not able to add the sensor, definitely get in touch with our team and we'll be happy to assist you further.

The sensor is back in stock, but limited quantity!

Thank you everyone for all your help. As it turns out, the issue was, as usual, me. I forgot that I had put my hub downstairs in my basement instead of upstairs... Moving has apparently done my brain in. I also realized just how many of my z-wave devices are battery powered... Once I got the sensors closer to the hub they paired instantly.

Buying some more receptacle/plug in z-wave devices to strengthen my mesh. The C-7 will also help with that once it comes so I can see what my mesh looks like.

Thanks again everyone, and I apologize for the trouble!

1 Like

Was hoping to find a solution here, but I have tried all the usual tricks and as a last resort I just placed the sensor on the shelf right next to the hub and the hub still wont pick it up. I even tried pairing it directly to a space USB stick earlier from 2 ft away.

It did start to pair to the hub once when I first tried and then failed, I removed the ghost, factory reset the device and now it wont talk to anything.

Did you get the updated Z-Wave SDK from Bryan? If you PM him he will give you the link. I think it will be in the next update as an automatic thing.

edit: not sure it would help of course but it does include fixes etc. Also I'm sure you did the usual device factory reset, pull plug yada yada yada...

Reboot the hub and look at the zwave settings again and see if there is still a device in there for it. If so, click discover and it should finish. If not, then I have no idea.

Yes, last week

Did that too :slight_smile:
Even reset and replaced my USB Stick to make really sure there was not a ghost.

I also already emailed Zooz asking a few things about the two sensors and told them I think my leak sensor is busted.

Could be. Last thing I would try is shutting down the Hub and pulling power for 60 seconds, then booting back up and trying again. Sometimes fully rebooting the Z-Wave side via power removal can help.

Obviously if it's a device issue though, that won't help at all.

Well if you can't even pair it to a USB stick sans hub then it does sound like a device issue..

I had a lot of issues with this (Zooz) sensor and had to send them back to Amazon. I got four (4) of them and all four had problems.

I spent almost 2 months with support going back and forth with pictures and video about how to get them to pair.

Zooz has great support by their way, and their light switches are fantastic.

But these water sensors just don't work for me. I reset everything a zillion different ways, upgraded the HE half a dozen times, disabled S2 security - EVERYTHING. Never could get a good reliable sensor.

In the end, I switched to Third Reality Zigbee leak sensors and have never looked back. The first six (6) I installed worked perfectly out of the box. They are heavy and solid feeling, intuitive to work with and always worked in every kind of test.

PS. First time caller, long time listener. I deeply appreciate how much time and effort the community puts into this. I have 2 HEs now and will be getting several more for my buildings. I'm up to 50+ devices and feel like I've transitioned from newbie to average/supporter level now, so I should be giving back by starting to write some posts of my own.

Download the Hubitat app