Zooz ZEN77 Advanced Driver issue

I have already committed the necessary change, will be in next release.

5 Likes

Awesome, thanks so much Bryan!

1 Like

I learned a lot here. Thanks folks!

It's been almost a month, is this release coming soon?

This driver works for any of the ZEN switches.

Been using the Zen77 (30+) for about 7 months now with the Zen77 specific drivers and can say it's been a mess bordering on nightmare honestly. Eventually, I gave up. All dimmers are on FW 10.10 and my C7 hub has even been replaced. About 1 in every 10 routine attempts actually work completely otherwise it's all over the map. Have excluded and reincluded many of the switches a dozen times or so. To make matters worse, every time one thing gets fixed a new problem crops up.

  1. Can confirm, state changes oftentimes are very inconsistent. For example, right now my living room light is off but it current state shows it as on, just with the dimmer showing at near 0. This is a relatively new problem/behavior. state shows as on but slider at near zero. This started happening after a few updates ago. It used to be the slider didn't move whether the state was on or off. When the switch was shut off the slider stayed where it was. Then an update came down that changed all that. Now when the state goes off the slider goes moves to zero. This also causes another issue. When the light gets turned off the slider will go to near zero and hopefully the state goes to off. Then when the light is turned on the dimmers dim level may stay at near zero. This has confused a lot of people in my house when the light is technically on but because the level is set so low the light is off. Needless to say I'm always having to double tap for full brightness. In fact, it's now routine for me to double tap to turn lights on because of how bad it all works.

  2. Continuing with bullet 1, random dimming levels. Sometimes (a lot actually) when a state goes from off to on it'll set itself to some random dim level. Dim level could be at 100% (well, 99% now for whatever reason... Why is there no 100% now?) the night before but when it gets turned on in the morning it'll set itself to something other than full brightness. A few of my dimmers do this religiously but many if not all have done it at least a couple times. Some of these lights I have never even dimmed.

  3. Despite Scenes as being enabled I can't do advanced routines. For example, I tried setting up my back porch light to go to full brightness on a single tap and then on a double tap set both the back porch and the fire pit lights to full brightness - it never worked. I did the setup a dozen times or so but it refused to work. The only thing I COULD get to work was setting both lights to full brightness on a single tap of which isn't what I wanted.

On a side note, I'll say from a bulb compatibility perspective I've been significantly disappointed. I've tried somewhere around a dozen brands (generic and name brand) of dimmable LED bulbs and nearly all of them do not work properly or flicker in some fashion with the exception of GE bulbs. I have a huge tote of expensive LED bulbs that simply don't work with the 77s. The sad thing is the 77 is a MOSFET dimmer but a Triac based Amico recessed dimmable LED light works flawlessly.

Anyway, going to give Jeffs advanced driver a go.

I'm sorry to hear about the issues you've experienced with your dimmer. It sounds like there are a few different challenges that may be specific to your installation or scenarios so it would make more sense to troubleshoot them one at a time for each device to arrive at a solution sooner. Have you reached out to our support yet? If not, just message me your email address and I'll be happy to open a request for you so we can get these issues resolved for you.

I think that will solve a lot of the issues. Let me know how it works out. I have around 20 various models of ZEN switches in my house and everything works good here.

1 Like

I spent a very long time going back and forth with zooz directly, that's also how I got the 10.10 firmware update. I also noticed that I had zero issues with using the dimmers when using the Silicon labs UZB controller and software on my laptop. This told me the problem was associated with the hub. Then when I moved over to @jtp10181s advanced drivers' performance improved exponentially. This put the nail in the coffin for the Zen77 specific drivers. I hate to be blunt, but, they're garbage and until the significant bugs have been fixed the driver should be removed from Hubitats driver list imo.

I did end up changing the drivers to your advanced driver and performance has improved significantly. I wouldn't say it's been flawless but the occasional issue is better than numerous chronic issues. I still can't get the double tap to trigger the fire pit lights but I've found an alternative that seems to be working. Instead of double tapping I have it set up for a long press. Not sure why I can't create triggers for double taps.

On a side note, not sure if a bug or intentional but I have noticed a weird phenomenon. I have the dimmers set up to go full brightness on a single tap and for double tap I have it set up to go to a custom brightness (25%). When the light is on the custom brightness (or any level other than full brightness for that matter) and I do a single tap it doesn't go to full brightness. To get full brightness out of a single tap I have to turn the light off then on. That being said, there's no issue with going to the custom brightness using a double tap from full brightness.

I have it set up like this because I use full brightness significantly more than I do the dimming function so single tap for full brightness was better than the default doulbe tap.

This is the behavior that Zooz says is correct. I remember posting about this exact same issue quite a while back about the Zen26 and even submitted a ticket to Zooz but they said it's working as intended. I was confused because the Zen30 can be setup for single tap full brightness so that when it's below 100% a single tap will return it to full brightness.

Zooz's position is that the "single tap" only refers to when the switch is in the off state.

Based on my interaction with Zooz support, I am not surprised. Fortunately, it's just a mild annoyance at this point.

Found my old post. It was about the Zen27 actually.

1 Like

Download the Hubitat app