Zooz Zen30 Relay Switch Not Working

@hydro311 yes certain. I'm going to reinstall it.

1 Like

And comparing what I already have installed to the link above, I do already have 2.0.2 installed as well.

@jtp10181 I have done the matching, I've gone through the repairing, it is showing as v2.0.2, not showing as any updates available, I'm selecting everything, and still showing as UNK00 type in the child device settings. Here's the debug logs on the parent device while pressing configure.


The info on the child device is irrelevant in this issue.

Looks like you cut off the start of the debug logs which is the part I actually want to see, see my post above for an example.

On the device page of the parent, the top right corner would show the version of the driver in an info box with a link to the community post, if its not there then it is so old it is before I added it to the top right.

It's there. It says "Community Link - Zooz ZEN30 v2.0.2"

Ok can you show the start of the debug logs from configure? It should look something like my example above. In your last screenshot it looks like you cut off the start of it.

After it is done, refresh the page and also show the Current States and State Variables again.

1 Like

@jtp10181




Screen Shot 2024-06-08 at 6.31.40 AM

Ok everything looks good now. The child relay is still not working correctly?

If you want to clear any of that info from the child, switch the type/driver to the one named "Device" then use the two buttons to clear current states and state variables. Refresh the page and it should be clear. Then you can switch it back to my custom child driver Child Central Scene Switch if you have it installed, otherwise Generic Component Central Scene Switch will also work.

You could also use the Device driver from the parent to delete the child device if you don't have a bunch of automations tied to it, and then let my driver r-create it.

From there, it looks like it should be working correctly now that the configure has detected the endpoints.

Whew. This worked! It's working through z-wave/the hub, working on the physical buttons, and now even working with Alexa as well. In the process of everything I even noticed the "Relay Auto Turn Off Timer" setting which is super handy for the bathroom exhaust fan to turn itself off after awhile of venting moisture after a shower.

You're the man! Thank you so much.

Glad we finally got it sorted out. So did you just have the wrong driver set on the child device this entire time? Clearing that warning on the child, although annoying, would not have done anything to make it suddenly start working. I honestly think the real fix was getting the configure to work correctly and getting that "endPoints: 2" state variable to populate. That is the KEY in making the 800LR model work with my driver.

If you want to take your bath fan to the next level check out this app. You just need a humidity sensor in the bathroom and one other in the house to use as a baseline.