Zooz Zen30 and 2.2.4

Yes, button presses were working fine prior to 2.2.4. See my screenshot here...

The problem is clearly on Hubitat's driver, since I have both a switch on 1.03 and 1.07 and neither registers button presses for scene control.

I deleted, excluded, and re-joined one of my ZEN30s. Same behavior - doubletaps on the paddle report from the child device. I submitted a support ticket to Zooz last night - will report back if any troubleshooting they provide makes any impact.

I suppose it would have been mentioned by now, but is anyone aware of a community driver to try as an alternative?

We tested the latest 1.07 version both on C-5 and C-7 and while on C-7 everything worked except for the multi-taps being reported incorrectly (we already reported it to HE), it didn't work too well on the C-5 (latest platform version) at all. We're currently waiting for the C-7 fix and will tackle C-5 next.
We also tested the ZEN30 on other platforms for comparison and it worked well both for status reports and scene control reports so the firmware on the device doesn't seem to be the problem.

3 Likes

I see that @agnes.zooz has posted earlier today. I came here to share that she also replied to my support ticket with the following:

"I'm sorry to hear about the issue you've experienced with your Double Switch. We're aware of this issue and have reported it to Hubitat. I hope to have an update and a fix date in the next couple of days."

I'll follow-up here with any new developments.

1 Like

Does this imply that the issue isn't with the switch, and is something on the hub? I haven't tested the double-tap issue, but it seems that a lot of my device statuses aren't updating consistently. I've posted elsewhere about that. For me, it isn't limited to my zen30.

It's an issue with Hubitat's Zen30 device handler. Always has been from the start. It needs to get fixed, it's been months.

1 Like

With only the greatest respect for the accomplishment that is Hubitat, it has become clear to me that it is not what I was expecting. Admittedly in hindsight this was my fault, as any perusing of this community quickly illustrates the numerous ongoing issues and most professional reviewers warn of the time requirements. Unfortunately it appears the platform is under resourced from a development testing perspective when "works with" brands break previously working features over multiple public software releases. While I still wouldn't trade the latency back to ST, at least with ST it's easy to know which devices (hint, the ones with a Samsung label) will work with every software update.

Sigh, smart home technology has come so far, but remains relegated to the hobbyist with time and desire to manage it. My own admittedly lofty goal is a system that once configured needs no ongoing maintenance, sort of like a light switch needs no maintenance after installation. I was willing to invest my time in the set up of a reliable system, but breaking stuff that already worked chaps me.

1 Like

Pretty much what I have, to the point that I started a thread here asking for more things to think about automating as I was getting bored w/my system "just working." :slight_smile:

But it is true that it's a YMMV situation when you combine multiple vendors, multiple communication protocols, HW types, home sizes, construction, layout, and combinations of different devices. Sorry your experience has not been good.

I upgraded to 2.2.4 last night and am having the same issue. I use the button as a trigger for the garage door, so every time we turn on The garage lights, the garage door opens. I had to suspend that rule to keep the garage door from opening.

Firmware 1.05 and a C5 hub.

Still having this issue with a C-5 hub and firmware 2.2.4.158.I have firmware 1.07 installed on the switch. The dimmer reports neither dimming changes nor single button presses, only the relay works. Any ideas on timeframe for when this might be addressed? my family is tired of the workarounds I have put in place and need to know if I should just change out the switch to something different.

3 Likes

@bcopeland It would be nice to have some answers on this.

3 Likes

Just sharing a link to a workaround that was successful for me to use the ZEN30 relay button in automations.

I switched to @jtp10181's driver here. Make sure to hit configure after changing the driver. But using this driver, I don't get a digital button press on the relay when pressing the paddle. I've been using it all week with no issues and I was able to unpause rules that were triggered by the relay.

3 Likes

The built in driver works fine for me with the relay. I just need the button press events to be recorded for my automations.

Ditto! Everything is working great with this new driver. In addition to fixing the relay/paddle button problem, these drivers also appear to support all 10 buttons (1x - 5x taps) on the paddle, and another 5 buttons (1x -5x taps) on the relay! Thank you @jtp10181!!

2 Likes

So far reports have been good that this custom driver fixes all the issues with the button reporting including the scene buttons. Shout out to @krlaframboise for the great starting point with his ST device handler which I ported over to Hubitat and then merged in all my upgrades from the other switch drivers.

4 Likes

Considering myself new enough to this community to feel compelled to ask whether more experienced members might by this time assume no fix is actually coming from Hubitat? I believe it was November when Hubitat suggested a driver update was coming and I have to admit I'm not feeling like it's going to happen.

If the experienced consensus is Hubitat won't fix the driver in the next few months then I'll take the time to install the @jtp10181 driver.

Maybe they put it on the back burner since I delivered a fix before they did?

Its really only a couple of clicks to get the driver going. Although I would recommend setting up the package manager and going through that, then if I do updates its easy to update it.

The stock drivers a lot of times are basic, just enough to get people going. If you want to take full advantage of all the features sometimes you will need a custom driver anyway I have found.

I appreciate your driver, but even with the latest 1.07 firmware on my devices, I'm still not seeing button press events showing up in the logs for scene control. This is the main issue right now for me. This was working prior to 2.2.4, and hasn't worked since.

It should work, I have one myself and have not heard of issues from anyone else. Did you press configure after switching the driver? Also make sure the descriptionText logging is enabled on both the parent and child device if you want it to show in the logs. Otherwise it will only show in the event history for each device (parent and child).

Post a screenshot of the Device Details: Data and Component Devices sections at the bottom of the page for your device. This will show me all the parameter settings.

Also what Hub do you have?

Download the Hubitat app