Zooz Zen30 and 2.2.4

I have a pair of Zooz Zen30s in my house, and I'm curious about the changes made to the driver for this device in 2.2.4. In the release notes, it says:

  • C7: Zooz Zen30 Double Switch: Fixed multi-channel incompatibilities. (note: device must be included without security due to reporting quirk in the device)

Question for Hubitat (@bcopeland), is this the reporting quirk that causes the relay switch to not send its status after a state change? A corollary question for Zooz (@agnes.zooz), is there a firmware fix in the works that will allow this device to operate "properly" with a C-7 running 2.2.4 and using S2 pairing?

Was about to ask basically the same thing.

Ha.. Y’all are taxing my memory here.. And I didn’t leave myself sufficient notes.. I’ll re-include the one I have security enabled so I can answer this intelligently..


We've released a firmware update for the ZEN30 recently that includes a few changes around S2 and will send the OTA to @bcopeland right away so hopefully we can make it happen @eppower :slight_smile:



1 Like

Thanks, @agnes.zooz!! :slightly_smiling_face: Is this newer than the 1.05 code I have now?

Yes, it's 1.07, not officially released there but hopefully very soon!


Is anyone having issues with the driver after the update? I have a rule subscribed to the button press of the relay but the main switch (up or down) now triggers an event for the relay.

1 Like

It doesn't affect my automations, but I do see the same behavior in my log files. I'm really hoping the new switch firmware and subsequent driver fix will clear up these issues. Right now the RM automation for controlling lights and fans on my ZEN30s are overly complex to handle the oddities, which translates to reliability issues.


Same Here. Turns on/off fine via automations, but doesn't refresh the state of the switch after turning the device on/off/dimming. I've noticed I can change the dimmer driver to the Zen27 and it will report on/off/dimming states just fine. Odd that it doesn't work with the Double Switch driver.

1 Like

I put a virtual switch in place that controls it then I can check the virtual for the correct state. Wonky way to do it but it works at least.

1 Like

I did the same. Here's my rule, which seems to work ok:

Rule to use virtual switch with ZEN30

driveway light

I only toggle the virtual version of the driveway light (a halogen post lamp wired to the ZEN30 relay switch), and the physical version follows. Note that I call it "temporary," since I'm hoping for a firmware/driver fix someday that will make this unnecessary. :wink:

1 Like

Unfortunately, it seems there is a problem with updating to the 1.07 Firmware for the Zen30. I'm getting the following error when trying to upgrade the firmware on these switches.

I have tried using the z-wave updater to update both 1.05 firmware and the newly released 1.07 firmware for the Zen30's, and I get the same error. This happens on all my Zen30's. I was able to use this utility fine for my Zen15's.

I suspect the issue is that they are showing as sleepy nodes with no way to wake them up since they don't respond when a command is sent.

So it's a bit of a chicken and egg problem, it seems. We need to get to 1.07 to get the switch working properly, but we can't get to 1.07 because the switch doesn't work properly.

I updated my Zen30s from 1.03 to 1.05 using a z-stick and the PC Controller software. Had the same behavior as you using the Hubitat z-wave updater, but with the PC Controller it went smoothly both times.

Same issue here as well, very frustrating because it broke a bunch of my rules :frowning:

My setup is a c5 hub, no s2 security - version 1.05 of the Zen30 firmware. I am not using load control on the relay switch but am using it on the paddle switch. Paddle switch button events are showing up for the relay switch (sub-device) instead of the paddle switch, which causes all kinds of problems (no way to distinguish between the 2 "button 1"s, button 2 pushes for a device that says it has only 1 button, etc).

Everything was working perfectly until I updated to 2.2.4

Similar problem. Oddly, some of my Zen30's seem to be working okay. At least one is experiencing the issue noted above of activating the relay when pressing the paddle buttons.

No paddle button presses are sent. A full switch reset and later a z-wave repair yielded both no resolution.

The non-functional one is [I think] the only zen30 for me with smart bulbs, so the paddle local control is disabled.

Is it worth rolling back to a pre-2.2.4 version of the hub software until a solution to upgrade the zen30's firmware is sorted?

[editing to add: I don't believe I added any of my zen30's with S2 security. And I'm on a c5 hub.]

Just installed the beta 1.07 firmware on the ZEN30 I have in the guest bathroom (not a critical location). @ncreed I used the instructions Zooz supplied for OTA updates with a z-stick, with the caveat that excluding the switch after updating didn't work. I had to fail it out of the PC Controller software and then factory reset it.

Excluded and included with HE, and it seems to behave nearly identically. @bcopeland and @agnes.zooz whatever changes Zooz made to the S2 code didn't help resolve the issue that the relay switch reports being actuated when the dimmer switch is toggled. The only difference I see in updating to 1.07 is that when I press or electronically control the relay switch, it actually reports its new status back to the hub. Fantastic, since it didn't do this before!

However, now the dimmer switch doesn't seem to be reporting its state when toggled, so I guess the whole experience is a wash. I'll hold off updating my other ZEN30 until firmware is out of beta and @bcopeland has a chance to see if he can update the driver to deal with these oddities.

Thanks for taking the time to test the firmware @eppower. We sent the firmware file to Bryan and will wait for his feedback to see if there's anything that could be done on the switch side to make it work better with security.


I’m catching up on drivers / devices today.. So I’ll have a report by end of day on this fix..