ZooZ Zen21 v4 switch param 10 not being set

I have latest firmware and Zooz ZEN21 Ver 4.0 Switch that I want to use for scene control only. Switch manual says parameter 10 can disable manual control with value of 0, so no relay will click when pressed. Hubitat shows in device Preferences a "Manual Control Enabled" option, and I set it from default "enabled" to "disabled". Log shows the variable being updated from null to 0 "Changing Manual Control Enabled(#10) from null to 0" but instead of sending that to the device, it seems to resend the #1 parameter a second time "Paddle Control(#1) = 0", see log image below:


It looks like it was asking you to save the device again in the logs due to pending changes. I've seen this in my logs for certain devices from time to time. Maybe not finished configuring?

Also you can post your picture using the picture link and it will embed in your post like this:

I pressed the "Save Preferences" and "Save Device" buttons multiple times, and then pressed "configure" and it still shows that "pending changes" warning.

I hate to say "shutdown/power off/wait 15+ seconds then power on" but... you might want to do that and then try and redo the parameter if it's not set. Also make sure you have a V4 device. I have a Zen24 V4 dimmer and setting that parameter works fine. The switch next to it is a Zen23 V3 and it does not work.

I tried powering down, didn't change anything. Tried re-setting the parameter a few times, always says it is changing from null to 0 or 1, keeps saying 1 pending change. Firmware shows v4 on Hubitat log and it v4 is printed on the switch's label.

On a side note, when I paste an image in here, it shows up in the preview, but when I hit "reply", a popup says "Sorry, you can't embed media items in a post." I just delete the "!" before the image link, it posts the link at least, not sure why embed isn't working.

I discovered there is an error in the printed manual and maybe some older online pdf versions. The printed manual (that came with my switch) says "enable/disable paddle control" is parameter 10, but the online pdf manual says it is 11 (which is correct based on my previous testing with Vera). Maybe the code (driver?) is trying to set #10 when it should be #11?

1 Like

Ah sorry .. did not realize it was probably due to your account being new not sure the discourse rules but I imagine it will change after a bit.

You might want to report that to @bcopeland as a driver issue. Looks like it is different between Zooz devices - my Zen24 V4 dimmer works as expected by setting that parameter.

Another thing to try as a workaround is install the community "Basic Z-Wave Tool" driver. This will allow you to change any parameter manually bypassing the properties page. To do this copy paste the driver code from the link into the "Drivers Code" section. Then go to your device page and temporarily change the driver "Type" to "USER / Basic Z-Wave Tool". You can set the parameter from there. Change the driver back when done - do not hit "configure" as it might override your changes.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.