Zooz Zen17 relay

So if there isn't a Hubitat capability, maybe hide this option, or map it to "dry contact" or another one of the capabilities that are present in Hubitat?

I think the thing many of us are requesting throughout the thread is to expose the timer parameters. There are 8 or so timer settings that are not exposed through this driver. (Parameters 6 through 9, and 15 through 18) It is very hard to make this work for a garage door opener without having those timers in the UI. You can swap to the Basic Zwave Tool, but that is very time consuming when you are trying to "tune" the timers to work properly. The LED on parameter (#5) also is not in the driver, but that is a lower priority, it doesn't affect the basic usability of this device.

The other feature request that I see here (and I would like to see too) is the ability to reverse the sensors in software (open=open, or open=closed). Not sure that is possible, but it would make this a lot more usable if you could tweak these for various sensors.

Ok.. I can do that..

:thinking: Ok..


Not an emergency, but 2.28 would be nice to see...

1 Like

I had asked for this. I think this should be a firmware change controlled by a parameter which would also need to be added to the driver. @agnes.zooz , please put this on your list for the next firmware revision.

1 Like

Noted, we'll let you know when that's added!

1 Like

There are 2 versions of firmware updater for C5 (it's confusing and hidden in the thread), this one will take the .gbl file and others. Used that to upgrade Zen16 and 17.
[RELEASE] Z-Wave Firmware Updater - Developers / Code Share - Hubitat

I have a fresh ZEN17 out of the box, updated to FW 1.04. C7 hub on latest fw. I'm seeing this error:

java.util.ConcurrentModificationException: null (supervisionCheck)

And also seeing the relays do the "bounce" after a power off event (they bounce back on sometimes). Turning on the DC motor feature seemed to relate, have tried both ways. This behavior renders the device unusable. Hoping there's a driver update to help out soon!

Seeing supervisionCheck errors with uncommanded relay state changes on ZEN17 too. C7 hub running latest software. ZEN17 on 1.04 firmware.

Have experienced same with Aeotec Smart Switch 7 devices as well. Using a generic driver and S2 security seems to fix as does using default driver with security "none". I don't find either of these solutions satisfactory given C7 claims S2 support and SS7 is explicitly listed as a supported device.

1 Like

Confirmed- same everything except I re-joined the ZEN17 with no security and the functions are normal & predictable, including DC motor mode (one relay never steps on the other).

1 Like

Mine's joined with no security and has been working as desired on 1.04 for a couple months now... Since it controls my garage, I'd like to get it on S2 someday, but no way I'm doing that anytime soon - S2 is just way too wonky overall right now!

This is resolved in 2.2.8 that is currently in beta


OK. Waiting patiently and hoping it's really resolved.

Wiring question with the Zen17.

So currently I have it powered with a 5v 1amp power adapter using USBC. Then i have a toggle switch attached to Relay 1 input terminals, and the fireplace power connection to No an C for Relay 1. This is working fine except for the occasional issue mentioned above. Last few times i tried it, it seems to be fine.

The next thing I am wondering about is hooking up some fans to the Zen17 that are powered from 12v. My question unlike what i did on relay 1 where i didn't need to supply power to any device, How would i wire in power and use relay 2 to supply the power to the fans. The documentation throws a bunch of red flags about not using multiple power sources.

The multiple power source red flags are related to powering the Zen17 device itself. USB C port or the wiring power port but not both at once.

You can simply wire the 12v + side of your power to the 2nd relay's C post and the fan's side of the 12v + to the NO post to control your fan. Like any other normal relay implementation.

1 Like

Hi all,

My Fortrezz MIMO2+ died and I was replacing it with a Zen17. On the MIMO there's a setting for a momentary on/off on the device. However on the Zen I can't find one on the parent or component. My desired use is just for a button on the dashboard to close a dry contact, nothing crazy.

I'm sure I can write a rule but it seemed like perhaps I was missing something obvious...

Is there a better way to be doing this?

Thanks in advance for the help!


Parameters 6/8 and 15/17 enable you to set an auto-off for the relays so that the relay actuation mimics momentary on/off behavior. Unfortunately, these parameters aren't currently exposed using the default driver.

You can use the "Basic z-wave tool" driver to access those (and other) parameters though, and it works well. I did that for my relay so that it mimics the garage door opener button.


Hopefully at some point they will add these as exposed parameters. Bryan seemed to imply that he would work on it when I asked this same question recently at about post 135 or so. :arrow_up:

But for now, the Basic Zwave Tool works OK to set these parameters as @hydro311 listed. Super basic Z-Wave parameter tool


@hydro311 @neonturbo

Ah yes parameters, thank you! Completely forgot to think about that.

I've gone ahead and set them to what should turn off after 1 second of being on, but I'm not getting the expected behavior. The relays just turn on, NOT on then off after 1 second.

Am I missing something obvious? Thanks again!

Huh, those parameters look correctly set up to me, so I'm not sure... Are any other rules that previously controlled on/off behavior disabled for certain (to ensure nothing is "clashing")?

I use a 2-second delay for my auto-off, but 1" should be no problem too.

Brand new device, so no rules yet. I went as far as to delete and re-add just to make sure.

I had tried 2 seconds as well and had the same thing.