ZooZ power switch v1 issues

Has anyone had any luck with these devices? I bought two of them, and I paired both of them without troubles to hubitat; they got recognized as ZooZ Power Switches, which was very promising. But after pairing the devices were "stuck" sending notifications to the hub (from looking at the logs) about their on/off state, and about metering - one of each every few seconds; they seemed so busy doing that that they ignored my on/off commands - or processed them after minutes...
I tried to un-pair and pair them again a few times, but the behavior was always the same. I also tried using Kevin's driver (originally available for smartthings); no better luck. I tried setting it up as a generic smart switch - nothing. Eventually I gave up.
I may try to pair them to smartthings in the future, and see if they behave better.

I'm not sure what you mean by v1 so what's the product number? I'm using the built-in drive with the ZEN15 and ZEN06 and I haven't had any problems with either of them.

Make sure you have it close to the hub when you add it and once it's added you should save the settings screen with the default values and give it a minute to fully sync the settings.

Once you've confirmed that everything is working using the default settings you can change the metering intervals, but don't set them low unless there's a reason you it that often.

Once everything is working the way you want it then you can move it to it's final location, but you might need to run a z-wave repair.

1 Like

Yeah, that's what I believe I've done several times. Maybe I have a couple of defective units; I'll try again and see if anything changes.

What's the model number of your device?

I highly doubt you received 2 defective units...

Only join one of them and perform the steps I mentioned above to see if you can get it working. Leave the Logging window open in another tab while testing it and if it stops working again post the logged data for that device so I can see what's happening.

1 Like

I don't disagree... they are "Zooz Z-Wave Plus Power Switch ZEN15 for Heavy Duty Appliances" units - I can check the model # later today. My reference to v1 (vs. v2) was related to the fact that I remember seeing newer units around with the plug at an angle - rather than straight, and some reference to that being a newer version than what I have.
I'll test it again this evening and report logging information if it still fails.

That's the ZEN15 so there's no need to check. Zooz confirmed that the one with the angled plug has the same firmware so the driver will work with both of them.

Let me know either way.

1 Like

Take a look here.

These are the first 5 minutes of the device after pairing. You'll notice the on() command I sent - which got processed after a minute or so; and the two off() commands - which haven't been processed yet...

Why is this thing generating generating events every 300ms or so?, that's not right...


Just chiming in here because I have 5 of the ZEN15's powering my AC units. Granted they are on a different system but with that different drivers. Mine update at 300 Seconds (5 minutes). Sounds like there's a driver issue or something weird going on or bad units which is doubtful for both to be bad in the same way.

1 Like

This specific log was using the system driver, with its defaults...

I think @krlaframboise has a custom driver for SmartThings for these and probably a version for Hubitat as well.

I tried @krlaframboise's drivers; I got the same behavior unfortunately.

Have you tried doing a hard factory reset of the ZEN15?

Sometimes that is needed with some devices even new out of the box.

I haven't; what's the procedure?

Which method are you using to join the device? You can either use auto inclusion, hold the button for 5 seconds or triple-click the button, but you should use the triple-click method.

I did auto-inclusion in this case.

I just tested auto inclusion and mine doesn't join secure so that's not the problem.

Exclude the device and hold the button for 20+ seconds to factory reset it like @jeubanks suggested.

Not that the factory reset gave me any visual cue of actually happening, but I got a similar behavior after re-pairing... This time I used the three clicks procedure to pair.
I think I'm ready to give up - my older GE outdoor plugs are behaving much better.

From the manual.... I happen to have one sitting on my desk :slight_smile:

HOLD the Z-Wave button for AT LEAST 20 Seconds. The LED will flash orange and then stay solid orange for 2 seconds to indicate successful reset. The Power Switch will then turn off.