Zooz power strip flooding zwave logs


#21

If you enable debug logging and click save again it will tell you which setting is still pending.


#22

Hmm, I just tried that and don't think I see anything in the logs that says something to that effect. (Unsurprisingly, it does make it log even more information, so it might be hard to see, but I paused it and looked through the few seconds surrounding this log.warn and still didn't see anything.)


#23

If it's logging that pending changes warning then when debug logging is enabled it should also log a debug line that looks like "CHANGING {setting name}(#) from X to X."

The debug line will appear at least 4 seconds before the warning...


#24

Do you have Iris plugs with the z-wave repeater turned on? I had some trouble with that and most of my Zooz devices, with lots of messages flooding the logs. I am not sure what helped, but I replaced the built-in z-wave repeater driver with the driver put together by @srwhite, then followed the instructions on the proper order to configure/interrogate each plug. There were some obvious issues with some of the plugs, that eventually got worked out. Then I ran a couple of z-wave repairs. The next day everything was working properly.


#25

Nope, most of my powered Z-Wave devices are Zooz (something I'm going to regret if these are really all messages from the device :laughing:). Beyond that, my only repeater is a HomeSeer WS-200+. I've run a few repairs as well.


#26

Are you still seeing the pending change warning when you tap save? If so, please post that "CHANGING..." log line so I can see which parameter isn't syncing. If debug logging is enabled, it will appear in the logs at least 4 second prior to that warning.


#27

Sorry if I wasn't clear on this--I'm using the v2 ZEN20 power strip with the new-ish stock driver. But FWIW, the warning is still happening. :slight_smile: (I am using yours for the ZEN15 that I'm not totally convinced is behaving well, either, but at least that's only two outlets, and this is not one of the problems with that.)


#28

The built-in driver will log that CHANGING message I'm looking for...


#29

Ah, here it is--thought I looked for it before but didn't see anything (and then assumed you were talking about a driver I thought you wrote before these were officially supported):

dev:1910 2019-03-12 23:33:50.679 warn There are 1 pending changes, please click the Save button again.
dev:1910 2019-03-12 23:33:50.676 info Zooz Ch 1 power is 20.9 W
dev:1910 2019-03-12 23:33:50.643 debug MeterReport: MeterReport(scale: 2, rateType: 1, scale2: 0, deltaTime: 10, previousMeterValue: [1, 3], meterType: 1, precision: 1, size: 2, meterValue: [0, 209]) (CH1)
dev:1910 2019-03-12 23:33:46.675 debug Power Reporting Threshold(#2) = 5
dev:1910 2019-03-12 23:33:46.376 debug CHANGING Power Reporting Threshold(#2) from 5 to 20

#30

Zooz originally launched a limited release of the Zooz Power Strip VER 2.0 and it had firmware 1.0 and everything since has had firmware 2.0.

It looks like they changed the parameter size of the Power Reporting Threshold from 2 to 4 in the 2.0 firmware and the built-in handler hasn't been modified to work with both versions.

If the firmware in the data section shows 2.0 then that setting is stuck on 5W which explains why you're unable to limit the number of reports being sent.

While waiting for the built-in driver to get updated you can use this driver to change that parameter to the same value you've been trying to set it to using the built-in driver's settings. Once that change is made you can switch the device back to the built-in driver.

parameter number: 2
size: 4
value range: 1-65535 W


Zooz Power Strip
#31

FWIW, my Zen20 2.0 power strip (which is reporting as often as I ask it to) is using firmware 1.0, cccording to its device settings page.


#32

Correct, that setting works fine for the original ZEN20 VER 2.0 which has firmware 1.0, but Zooz made a couple of changes to the 2.0 firmware so that workaround needs to be used until the built-in driver is updated to support both VER 2.0 firmware versions.


#33

Hey Kevin, I love your drivers and noticed the one for the Zooz strip is not yet ported to Hubitat. Did you have any thoughts of doing this? I notice the hubitat default driver does not include the usb ports.

Thanks