Zooz Double Plug (Zen25) child devices - Consistently not working from Dashboard (or at all)


I'm going to return the switch tomorrow...just too much time wasted on it and too many tries to include it that have gone south.

I'll look for an alternative option, once burned, twice shy.

Thanks to everyone for the feedback and help.

If you haven't already unplugged it, can you control it from the Devices page? Click on the Plug Zooz Double-Right Outlet and it should open a page like the one I posted here.

Then try the on & off .

@krlaframboise and @agnes.zooz are the Zooz contacts so I figured it couldn't hurt to tag them in this message.

And finally, this is what shows up in the logs when I do the Z-Wave repair for all of my double plugs.

Thanks for your questions. I just plugged the little bastard back in, I know I'm going to regret this... :wink:

I can control the plug (parent and children) from the device page at this point, on/off, on/off, works fine.

Created new tiles for them on a new dashboard (again) and within a few tries they lock up looking like below - that's happened repeatedly, each time I've excluded and then included again, the dashboard control never works reliably - gets locked up like this. Sometimes I can get the parent tile to return to normal by tapping the on/off button on the plug, but the child tiles stay stuck in "Sending." While the tiles are in this state I can return to the device pages and control the parent and children, on/off, no problem.

I've excluded/included a bunch of times, done the "wait before saving" on the Zwave pairing page so the device has time to setup, etc., and it just isn't happening for me. FW is 2.0 so doesn't need an update. I've done multilpe Zwave repairs, as well, that haven't helped. This should not be a zwave mesh issue, as I can currently control from the device pages fine at this point. Just from teh Dashboard is failing. Weird, they should be making the same call to turn it on/off, right?

I'm not a contact for Zooz, I'm just familiar with all their devices and I've helped troubleshoot issues with the built-in handlers in the past, but now I only assist users that are having issues with the custom handlers that I've posted...

1 Like

@krlaframboise - What's your retainer rate? I can go as high as three twinkies a week, with an option for a snowball if you are willing to do a home visit (mask required).


It is nice to see all the old ST pros over here, BTW. I get that you support your stuff, not HE generally, makes sense.

Thanks, I got it. I seem to remember that you got these working during my brief stint with ST.

BTW, just a post-script. I moved pretty much everything over to HE today, all my smartthing devices.

Did a Zwave repair, completed w/out any warning messages or issues. I should stop while I'm ahead, right?

No, of course not, because I am just not smart enough to walk away, I tried to pair the Zooz double plug. Failed at initializing. Would not come back after reboot, Discover button, refresh, unplug/replug.

It hates me as much as I hate it. Boxed and on the way back to Amazon, and we will both be happier. :smiley: See, I'm smiling already.

I don't know what the deal with this device is, I have one on the way...

1 Like

LOL...yours will work perfectly, you realize that don't you. (Shhh...they're listening...)

We were able to replicate the issues on our side as well. S0 inclusion is probably the closest to having the device to work but it still shows up as the ZEN20 Power Strip (though you can use Ch1 and Ch2 to control the outlets on the plug individually). @mike.maxwell let me know if we can provide any additional information to get this resolved.

Can anything be done about the tons of power/voltage messages?-nevermind latest platform has fix.

And on my C4 hub I had the same experience, commands get backed up. The aeon micro switch above this zen25 plug, I can flip on/off rapid fire without a hiccup, but the Zen25 seems to get bogged down with close commands, off works instantly, the on command doesn't happen till a 4-5 second delay. I recently upgraded the zen25 to ver2.0 in hopes of fixing the issue, but it didn't help. I do not have the plug joined securely.

1 Like

I use three of these along with many other Zooz items without any real issues. They are inexpensive, fit behind furniture and work reliably. However, if I could completely shut down the power reporting reports, I would. I have the reporting disabled where I can but when you turn one of these off you always get left power is 0W, right power is 0W, double power is 0W, double current is 0A and double voltage is 0V. which to me seems a bit unnecessary since I just turned everything off.

mine is not working correctly either.. it is in the same room 20 feet from the hub in direct view of it. in a zwave outlet that works fine.. the outlet is always direct to the hub.. there are also two other repeaters in the same room and 3 other zwave swtiches.. this stupid thing keeps having delays and jumping routes to to one of the switches and to the basement then to the hub.. i repair it and it works fine at 100k and then 5 hours later has a stupid delayed route again.. i already updated to latest firmware.. i wanted it because i am using one of the sides as my zwave hubwatchdog test device (that is hidden under a desk so wife will not bitch i used up a plug) but when it picks a stupid route the test times go up.. there is definately something wrong with it.. now buying a different brand of dual control zwave and will try that..
this is going back..

Update to this driver in 2.2.4

1 Like

On previous Hub FW versions I had nothing but problems w/the Zen25 no matter where I put it. The good news is that w/the 2.2.4 beta it is a much better experience. The Zen25 has stayed connected and responds normally to on/off commands. But...I do think this plug doesn't like to be far from the hub.

Initially I tried the Zen25 at the other end of the house on the 2.2.4 hub FW beta - it didn't do well in that location, became non-responsive. As a compare, I have a GE/Jasco/Honeywell double plug even a little farther away and it hasn't given me any issues.

So I moved the Zen25closer to the hub and it's been doing fine since then. Running for several days w/out issue.

got new zen 25 for testing before sending one back to amazon.. is on latest f/w out of box.. there is somehting major wrong with the antenna or reception of these devices.. this one is paired literally 5 feet from the hub and no other zwave devices near it for about 4 feet.

it still is flakey and dropping back to other switches in the route and in general has bad reception.. see the picture.. all other devices in the same room are at -100

what does the new driver in latest hub firmware fix?

I'm not sure what the details are but the only entry in the beta release notes is below.

  • Fixed Zooz Double Plug child events

Bryan or Mike may know more...

@bcopeland, @mike.maxwell

Mine is working great near the hub at the moment. later today or tomorrow I'm going to move it for a little way and continue to place it and see if it holds up.

ya doesnt seem like an event issue.. seems more like some kind of reception issue with the radio.. weird becuase other zooz devices seem fine..

I remember them and Agnes at Zooz saying that a new\updated driver for the Zooz double plugs was coming in two.2.2.4. I don't think it's specifically called out In the release notes, but that's what they said if I remember correctly.

There may be a radio issue on top of whatever other issues that are as I had difficulty controlling the plug when it was at the farthest reach of my house.

update is coming in 2.2.4

1 Like