Zooz Double Plug (Zen25) child devices - Consistently not working from Dashboard (or at all)

I've added a Zooz Double plug using the built-in Zooz double-plug driver.

I can control both plugs from the main device page, and each outlet separately from the child devices pages. FWIW, the Child device pages don't seem to update very well, when I got to them they often don't have the correct current state of the left/right outlet.

However, when I add them to a dashboard, as a switch or outlet, only the parent device tile works. Both child devices freeze as soon as I click on them, w/a "Sending" message. See below:

This happens repeatedly, I've tried recreating the dashboard tiles, deleting and creating an entirely new dashboard, and I get the same results. It happened on 2.2.2 C7 FW, and I updated to the new C7 FW today, and it is still happening.

Has anyone got this plug working properly? I must be missing a trick...

UPDATE: I did a Zwave repair and that has not changed anything, same behavior on the Dashboard.

I have 2 of these plugs, and hate them. This is my 3rd time excluding/re-pairing redoing rules etc.

They're a real pain in the arse(C4 hub btw) on
And I have 3 z-wave repeaters in the same room and just did a repair last night

I have to admit that I am starting to develop the begginings of a slight loathing...only having the option turn both on or off at the same time from a dashboard makes the plug much less useful. It may end up getting placed behind some furniture as a repeater only...but I hold out hope that someone has some advice to help make it function normally.

Not that this is any help, but I have three of these and have never had that issue. I'm not a fan of the way they spew out all of the power reporting data when they are turned off, but other than that they have always worked fine as switches. I updated mine to firmware version 2, but they worked fine before i did that.

Good luck.

1 Like

Thanks for the feedback. I checked and mine are v2 FW already (firmwareVersion: 2.0) so unfortuntely that's not going to be the quick fix.

So you can control the infividual plugs from the dashboard? Do you create them as Outlets or Switches (not that it likely matters, as they fail in either of those modes for me).

The only solution may be that I will put mine in the mail to you, and you can whip it in to shape and then send it back to me. :slight_smile:

I can control them individually. There’s one that controls my desk lamp that’s triggered by a motion sensor mounted under my desk and it turns on and off all day, depending on how hard I’m actually working from home. I use switches for the dashboard template because I think it looks better than the outlet. They both work to control them as you said. I do turn off the double plugs together when running my goodnight automations because it seems to turn off quicker than when doing the individual plugs.
Can you turn them on and off individually from the devices page? One thing I remember from I paired these is that they take bit longer to pair than other devices. Meaning that after it looks like it’s finished pairing, just wait a little bit longer until you hit save. Also do you have all of the components in the devices page? I attached a picture of one of my office double’s device page. When you did the Z-Wave repair did you watch the logs to see if the device was actually repaired?

Good call, it definitely did not finish...all I have is below. Every time I add it, it gets added as a "Device" and I have to switch to the Zooz double plug driver. So when I hit Save during the initial pairing, it's saving as a generic Device rather than as a double plug. Yours pairs as a double plug initially?


Usually once you change drivers, it is good practice (necessary?) to hit "Configure" in the device page.

Have you tried that?

Yeah, the first time I went to their device page I hit configure after changing the driver, just tried it again, no change. Looks like I'm going to have to exclude and try to add again?

Can't remember if you have one, @neonturbo. If you do, have you ever been able to add this as anything but a "Device?"

Nope, I don't have any.

I don't know whether remove and pair again will help, but it might be worth a try if you aren't using it in a ton of rules etc. I think I would see if anyone else has suggestions before doing that though.

It's just sitting there annoying me. :wink:

Nothing going on with it, as I'm still "poised to start my Hubitat adoption/migration" but silly things like my family are eating up all my time. They just don't get that my techincal play time is the MOST IMPORTANT THING IN THE WORLD. :wink:

I'll try a few more things and if it doesn't start playing nice I'll go for the exclude and try again.

1 Like

Excluded and added it back in.

Then went into Parent and saved preferences and and the two child instances were created. Also enabled USB child. Hit configure and then went out to mail device list and it looks right - parent, and three children.

But...is not reliably controlled from the device page - off/on commands don't seem to get there for a while, the plug seems dead, and then five or more changes will occur in a second.

Started a Zwave repair and am getting this messy error over and over again...this is all w/the built-in driver. So something odd is going on. I'm starting think it's time to return this plug.

[dev:420]( 07:25:45.327 pm [error]( No signature of method: zoozDoublePlug.parse() is applicable for argument types: (hubitat.zwave.commands.supervisionv1.SupervisionGet, java.lang.Short) values: [SupervisionGet(statusUpdates:false, reserved:0, sessionID:55, commandLength:10, commandClassIdentifier:50, commandIdentifier:2, commandByte:[33, 50, 0, 0, 0, 0, 0, 0]), ...] Possible solutions: parse(java.lang.String), wait(), run(), reset(), run(), grep() (parse)

It comes in groups, or individually between other log messages:

Once you get into those groovy errors, it is about time for me to call in the experts.

One of my last suggestion before I am way over my head is you could go through all the preferences in the device page, flip them to something "wrong" and save preferences. Then go back and put them back to "normal" and save preferences again. There was a similar error in another Zen25 thread where that supposedly fixed something.

The other thing I guess I would ask you is if you have a decent Zwave mesh in general? Do other devices work correctly and it is just this one that is causing issues? I have seen weak mesh and lack of repeaters give the effect you have with dashboards and so on, but sort of doubt with these errors that is the cause.

Thanks, I'll try that.

My Zwave mesh has almost nothing on it. :slight_smile: All are mains powered. I have the Zooz plug, a Honeywell light switch, and an Aeon HEM v1.

I was doing a zwave repair and it completed w/out issue (other than the Zooz plug errors).

I'm actually wondering if this plug has a HW issue...

It could be, but if you only have those few devices it very well could be a mesh issue. Try moving the plug close to the hub, do another Zwave repair. Then maybe do one last configure and see if either of those do anything.

are you presenting the child devices to your dashboard? i can control each plug individually on mine no problems

iirc, i did have some issues to pair it initially. i think i was too quick on clicking save once it was detected. wait for the zwave include timer to finish then click save on the device after it finds it

Wow...that actually will be very disappointing if I have a weak mesh issue w/three powered devices all within 20 odd feet of the hub. You're not saying that I will have to leave the zooz nearer to the hub, are you? Or do you mean do the repair near the hub and then and then it will be OK farther away.

Thanks for your questions.

Yes, all three children (left, right, usb) are there.

I waited until the end of the pairing timer, and then sat on the pairing screen w/the "Save" button waiting for another minute before hitting Save.

I am actual an iota closer now... :slight_smile:

I can control the parent from the dashboard (as before). I can now only turn off the individual children on the dashboar, but can't turn them back on individually. So turn on parent, turn off both children individually works, but can't turn the children back on individually.

Still getting this in the log, so I'm thinking I'm going to need to try exclude/pair again.

The more the better with Zwave. Honestly 3 is not that many devices. I don't think there is an official number of what is sufficient, but my estimate is that around a dozen is the magic number to begin to have a good mesh.

I meant temporarily as a test. If it works, then signal is suspect. If no different, then move onto something else.

I didn't really mean that, I meant to repair for the temporary test above so the hub (and mesh) knew you moved it.

1 Like

FWIW I have this device and can control the child device from a dashboard. Zero problems. :man_shrugging: