Zooz 4-in-1 Sensor

Tried using the provided zooz/monoprice driver and it didn’t work very well. I installed the Rboy driver for Zooz 4-in-1 and it is working. Some code cleanup needs to be done for Hubitat. I may clean it up for myself, but I’ll contact RBoy to see if he’s interested in supporting Hubitat officially.

3 Likes

Perhaps @krlaframboise could port his Dh over? I’m using it in ST.

There should already be a built-in driver for it.

Built-in driver is not working well. Does not report motion reliably

Do you have automations that aren’t triggering or is the motion value in the right column of the device screen not changing to active?

Motion value stops changing.

What firmware version do you have and what do you have for the motion sensitivity and motion re-trigger settings?

Firmware 5.1.
Motion sensitivity 4.
re-trigger 2 minutes.

What’s the battery level?

80%

If this is something you can reproduce, enable logging in the device settings, open the logging window, and post the logging data for that device after it happens.

I will try. That sensor is my basement, does not get triggered very often. I noticed that it will work for a few days then gets stuck. Have to wake it up with a pin.
Actually it does the same thing with Robert Vandervoort’s driver I ported from ST.

I don’t believe it’s the drivers or Hubitat because I’ve seen the same complaints on the ST forum.

Motion detection in the original version (5.9) was really buggy. The next version (16.9) improved the problem and the current version (17.9) seems to have fixed it.

The hardware was modified in each new version so the firmware can’t be updated.

just ordered one of these of amazon to replace a xiaomi motion sensor that keeps dropping. do i need your driver from ST or the built-in driver will work for motion/temperature/humidity?

is there a way to check the version without installing the device?

thanks.

got this hooked up using the built-in driver but cant seem to get motion. what am i missing?

thanks.

Does it show the firmware version near the bottom of that screen?

If not, does the device use 2 AAA batteries or 1 CR123A battery?

If it uses 2 AAA batteries, does the packaging it came in say “Zooz”?

1 CR123A battery.

thanks.

edit: did a zwave remove then device reset now trying again.

this time motion seems to be working but not sure what the pendingchanges number means ... that does not seem to be going down or something.

thanks.

The device sleeps so you need to use the paperclip to wake it up any time you make changes to the settings.

1 Like

so did the paperclip then clicked the save button and the pendingchanges count went from 8 to 7. am i doing it wrong? :slight_smile:

EDIT: now not reporting motion any more :frowning: