Zigbee Touch Switch With Multiple Switches in Single Gang Electrical Box

I'm posting this for people like me that might be having trouble with one of these type switches. The Tuya Zigbee Smart Wall Switch is the one listed under Hubitat compatible devices, but today the only Tuya brand I can find of these type switches are WIFI not Zigbee. However, there are others out there and a lot of them seem to work the same as the Tuya.

I bought this one on Amazon:

Diese, ZigBee Home Wall Touch Smart Light Switch.

I had a great deal of trouble with this and was ready to give up. I could not find where you configure the sub-switches.

I would've given up if I hadn't found this thread in the Hubitat Community: Tuya Zigbee Switch on Hubitat - #18 by mike.maxwell

The problem is that when you first pair this switch it appears as a single device rather than multiple switches. And when you go to the Individual Device set up page for this device, you still see only one device. Any On/Off signals you send to it turn on or off all the child switches, and they cannot be controlled individually.

To fix this you first must change the driver to the "Generic Zigbee Multi-Endpoint Switch" and click CONFIGURE. But that isn't the end of it.

You still cannot see but one device. You must...

1)  Change the driver to:  Generic Zigbee Multi-Endpoint Switch
2)  Save the change,
3)  Click CONFIGURE.  (You still will not be able to see the child devices). 
4)  Save again just to be sure.  
5)  GO ALL THE WAY BACK OUT TO THE MAIN DEVICE PAGE WHERE YOU SEE ALL YOUR DEIVICES IN A LIST.  
6)  REFRESH YOUR BROWSER.
7)  Look up the device in the list.
8)  The device will look something like the image below showing all the sub-switches which can now be individually setup.  

if you post the fingerprint for this device we can get it added to the multi-endpoint switch driver, then future users won't have to manually change and configure the driver....

1 Like

As a man who always has trouble with the obvious, you will have to tell me where the device's fingerprints are seeing that it has no fingers.

1 Like

Change the driver to the "Device" driver, open live logs, then click getInfo, the fingerprint will display in the logs.
Also post a link to the device so I can get a common name for it as well...

So are you saying I should change the driver of this switch from "Generic Zigbee Multi-Endpoint Switch" which is currently working to something called "Device?"

Remember you are talking to Captain Obvious. I understand statements like, "I am currently typing."

yes, then after you get me the fingerprint, change it back, changing it to run this command won't break anything after you change it back when done...

1 Like

OK. I was able to change the driver to "Driver." But I don't see "live logs." Is that in the setup screen for the device or somewhere else?

I was able to find "Zigbee Logging" under Hubitat Settings. Could that be what you're talking about? It shows this for the device:

Go to your device.
Change device type to DEVICE.
Save.
Open a new browser window and log in to your hub.
Select logs at the bottom of the left hand menu. This is LIVE logging.
In your device window click on Get Info.
The 'finger print will appear in live logging.
Change your device back to the original multi enfd point driver.
Post logs here.
Good luck. :+1:

1 Like

Thanks Bobbies. This appears to be what Mike is looking for:

Please let me know if this is right?

1 Like

@mike.maxwell is the above info what you need?

yes

1 Like

Hey guys. I'm experiencing the same issue here, with another 4-channel/gang switch.
Even using the "Generic Zigbee Multi-Endpoint switch" Driver, no child devices appear when clicking configure, and only State Variables bin : 1 appears.
Here is device´s fingerprint:

Somebody can assist-me on put this device up and running?

Thanks!

Each key, when pressed, generates this sequence of information on the log window:

@mike.maxwell

Hi, Mike

I want to get fingerprint info from the log window, but I can't get this infomation so far.
When a new device join to the Hubitat hub, it always show the info as below even if I chnaged the device Type to Generic Zigbee Multiple-Endpoint Switch.

descMap:[raw:catchall: 0000 8005 00 00 0040 00 9449 00 00 0000 00 00 A7004994020102, profileId:0000, clusterId:8005, clusterInt:32773, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:9449, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[A7, 00, 49, 94, 02, 01, 02]]

Please help how can I get right fingerprint info.
Thanks.

@mike.maxwell
My joined device info list as well
manufacturer : _TZ3000_qcgw8qfa

idAsInt : 1

inClusters : 0000,0003,0004,0005,0006

endpointId : 01

profileId : 0104

application : 01

outClusters : 0003,0019,0006

initialized : true

model : TS0002

stage : 4

manufacturer :

idAsInt : 2

inClusters : 0000,0003,0004,0005,0006

endpointId : 02

profileId : 0104

application :

outClusters : 0003,0019,0006

initialized : true

model :

stage : 4

@mike.maxwell
Hi Mike,
Could you help add my device info to Generic Zigbee Multiple-Endpoint Swith driver.
Thanks a lot.

Does it work correctly with that driver?

1 Like

@mike.maxwell
I changed the device type to Generic Zigbee Multiple-Endpoint Switch, it works correctly after change. I can use the web page to control each endpoint, also the states on webpage were updated when device reported its on/off attribute to Hubitat hub.

Thanks.

1 Like

Download the Hubitat app