Zigbee switches not responding to commands

I've been using a C-7 hub in my motorhome for years without issue. Couple of days ago I started having a problem where my zigbee switches are no longer responding to commands. I can see the devices and their state is being reported correctly, but when I send an off/on command they do not work. I can manually toggle the devices by hitting the physical switch on the device and the state updates in Hubitat instantly. But Hubitat is simply not sending commands to the device so none of my rules are working or dashboards function. When I press a button on the dashboard it simply says sending but never changes. I have also tried restarting the hub and powering down the hub for 30 mins then turning it back on to "heal", but no changes. You can see from the logs the devices are communicating but commands just aren't going out. I haven't made any changes to my setup recently.

Platform Version

Please make a screenshot of the Device Details,’Data section.

Have you tried resetting the switch(es) and re-pairing them to Hubitat? For zigbee devices, you can do this without deleting the device on Hubitat.

All looks fine, there are a lot of folks that use these Third Reality plugs… Try pairing again to the hub, as proposed by aaiyar in the post above.

If re-pairing does not help, you can try changing the Zigbee channel. This strange one-way communication problem may be due to WiFi interference from a new wireless router nearby.

P.S. you didn’t mention whether the plugs control works or not from the device web page on/off buttons. so I assumed the problem is not in the dashboard.

1 Like

I just tried repairing this one device and no change. Every single one of my zigbee devices is affected and there are several different manufacturers. Most of the other ones are buried behind cabinets and other hard to reach places so repairing them all will be a nightmare.

This third reality is the only new device I've added and that was done early last week. It has been working fine up until 2-3 days ago. I only noticed because I have a rule that turns it off at night and back on during the day when my solar is charging and I found it still turned on during the previous night, I switched it off manually then it never came back on during the day. At first I thought it was just that one rule broken until I started to notice none of my other devices would respond to the Alexa skill or even when I toggled manually in the dashboard. Nothing happens when I send the commands from the device page either.

I'm in a motorhome pretty far off grid, no other wifi networks anywhere around besides my own. I changed routers about 4 weeks ago when I got a Starlink dish on my roof. But the wifi antenna is on the roof not near the Hubitat. Starlink dish is also on the roof pretty far away as well and mostly turned off since it is just a backup service so is no interference from that as well.

If you unplug it from the mains, are the rest of the devices working?

No. Even if i unplug the third reality plugs, all the other devices are still not working.

Just speaking from experience and not knowledge here, but that is similar to the experience I had with my C-8. I had a bunch of Centralite plugs. They'd act up and I tried everything to get them back on line, but the only thing that worked was cycling power.

I blamed Centralite and went to all Z-Wave except for battery Zigbee devices, but that's not for everyone. :slight_smile:

Anyway, I would suggest cycling the main power breaker.

As I said in my OP, I already tried unplugging the hub for 30 mins to put it in panic mode to heal the network. I've manually unplugged and replugged in a few of the outlets, which made no difference. Plus my plugged in devices get power cycled daily cause my motorhome AC power is turned off for a few hours late at night to perserve power. Hubitat and my router stay on because they are powered directly by DC through a big 12v lithium battery.

I guess I mis-read your OP.
For me, toggling the outlet's switch got it working again. I figured toggling power would do it as well.
For you, toggling the device gets it to report, but it still doesn't respond.